No sound with HDA Intel, VIA VT8237A/VT8251, kernel 3.12

Bug #1265611 reported by hr on 2014-01-02
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ALSA driver
Unknown
Unknown
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

After updating my system to Ubuntu Trusty Tahr (development branch) Release: 14.04
my soundcard VIA Technologies, Inc. VT8237A/VT8251 HDA Controller is not working anymore on the newer kernel (3.12).
After booting an older kernel (3.2) the card is working.

Already tried various options in /etc/modprobe.d/alsa-base.conf,
e.g. options snd-hda-intel probe_mask=1 model=3stack-dig but without success

Configuration infos
lspci: 04:01.0 Audio device: VIA Technologies, Inc. VT8237A/VT8251 HDA Controller

Bad system configuration:
------------------------------
Linux version 3.12.0-7-generic (buildd@aatxe) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-8ubuntu1) ) #15-Ubuntu SMP Sun Dec 8 23:39:27 UTC 2013 (Ubuntu 3.12.0-7.15-generic 3.12.4)

[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.12.0-7-generic root=UUID=cd684c44-c353-4cdf-8242-a865c65b61b3 ro quiet splash vt.handoff=7

[ 21.342849] hda-intel 0000:04:01.0: Using VIACOMBO position fix
[ 21.342893] snd_hda_intel 0000:04:01.0: irq 68 for MSI/MSI-X
[ 22.348029] hda-intel 0000:04:01.0: Codec #0 probe error; disabling it...
[ 27.384025] hda-intel 0000:04:01.0: no codecs initialized

uploded alsa info of bad configuration:
http://www.alsa-project.org/db/?f=c1cebc6d64b60684489e6143a813f529d01bc410

Good system configuration:
--------------------------------
Linux version 3.2.0-56-generic (buildd@roseapple) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #86-Ubuntu SMP Wed Oct 23 09:20:45 UTC 2013 (Ubuntu 3.2.0-56.86-generic 3.2.51)
[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-56-generic root=UUID=cd684c44-c353-4cdf-8242-a865c65b61b3 ro quiet splash vt.handoff=7

[ 23.147203] snd_hda_intel 0000:04:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 23.147262] snd_hda_intel 0000:04:01.0: irq 68 for MSI/MSI-X
[ 23.147292] snd_hda_intel 0000:04:01.0: setting latency timer to 64
[ 26.196033] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x000f0001
[ 27.144807] hda_codec: ALC888: BIOS auto-probing.
[ 27.144813] hda_codec: ALC888: SKU not ready 0x411111f0
[ 27.153432] input: HDA VIA VT82xx Line as /devices/pci0000:00/0000:00:13.0/0000:04:01.0/sound/card0/input7
[ 27.153568] input: HDA VIA VT82xx Mic as /devices/pci0000:00/0000:00:13.0/0000:04:01.0/sound/card0/input8
[ 27.153684] input: HDA VIA VT82xx Front Headphone as /devices/pci0000:00/0000:00:13.0/0000:04:01.0/sound/card0/input9
[ 27.153801] input: HDA VIA VT82xx Line-Out Side as /devices/pci0000:00/0000:00:13.0/0000:04:01.0/sound/card0/input10
[ 27.153914] input: HDA VIA VT82xx Line-Out CLFE as /devices/pci0000:00/0000:00:13.0/0000:04:01.0/sound/card0/input11
[ 27.154022] input: HDA VIA VT82xx Line-Out Surround as /devices/pci0000:00/0000:00:13.0/0000:04:01.0/sound/card0/input12
[ 27.154127] input: HDA VIA VT82xx Line-Out Front as /devices/pci0000:00/0000:00:13.0/0000:04:01.0/sound/card0/input13

uploded alsa info of good configuration:
http://www.alsa-project.org/db/?f=39d8e002614a92b0b9f993e3a9c46c7a5e86ae38

Raymond (superquad-vortex2) wrote :

https://bugzilla.kernel.org/enter_bug.cgi?product=Drivers

do you mean regression ?

there are numerous changes between 3.2.0-56 and 3.12.0-7

try some LiveCD or git bisect

hr (hhancock) wrote :

yes, I think its regression between the two kernels, but I am not sure if this is the root cause.

will try some LiveCDs, but this will take some time.

regards hr

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Raymond (superquad-vortex2) wrote :

you have to file a bug report upstream

lepetit (lacsebastien) wrote :

xubuntu 12.04 , kernel 3.13, i have no sound with this sound chipset

Janet (bugzilla-kerridis) wrote :

Problem seems to persist, Kubuntu 14.10, kernel 3.16.0-24...

Maurizio (maurizio-laurenti) wrote :

I' ve a problem.
If I start Lubuntu 14:04, with main power supply, normal sound from the headphones and no sound from speakers.
Everything is enabled both on alsamixer and pavucontro.
I turn off the laptop and boot from a USB key with Live VectorLinux.
Perfect sound from the speakers
I turn off the laptop, I remove the key, I start again Lubuntu and I' ve perfect sound from the speakers.
Then I restart again, always with the main power supply and sound always perfect.
I turn it off,I take off the main power supply and I restart Lubuntu using the battery and ... no sound from the speakers,from the headphones only.
I repeat the cycle from the start and I always get the same result.
In addition to an exorcism, what can I do?
Best regards.

I can confirm a similar behavior as described in post #7.

1. I installed Ubuntu Studio 15.04 on the harddisk and there was no way to get sound from speakers.
2. I started Ubuntu Studio 12.04.5 from a USB stick with persistence and did all updates.
3. With 12.04.5 initial system and also after update I had sound on speakers.
4. I boot 15.04, with power connected, and there is sound on speakers.
5. I boot 15.04 using the battery, and there is NO sound on speakers.
6. I boot 15.04, with power connected, and there is NN sound on speakers.

7. I go back and can repeat cycle starting at item 3.

I also verified, that when just temporarily removing power cable before step 4, I still have sound in step 4.

mausmaus (maurizio-maurizi) wrote :

Exactly same problem of post #7, Lubuntu 14.04 kernel 4.2.0-36-generic, on HP Netbook HP2133.
no sound from speakers, light sound from headphones.
From live CD (USB installer 14.04) no sound.
Speakers worked perfectly on old 10.04.
Perfect on dual-booted WinXp (sorry!)
Will try Mint.
Any suggestions?
Regards
Maurizio Maurizi

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.