[HP Pavilion Media Center TV m8175.es Desktop PC] Non support for ALC1200 Analog

Bug #1245624 reported by Antoni Bella Pérez on 2013-10-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

  Hello

  I've been using the kernel Linux 3.0.100 kernel, and since then (subsequent versions), I don’t have support analog for this chipset. I ask whether you can solve. Thanks

  Regards
  Toni

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-12-generic 3.11.0-12.19
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: toni 2249 F.... pulseaudio
 /dev/snd/controlC1: toni 2249 F.... pulseaudio
 /dev/snd/controlC0: toni 2249 F.... pulseaudio
Date: Mon Oct 28 19:29:17 2013
HibernationDevice: RESUME=UUID=146689ca-5189-4daa-87d7-b59d90ce4ac6
InstallationDate: Installed on 2013-05-07 (173 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: HP-Pavilion GJ306AA-ABE m8175.es
MarkForUpload: True
ProcEnviron:
 LANGUAGE=ca_AD:ca
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ca_AD.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 nouveaufb
 1 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=UUID=11a5f37e-f23e-4f05-8e78-0e1d97767d70 ro vga=791 acpi_sleep=s3_bios,s3_mode libata.atapi_enabled=1 combined_mode=libata
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-12-generic N/A
 linux-backports-modules-3.11.0-12-generic N/A
 linux-firmware 1.116
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: yes
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to saucy on 2013-10-18 (10 days ago)
dmi.bios.date: 07/11/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 5.05
dmi.board.name: Berkeley
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr5.05:bd07/11/2007:svnHP-Pavilion:pnGJ306AA-ABEm8175.es:pvr:rvnASUSTeKComputerINC.:rnBerkeley:rvr1.xx:cvnHewlett-Packard:ct3:cvrChassisVersion:
dmi.product.name: GJ306AA-ABE m8175.es
dmi.sys.vendor: HP-Pavilion

Antoni Bella Pérez (abella) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.12 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc7-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Antoni Bella Pérez (abella) wrote :

Here I send information from the ALSA Information Script v 0.4.62

http://www.alsa-project.org/db/?f=49a85d336fe00e727855904771447325a657f34f

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: needs-full-computer-model needs-upstream-testing oneiric
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Antoni Bella Pérez (abella) wrote :

Side tag:
- HP-Pavilion PC m8000
- m8175.es

Frontal
- HP Media Center PC

My deduction:
- HP Pavilion Media Center m8175.es Desktop PC

  There are several configurations for the same model.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - Non support for ALC1200 Analog
+ [HP Pavilion Media Center TV m8175.es Desktop PC] Non support for
+ ALC1200 Analog
tags: removed: needs-full-computer-model

Antoni Bella Pérez, thank you for providing the requested information. Could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please just make a comment to this?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Antoni Bella Pérez (abella) wrote :

Yes. Today, 2013-12-17

I see no change. Appears HDMI only.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: trusty
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Antoni Bella Pérez (abella) wrote :

I'm try 3.13.0-031300rc5-generic

ALSA-Info v 0.4.62
http://www.alsa-project.org/db/?f=297a5a14996537475e9fec9ac60771449990c883

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Antoni Bella Pérez, thank you for testing the latest mainline kernel. Just to clarify your Bug Description:
>" I've been using the kernel Linux 3.0.100 kernel, and since then (subsequent versions), I don’t have support analog for this chipset."

Are you noting it worked on the 3.10.x series kernel, but afterward upgrading to 3.11.x it stopped?

tags: added: kernel-bug-exists-upstream-v3.13-rc5
removed: kernel-bug-exists-upstream needs-upstream-testing

Sending to alsa-base as per ubuntu-bug audio workflow. Please re-assign if found to be incorrect.

affects: linux (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: Confirmed → New
Raymond (superquad-vortex2) wrote :

Sysfs Files
!!-----------

/sys/class/sound/hwC0D0/init_pin_configs:
0x11 0x18561170
0x14 0x411111f0
0x15 0x411111f0
0x16 0x411111f0
0x17 0x411111f0
0x18 0x411111f0
0x19 0x411111f0
0x1a 0x411111f0
0x1b 0x411111f0
0x1c 0x411111f0
0x1d 0x411111f0
0x1e 0x411111f0
0x1f 0x411111f0

/sys/class/sound/hwC0D0/driver_pin_configs:

/sys/class/sound/hwC0D0/user_pin_configs:

/sys/class/sound/hwC0D0/init_verbs:

/sys/class/sound/hwC0D0/hints:

!!ALSA/HDA dmesg
!!--------------

[ 9.032725] usb_audio: [5] FU [Mic Capture Volume] ch = 1, val = 4608/7680/1<6>[ 9.032967] usbcore: registered new interface driver snd-usb-audio
[ 9.066009] snd_hda_intel 0000:00:1b.0: irq 43 for MSI/MSI-X
[ 9.114834] hda_codec: ALC1200: SKU not ready 0x411111f0
[ 9.114917] autoconfig: line_outs=0 (0x0/0x0/0x0/0x0/0x0) type:line
--
[ 9.114928] realtek: Enable default setup for auto mode as fallback
[ 9.116492] hda-intel 0000:02:00.1: Handle VGA-switcheroo audio client
[ 9.116536] snd_hda_intel 0000:02:00.1: irq 44 for MSI/MSI-X
[ 9.116572] hda-intel 0000:02:00.1: Disabling 64bit DMA
[ 9.119940] hda-intel 0000:02:00.1: Enable delay in RIRB handling
[ 9.451165] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
[ 10.132075] hda-intel 0000:02:00.1: Codec #1 probe error; disabling it...
[ 10.697843] microcode: CPU0 sig=0x6f7, pf=0x10, revision=0x66
--
[ 11.115801] platform microcode: Falling back to user helper
[ 11.148034] hda-intel 0000:02:00.1: Codec #3 probe error; disabling it...

Raymond (superquad-vortex2) wrote :

https://bugzilla.kernel.org/enter_bug.cgi?product=Drivers

report the bug in kernel with your two alsa-info

http://www.alsa-project.org/db/?f=49a85d336fe00e727855904771447325a657f34f

http://www.alsa-project.org/db/?f=297a5a14996537475e9fec9ac60771449990c883

it is strange that alc1200 have no pin complexes for analog playback and capture

how many audio jacks , internal speakers or Mic ?

Node 0x11 [Pin Complex] wcaps 0x400300: Mono Digital
  Control: name="HDMI Phantom Jack", index=0, device=0
  Pincap 0x00000010: OUT
  Pin Default 0x18561170: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Black
    DefAssociation = 0x7, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x10

Raymond (superquad-vortex2) wrote :

try hda Jack sense test to find out the node of the jacks of front and rear panels by plugged in them one by one

Raymond (superquad-vortex2) wrote :

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/sound/pci/hda/patch_realtek.c?id=67b6ec3196da235317ff1b9474f17379b78f3294

send email to the author to add a 6stack_digout_digin_automute for your alc1200

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01127593&tmp_track_link=ot_faqs/top_issues/en_us/c01127593/loc:2&cc=us&dlc=en&lc=en&product=3464130#N1069

2 - Coaxial SPDIF Out
4 - Audio: Rear Speaker Out (black)
5 - Audio: Center/Subwoofer (yellow orange)
6 - Audio: Line In (light blue)
7 - Audio: Line Out (lime)
8 - Audio: Microphone (pink)
9 - Audio: Side Speaker Out (gray)
13 - Coaxial SPDIF In

Antoni Bella Pérez (abella) wrote :

Reply to: Christopher M. Penalver (penalvch) wrote on 2013-12-24

No, not working

Reply to: Raymond (superquad-vortex2):

Need help with more information? What package version should I try?

Raymond (superquad-vortex2) wrote :

you have to send email to tiwai with your alsa-info , your BIOS doest not set any pin complex and need a new model for 6 audio Jack at rear panel, digital out and digital in , front audio panel headphone and Michael support Jack detection

Raymond (superquad-vortex2) wrote :

e.g. 0x17 0x01012014

Node 0x17 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals: [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals: [0x00 0x00]
  Pincap 0x00000036: IN OUT Detect Trigger
  Pin Default 0x01012014: [Jack] Line Out at Ext Rear
    Conn = 1/8, Color = Grey
    DefAssociation = 0x1, Sequence = 0x4

Antoni Bella Pérez (abella) wrote :

  I'm not a programmer. Nothing.

  I understand that this report contains all information needed.

  What is the email for tiwai? -- I guess this is the name of an user.

Raymond (superquad-vortex2) wrote :

http://voices.canonical.com/david.henningsson/2011/11/29/turn-your-mic-jack-into-a-headphone-jack/

check advanced override and show not connected checkbox

fix the four lineout , front Mic, rear mic , line in , headphone, optical out and in jacks with correct color , default associtation, location ,.....

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Raymond (superquad-vortex2) wrote :

https://launchpadlibrarian.net/161839693/AlsaInfo.txt

0x11 0x18561130 except this is [Jack] Digital Out at Int HDMI Conn = Digital, Color = Black DefAssociation = 0x3, Sequence = 0x0 Misc = NO_PRESENCE
0x14 0x01014010
0x15 0x01012014
0x16 0x01016011
0x17 0x01011012
0x18 0x01a19840
0x19 0x02a19850
0x1a 0x0181304f
0x1b 0x0221401f
0x1c 0x411111f0
0x1d 0x4005ce01
0x1e 0x01441120 [Jack] SPDIF Out at Ext Rear Conn = RCA, Color = Black DefAssociation = 0x2, Sequence = 0x0 Misc = NO_PRESENCE
0x1f 0x01c46160

Raymond (superquad-vortex2) wrote :

try hda-jack-sense-test to find out the node when you plugged and unplugged the analog jack one by one

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers