[Acer AO722] Internal microphone don't work

Bug #1245020 reported by Sushenjit Bandyopadhyay on 2013-10-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Unassigned

Bug Description

The "Mic Boost" setting in Alsamixer reverts to zero after each boot and the microphone stops working until alsamixer setting is changed again.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-12-generic 3.11.0-12.19
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: sushenjit 2368 F.... pulseaudio
 /dev/snd/pcmC1D0p: sushenjit 2368 F...m pulseaudio
 /dev/snd/controlC0: sushenjit 2368 F.... pulseaudio
Date: Sat Oct 26 13:13:55 2013
HibernationDevice: RESUME=UUID=67e8714a-d8e0-422e-b9fb-f41ebf64d499
InstallationDate: Installed on 2012-05-20 (524 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
Lsusb:
 Bus 002 Device 004: ID 04f2:b209 Chicony Electronics Co., Ltd
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Acer AO722
MarkForUpload: True
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=UUID=b42fc94e-bbb7-444d-a5e8-25218dfc4101 ro elevator=noop quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-12-generic N/A
 linux-backports-modules-3.11.0-12-generic N/A
 linux-firmware 1.116
SourcePackage: linux
UpgradeStatus: Upgraded to saucy on 2013-10-23 (3 days ago)
dmi.bios.date: 12/06/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.08
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JE10-BZ
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.08
dmi.modalias: dmi:bvnAcer:bvrV1.08:bd12/06/2011:svnAcer:pnAO722:pvrV1.08:rvnAcer:rnJE10-BZ:rvrBaseBoardVersion:cvnAcer:ct10:cvrV1.08:
dmi.product.name: AO722
dmi.product.version: V1.08
dmi.sys.vendor: Acer
---
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: sushenjit 2437 F.... pulseaudio
 /dev/snd/pcmC1D0p: sushenjit 2437 F...m pulseaudio
 /dev/snd/controlC0: sushenjit 2437 F.... pulseaudio
DistroRelease: Ubuntu 13.10
HibernationDevice: RESUME=UUID=67e8714a-d8e0-422e-b9fb-f41ebf64d499
InstallationDate: Installed on 2012-05-20 (527 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
Lsusb:
 Bus 002 Device 002: ID 04f2:b209 Chicony Electronics Co., Ltd
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Acer AO722
MarkForUpload: True
NonfreeKernelModules: fglrx
Package: linux (not installed)
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=UUID=b42fc94e-bbb7-444d-a5e8-25218dfc4101 ro elevator=noop quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-12-generic N/A
 linux-backports-modules-3.11.0-12-generic N/A
 linux-firmware 1.116
Tags: saucy
Uname: Linux 3.11.0-12-generic i686
UpgradeStatus: Upgraded to saucy on 2013-10-23 (6 days ago)
UserGroups: adm cdrom dip disk lpadmin plugdev sambashare sudo
WifiSyslog: Oct 29 07:41:58 Arthur NetworkManager[1048]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
dmi.bios.date: 09/25/2012
dmi.bios.vendor: Acer
dmi.bios.version: V1.11
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JE10-BZ
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.11
dmi.modalias: dmi:bvnAcer:bvrV1.11:bd09/25/2012:svnAcer:pnAO722:pvrV1.11:rvnAcer:rnJE10-BZ:rvrBaseBoardVersion:cvnAcer:ct10:cvrV1.11:
dmi.product.name: AO722
dmi.product.version: V1.11
dmi.sys.vendor: Acer

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: bios-outdated-v1.11 needs-upstream-testing regression-potential
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

Christopher M. Penalver Thank you very much for your prompt response and suggestion to update the BIOS. I have updated to BIOS 1.11 and it has solved the problem. In other words, the microphone works after the BIOS update.

The internal microphone works with BIOS updated to 1.11, the latest at the time of writing.

Changed in linux (Ubuntu):
status: Incomplete → Invalid

apport information

Changed in linux (Ubuntu):
status: Invalid → Incomplete
tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

The "Mic Boost" setting in Alsamixer reverts to zero after each boot and the microphone stops working until alsamixer setting is changed again.

Sushenjit Bandyopadhyay, ok. As per ubuntu-bug audio workflow sending to alsa-base.

tags: added: latest-bios-v1.11
removed: bios-outdated-v1.11 needs-upstream-testing
description: updated
Changed in linux (Ubuntu):
importance: Medium → Low
status: Incomplete → New
affects: linux (Ubuntu) → alsa-driver (Ubuntu)
Raymond (superquad-vortex2) wrote :

does so722 really support headset Mic, Mic Jack and internal ?

: Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic' 'Internal Mic' 'Mic 1'
  Item0: 'Internal Mic'

Node 0x1a [Pin Complex] wcaps 0x400481: Stereo
  Control: name="Mic Jack", index=1, device=0
  Pincap 0x00001324: IN Detect
    Vref caps: HIZ 50 80
  Pin Default 0x03a1103e: [Jack] Mic at Ext Left
    Conn = 1/8, Color = Black
    DefAssociation = 0x3, Sequence = 0xe
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=04, enabled=1
  Power states: D0 D1 D2 D3 D3cold EPSS
  Power: setting=D0, actual=D0
Node 0x1b [Pin Complex] wcaps 0x400581: Stereo
  Control: name="Mic Jack", index=0, device=0
  Pincap 0x00011334: IN OUT EAPD Detect
    Vref caps: HIZ 50 80
  EAPD 0x2: EAPD
  Pin Default 0x03a19030: [Jack] Mic at Ext Left
    Conn = 1/8, Color = Pink
    DefAssociation = 0x3, Sequence = 0x0
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=02, enabled=1
  Power states: D0 D1 D2 D3 D3cold EPSS
  Power: setting=D0, actual=D0
  Connection: 2
     0x10* 0x11

Node 0x1e [Pin Complex] wcaps 0x400481: Stereo
  Control: name="Internal Mic Phantom Jack", index=0, device=0
  Pincap 0x00000024: IN Detect
  Pin Default 0x95a70120: [Fixed] Mic at Int Top
    Conn = Analog, Color = Unknown
    DefAssociation = 0x2, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x20: IN
  Unsolicited: tag=00, enabled=0
  Power states: D0 D1 D2 D3 D3cold EPSS
  Power: setting=D0, actual=D0

there are three mic but only two boost volume control

if the driver share the Mic boost control between three Mic, you need a new name for this kind of Mic boost

:: Node 0x17 [Audio Selector] wcaps 0x30050d: Stereo Amp-Out
  Control: name="Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
  Amp-Out vals: [0x00 0x00]
  Power states: D0 D1 D2 D3 D3cold EPSS
  Power: setting=D0, actual=D0
  Connection: 4
     0x1a 0x1b* 0x1d 0x1e
Node 0x18 [Audio Selector] wcaps 0x30050d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
  Amp-Out vals: [0x00 0x00]
  Power states: D0 D1 D2 D3 D3cold EPSS
  Power: setting=D0, actual=D0
  Connection: 4
     0x1a* 0x1b 0x1d 0x1e

Raymond: Where is the "Mic boost volume?"

My analog-input.conf.common reads partially:
;;; Various Boosts

[Element Capture Boost]
switch = select

[Option Capture Boost:on]
name = input-boost-on

[Option Capture Boost:off]
name = input-boost-off

Thanks

Raymond (superquad-vortex2) wrote :

what you need is to not switch off Mic boost in

http://cgit.freedesktop.org/pulseaudio/pulseaudio/tree/src/modules/alsa/mixer/paths/analog-input-internal-mic.conf

if internal Mic and external mic share mic boost

[Element Mic Boost]
switch = off
volume = off

Raymond, when I change Element Mic Boost switch in analog-input-internal-mic.conf to

[Element Mic Boost]
switch = on
volume = on

My Internal Microphone Input disappears in Sound Settings Input tab. See attached 'No Internal Mic.png'.

Thanks

Raymond, when I change Element Mic Boost switch in analog-input-internal-mic.conf back to

[Element Mic Boost]
switch = off
volume = off

Raymond, I am attaching the contents of the folder 'path'. I hope it helps diagnose the problem.

Raymond (superquad-vortex2) wrote :

you still not tell me whether your ao722 support headset Mic or not ?

auto Mic in driver is automatically disabled when there are three mics and they are not dock Mic, ext mic and int Mic which have known priority

Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic' 'Internal Mic' 'Mic 1'
  Item0: 'Internal Mic'

have you found the node (0x1a or 0x1b) of ext mic using hda-jack-sense-test ? the state of the node change to yes

use hda-jack-retask to change the pin default of the headset Mic node from [Jack] to [N/A] if ao722 does not support headset Mic

Raymond (superquad-vortex2) wrote :

if your ao722 really support headset mic

for example if the value of node 0x1b change to yes when you plug the external mic, change the sequence of node 0x1a to 0x0d

http://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/?id=cb420b1186e0090f24137855e14e6f3bf7cb769d

Raymond (superquad-vortex2) wrote :

the sequence should be changed to 0x0c

+#define HDA_PINCFG_HEADSET_MIC (1 << 2) /* Try to find headset mic; mark seq number as 0xc to trigger */
+#define HDA_PINCFG_HEADPHONE_MIC (1 << 3) /* Try to find headphone mic; mark seq number as 0xd to trigger */

Raymond, thanks for your response. I am not sure I understand your question and how to answer it. What is a headset mic? AO722 has an external microphone socket next to a headphone socket. Do you mean that it could support a phone headset with a microphone with a single 3.5 pin? Or do you mean an USB or Bluetooth headset? The AO722 does not have bluetooth built in, and I don't have an USB headset to test.

I looked at the git.kernel.org URL page you linked above but couldn't figure out what to do with the patch/code. Do I need to compile it? If so, how?

Two questions:

1. How do I test if AO722 supports headset mic?

2. How to check if the value of node 0x1b change to yes when i plugin an external microphone in to the microphone socket?

Please indicate what commands I need to type in the terminal or which file I should check.

Thanks

Raymond (superquad-vortex2) wrote :

if the user manual did not mention that you can use headset Mic (with TRRS connector), you only need to remove the reduandant Mic Jack by hda-jack-retask

Raymond (superquad-vortex2) wrote :

plug Mic into the Mic jack

hda-jack-sense-test -a

Raymond, here are the output of hda-jack-sense-test -a with no external mic in the mic jack

$ sudo hda-jack-sense-test -a
Pin 0x03 (Unknown Digital Out): present = No

And now with the mic plugged in the mic jack:
$ sudo hda-jack-sense-test -a
Pin 0x03 (Unknown Digital Out): present = No

There is no change! What does this mean?

Thanks.

Raymond,

I couldn't find hda-jack-retask, the command line version. Instead I found the hdajackretask (GUI), A screenshot is attached.

How do I use this to remove the redundant Mick Jack?

Raymond (superquad-vortex2) wrote :

you have to specify card 1 since your Cx20588 is card 1

 hda-jack-sense-test.py -a (see -h for switches to set codec and card indices).

Raymond, here is the new output.

Without mic in jack
$ sudo hda-jack-sense-test -c 1 -a
Pin 0x19 (Black HP Out): present = No
Pin 0x1a (Black Mic): present = No
Pin 0x1b (Pink Mic): present = No
Pin 0x1c (Not connected): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Internal Mic): present = No
Pin 0x1f (Internal Speaker): present = No
Pin 0x20 (Not connected): present = No
Pin 0x22 (Not connected): present = No
Pin 0x23 (Not connected): present = No

With pic plugged into the external mic jack:
$ sudo hda-jack-sense-test -c 1 -a
Pin 0x19 (Black HP Out): present = No
Pin 0x1a (Black Mic): present = No
Pin 0x1b (Pink Mic): present = Yes
Pin 0x1c (Not connected): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Internal Mic): present = No
Pin 0x1f (Internal Speaker): present = No
Pin 0x20 (Not connected): present = Yes
Pin 0x22 (Not connected): present = No
Pin 0x23 (Not connected): present = No

Raymond, There is no mention of headset mic and or TRRS connector in the AO722 manual. I don't think this netbook has connections for the headset mic.

Thanks

Raymond (superquad-vortex2) wrote :

do you mean you cannot select Conexant CX20588 in the drop down combo box in hdajackretask

git.alsa-project.org/?p=alsa-tools.git;a=blob;f=hdajackretask/README;hb=HEAD

check show adavnced overrite box and change node 0x1a to [N/A/ instead of [Jack]

do you need inv mic fix ? (i.e. mute the right channels is the left and right channels your mic are out of phase ) ?

Raymond, I didn't know what to do with the hdajackretask app. Thanks for the link and specific instructions. I will try these when I get home tonight.

Thanks again Raymond! I followed your instructions and it worked!! A new screenshot of hdajackretask is attached showing the new settings. I don't think I need the inv mic fix. How to check?

Thanks again.

To post a comment you must log in.