macbook air 2,1 no sound

Bug #1181828 reported by Le Gluon Du Net on 2013-05-19
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ALSA driver
Unknown
Unknown
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

Hello,

I installed Ubuntu raring 13.04 on a Macbook Air 2,1 and I have no sound. The card is recognized by alsamixer and pulseaudio. I put the volume to the maximum, put all the mixer unmute in alsamixer, no sound at all.

Thanks for your help.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: alsa-base 1.0.25+dfsg-0ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-21.32-generic 3.8.8
Uname: Linux 3.8.0-21-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rom1 1493 F.... pulseaudio
CurrentDmesg: [ 8.408776] NVRM: GPU at 0000:02:00: GPU-e1116370-0337-a0c6-6dce-80e73ebd884a
Date: Sun May 19 20:29:36 2013
InstallationDate: Installed on 2013-05-19 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/14/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA21.88Z.0075.B03.0811141325
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F42D88C8
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F42D88C8
dmi.modalias: dmi:bvnAppleInc.:bvrMBA21.88Z.0075.B03.0811141325:bd11/14/08:svnAppleInc.:pnMacBookAir2,1:pvr1.0:rvnAppleInc.:rnMac-F42D88C8:rvr:cvnAppleInc.:ct10:cvrMac-F42D88C8:
dmi.product.name: MacBookAir2,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Le Gluon Du Net (legluondunet) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Paul (treepata) wrote :

For what it is worth, the exact same problem also surfaces on the Macbook Air 1,1. Everything seems to be working fine; sound card is recognised and alsamixer shows the various channels as active and unmuted. But no sound comes out of the speakers.

The problem for the Macbook Air 1,1 is reported on various sites, among here: http://ubuntuforums.org/showthread.php?t=2141179

Raymond (superquad-vortex2) wrote :

try hda-jack-sense-test to find out the headphone and mic jack by plug and unplug the headphone and mic

!!Sysfs Files
!!-----------

/sys/class/sound/hwC0D0/init_pin_configs:
0x14 0x01214030
0x15 0x400000f0
0x16 0x400000f0
0x17 0x400000f0
0x18 0x90100120
0x19 0x400000f0
0x1a 0x400000f0
0x1b 0x400000f0
0x1c 0x400000f0
0x1d 0x400000f0
0x1e 0x400000f0
0x1f 0x400000f0

/sys/class/sound/hwC0D0/driver_pin_configs:

Le Gluon Du Net (legluondunet) wrote :

Bug is still present in Ubuntu 13.10

tags: added: saucy
Le Gluon Du Net (legluondunet) wrote :

#dmesg |grep codec
[ 5.949588] hda_codec: ALC889A: SKU not ready 0x400000f0

Raymond (superquad-vortex2) wrote :

sku not ready I'd not any error

have you try hda-jack-sense-test -tryallpins to find out the missing Mic jack and verify the headphone Jack is node 0x14

Le Gluon Du Net (legluondunet) wrote :

Raymond, this is the test result:

#hda-jack-sense-test -a
Pin 0x14 (Green HP Out): present = No
Pin 0x15 (Not connected): present = No
Pin 0x16 (Not connected): present = No
Pin 0x17 (Not connected): present = No
Pin 0x18 (Internal Speaker): present = No
Pin 0x19 (Not connected): present = No
Pin 0x1a (Not connected): present = No
Pin 0x1b (Not connected): present = No
Pin 0x1c (Not connected): present = No
Pin 0x1d (Not connected): present = No
Pin 0x1e (Not connected): present = No
Pin 0x1f (Not connected): present = No

This bug needs to be forwarded upstream (https://wiki.ubuntu.com/Bugs/HowToTriage#Forwarding_upstream).

Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
acidjunk (acidjunk) wrote :

I'm running in the same problem as the other users. Running 13.04 on Macbook air 1.1.

Is there anything I can do to help? I did read the upstream wiki page; but i'm not sure how to continue.

acidjunk, the only thing needed for marking this bug as ready to be worked on is this:

1. Search if the bug has already been reported in http://www.debian.org/Bugs/.
2. If it hasn't, report it following these instructions: http://www.debian.org/Bugs/Reporting.
3. Here in Launchpad, at the beginning of this report , unfold the flange preceding "ALSA driver".
3. In the unfolded parameters, in the field "URL", paste the URL where the report for Debian is already written.

This will take you no more than 15 minutes.

Thank you ☕

Raymond (superquad-vortex2) wrote :

did availability of analog-output-headphone change to yes when you plugged the headphone ?

pactl list sinks

ports:
  analog-output-speaker: Haut-parleurs (priority 10000, latency offset 0 usec, available: unknown)
   properties:
    device.icon_name = "audio-speakers"
  analog-output-headphones: Casques analogiques (priority 9000, latency offset 0 usec, available: no)
   properties:
    device.icon_name = "audio-headphones"

http://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/plain/Documentation/sound/alsa/HD-Audio.txt

study the following section and try hda-analyzer to toggle gpio

Speaker and Headphone Output
~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Le Gluon Du Net (legluondunet) wrote :

I tried the new Ubuntu 3.13 kernel, still no sound.
I opened a bug on kernel bug tracker:
https://bugzilla.kernel.org/show_bug.cgi?id=65681

Changed in alsa-driver:
importance: Undecided → Unknown
status: New → Unknown
Changed in alsa-driver (Ubuntu):
status: Confirmed → Triaged
Le Gluon Du Net (legluondunet) wrote :

Finally resolved for me in kernel 3.13, look here:
https://bugzilla.kernel.org/show_bug.cgi?id=65681

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.