Ubuntu

[Inspiron 5523, IDT 92HD91BXX, Speaker, Internal] Playback problem: sound only works in headphones

Reported by Vyacheslav on 2013-02-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Just bought Dell Inspiron 15z 5523. Sound worked fine in Windows 8.
After installing Ubuntu 12.04 64bit, sound only works through headphones. Built in speakers are silent.
====
I checked usual solutions:
alsamixer, audio controls (and pavucontrol)
====
tried to add records in /etc/modprobe.d/alsa-base.conf like:
options snd-hda-intel model=auto
====
tried to use following kernel versions:
3.6.0
3.7.0
3.7.9
3.8.0
3.8.0 from daily folder

with some of them interface (and sudo command in terminal) got frozen.
with all of them speakers and wi-fi haven`t worked.
========
~$ lsb_release -rd
Description: Ubuntu 12.04.2 LTS
Release: 12.04

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-25.38~precise1-generic 3.5.7.4
Uname: Linux 3.5.0-25-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: vyacheslav 1771 F.... pulseaudio
 /dev/snd/pcmC0D0p: vyacheslav 1771 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7e10000 irq 44'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:111d76e0,1028058f,00100303 HDA:80862806,80860101,00100000'
   Controls : 24
   Simple ctrls : 11
Date: Sat Feb 23 00:21:19 2013
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_Jack: Speaker, Internal
Symptom_Type: Only some of outputs are working
Title: [Inspiron 5523, IDT 92HD91BXX, Speaker, Internal] Playback problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/20/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: 0RK83G
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd08/20/2012:svnDellInc.:pnInspiron5523:pvrNotSpecified:rvnDellInc.:rn0RK83G:rvrA00:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Inspiron 5523
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.
modified.conffile..etc.modprobe.d.alsa.base.conf: [modified]
mtime.conffile..etc.modprobe.d.alsa.base.conf: 2013-02-22T22:46:29.041626

Vyacheslav (madboy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Simon Schneider (s-schne) wrote :

Hi,

a bios update from A00 to A03 fixed this for me.

Vyacheslav (madboy) wrote :

Hello,

thanks for a tip. But I won`t risk updating bios, as worst-case scenario is not acceptable.
I`ll be hoping for another solution.

loblik (lobl-pavel) wrote :

Hi,

updating bios worked for me too. Bios flashed with 5523A05.

Patrick (psp294) wrote :

Hi,

updating the bios from A00 to A05 worked for me too. Unfortnately I had to boot from a Windows Vista Installation CD to do this (Freedos and ReactOS won't start).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers