Ubuntu

High noise recording with internal microphone on Thinkpad Edge 13

Reported by David on 2013-02-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

I get a high noise using the internal microphone.

My computer is the Thinkpad Edge 13. The information about my system can be found here:
http://www.alsa-project.org/db/?f=caa4f278baae73257cec7816c72eedcbe977468e

The microphone works with really low volume. Setting the volume at max makes the noise unbearable. I have tried the inverted internal microphone fix shown here: http://voices.canonical.com/david.henningsson/2012/05/22/three-audio-bugs-in-12-04/ and the audio ppa https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules without success.

I have also tried and in the Windows included the sound works as expected without that much noise.

The noise is "like a hoover".

I'm available to any testing or to add further information.

Raymond (superquad-vortex2) wrote :

unsolicited event should not be enabled on internal Mic which does not support Jack detection Misc = NO_PRESENCE

Node 0x1a [Pin Complex] wcaps 0x400481: Stereo
  Pincap 0x00001324: IN Detect
    Vref caps: HIZ 50 80
  Pin Default 0x95a701f0: [Fixed] Mic at Int Top
    Conn = Analog, Color = Unknown
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=38, enabled=1
  Power states: D0 D1 D2 D3 D3cold
  Power: setting=D0, actual=D0

David (davisein-registro) wrote :

Ok, that seems promising. How can I fix it?

And some more info.

I do not have a jack for microphone but the headset jack that is present should support microphone too. I have plugged in a phone headset but I hear some noise. If I change the channels to only make sound on the right or the left the noise disappears.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed

I have same problem, The mic is very noisy, but in Win there is no problem with mic.
it sounds like mic is boosted, I used alsamixer to set down the boost but noise presist but with lower volume.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers