ASUS Xonar U3 volume slider problem

Bug #1077829 reported by Denis Washington on 2012-11-12
This bug affects 9 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)

Bug Description

I got an ASUS Xonar U3 USB sound card for my Thinkpad T420 for my birthday this year and tried to use it on Ubuntu 12.10. Unfortunately, its sound output is either bearably noticeable or - if I increase the volume by even the slightest notch with the audio indicator - EXTREMELY loud (and, because I use earphones, pretty painfully so).

I did some experiments with alsamixer, and it seems as if the complete volume range that I would expect to be stretched over the complete slider is compressed in the PCM levels between 1 and ~7. This means the only way I can sanefully use the USB sound card right now is by turning the volume in each application very, very low so that I have some amount of precision with the global volume slider (which I can control with function keys), but every time I forget this somewhere, it's a pretty painful surprise, so I hope this can be fixed.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: alsa-base 1.0.25+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Mon Nov 12 08:19:30 2012
InstallationDate: Installed on 2012-09-09 (63 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MarkForUpload: True
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: alsa-driver
Symptom: audio
Symptom_Card: USB Advanced Audio Device - USB Advanced Audio Device
Symptom_Type: Volume slider, or mixer problems
Title: [USB-Audio - USB Advanced Audio Device, playback] volume slider problem
UpgradeStatus: Upgraded to quantal on 2012-10-18 (24 days ago) 06/12/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 83ET70WW (1.40 )
dmi.board.asset.tag: Not Available 4180PH1
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr83ET70WW(1.40):bd06/12/2012:svnLENOVO:pn4180PH1:pvrThinkPadT420:rvnLENOVO:rn4180PH1:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable: 4180PH1
dmi.product.version: ThinkPad T420
dmi.sys.vendor: LENOVO

Denis Washington (dwashington) wrote :
Raymond (superquad-vortex2) wrote :

how about the patch which disable spdif ?

Denis Washington (dwashington) wrote :

I don't use S/PDIF, I have regular earphones plugged in. I don't see how that should be related.

Denis Washington (dwashington) wrote :

I need to take this back: I installed the Xonar U3 driver under Windows and after a restart, S/PDIF is also available under Ubuntu; this output option features normal volume control over the whole percentage range. So I guess the kernel patch to turn on S/PDIF would have fixed my problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Denis Washington (dwashington) wrote :

Has the kernel patch that Raymond pointed to been added upstream? Unfortunately, the Windows driver only enables S/PDIF on the card until the Xonar U3 is unplugged, so there isn't even a workable workaround.

Denis Washington (dwashington) wrote :

I have reported the problem upstream (in the alsa-devel list) and submitted the S/PDIF patch found in Since then, Linus has merged the change for the 3.8-rc1 kernel:;a=commit;h=046e7d685bc370fd4c879ab6635ad3f69e6673d1;a=commit;h=1d31affbef40cea4958da03cf6ec3cea1c7f801e

Considering the change is trivial and this USB sound card model seems to be relatively popular, it might be worth to backport it. I'm using it on Ubuntu 12.10 (self compiled 3.5.0-19-generic Ubuntu kernel) for quite a while without problems.

David Kolibáč (david-kolibac) wrote :

I'm experiencing the same issue on Kubuntu 13.04 with 3.8.0-29-generic kernel.

Henrik S. (henrik-hw0) wrote :

I have this problem on Ubuntu 14.10 utopic unicorn. Regression???

Valentin Crone (va-crone) wrote :

I have this problem on Ubuntu 14.04 LTS, with Linux 3.18.1 (or official Ubuntu kernel), this bug is always existent 2years later? :o

Valentin Crone (va-crone) wrote :

I have tried my Xonar U3 on Android X86 (on my computer), and the volume slider work properly, but it doesn't work properly on Ubuntu 14.04 with Linux 3.18.1.

Valentin Crone (va-crone) wrote :

PS: Android X86 4.4.4 with Linux 3.18
And Ubuntu 64bits.

Valentin Crone (va-crone) wrote :

On Ubuntu 14.04 LTS, I have tested a new card (in remplacement of my Xonar U3):
Terratec Aureon Dual USB
And I have exactly the same bug !!!

An USB sound card who working with Ubuntu exists? :o

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete

This issue has sat incomplete for more than 60 days now. I'm going to close it as invalid. Please feel free re-open if this is still an issue for you. Thank you.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-alsa-devel Edit

Bug watches keep track of this bug in other bug trackers.