Ubuntu

[CS46xx - Sound Fusion CS46xx, playback] fails after a while

Reported by stef@no on 2012-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

to tell the thruth, is several years and several ubuntu versions I can't find peace with sound. In the past I was able to ear one song moving the volume cursor (but I had to repeat it for each song). Now I can ear just some second of music followed by silence.
Thank in advance

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic-pae 3.2.27
Uname: Linux 3.2.0-30-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu13
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: CS46xx [Sound Fusion CS46xx], device 0: CS46xx [CS46xx]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: stefano 20593 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'CS46xx'/'Sound Fusion CS46xx at 0xda000000/0xd9800000, irq 10'
   Mixer name : 'Cirrus Logic CS4294 rev 5,Cirrus Logic CS4294 rev 5,Cirrus Logic CS4294 rev 5'
   Components : 'AC97a:4352592d AC97m:4352592d'
   Controls : 60
   Simple ctrls : 43
Date: Fri Sep 7 19:54:55 2012
PackageArchitecture: all
ProcEnviron:
 TERM=screen-bce
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_Card: Audio interno - Sound Fusion CS46xx
Symptom_Type: Sound works for a while, then breaks
Title: [CS46xx - Sound Fusion CS46xx, playback] fails after a while
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/13/2003
dmi.bios.vendor: Award Software, Inc.
dmi.bios.version: ASUS A7A266 ACPI BIOS Revision 1013 Beta 001
dmi.board.name: A7A266
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: REV 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 7
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAwardSoftware,Inc.:bvrASUSA7A266ACPIBIOSRevision1013Beta001:bd08/13/2003:svnSystemManufacturer:pnSystemName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnA7A266:rvrREV1.xx:cvnChassisManufacture:ct7:cvrChassisVersion:
dmi.product.name: System Name
dmi.product.version: System Version
dmi.sys.vendor: System Manufacturer

stef@no (stefano-papo) wrote :
Raymond (superquad-vortex2) wrote :

which 4.1 surround speaker do you have and how many audio jacks (green/back) ?

cs4630 require firmware to support multi-channels

can you post the verbose pulseaudio log?

since cs46xx use multi plugin to use three stereo device 0,1,3 for surround5.1

  device.string = "surround41:0"
  device.buffering.buffer_size = "163840"
  device.buffering.fragment_size = "5120"
  device.access_mode = "mmap+timer"
  device.profile.name = "analog-surround-41"
  device.profile.description = "Surround analogico 4.1"
  device.description = "Audio interno Surround analogico 4.1"

**** List of PLAYBACK Hardware Devices ****
card 0: CS46xx [Sound Fusion CS46xx], device 0: CS46xx [CS46xx]
  Subdevices: 31/31
card 0: CS46xx [Sound Fusion CS46xx], device 1: CS46xx - Rear [CS46xx - Rear]
  Subdevices: 31/31
card 0: CS46xx [Sound Fusion CS46xx], device 2: CS46xx - IEC958 [CS46xx - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CS46xx [Sound Fusion CS46xx], device 3: CS46xx - Center LFE [CS46xx - Center LFE]
  Subdevices: 31/31

first of all, thank you for aswering and please, forgive my very bad
english :-(

On 08/09/2012 02:15, Raymond wrote:
> which 4.1 surround speaker do you have and how many audio jacks
> (green/back) ?
I have not 4.1 system, but just 2.1 Creative Soundworks SW310.
Unfortunately I can't find the setting for this equipment in ubunt
softwares. A green jack start from surround speaker ending in the desk
rack of my Hercules Game Theater XP
(http://ixbtlabs.com/articles/herculesgametheaterxp/index.html)
from this rack start a very complex cable connecting the real audio card
in the case.

> cs4630 require firmware to support multi-channels
> can you post the verbose pulseaudio log?
well, I hope I have followed correctly the instructions because it's
really disappointing:

pulseaudio: unrecognized option '--log-timeLANG=C'
E: [pulseaudio] main.c: Failed to parse command line.

But a news happens trying pulseaudio: now the song is not interrupted
but the sound level is very very low.
how can I proceed?
Thanks in advance

Stefano Cocchia

>
> since cs46xx use multi plugin to use three stereo device 0,1,3 for
> surround5.1
>
>
> device.string = "surround41:0"
> device.buffering.buffer_size = "163840"
> device.buffering.fragment_size = "5120"
> device.access_mode = "mmap+timer"
> device.profile.name = "analog-surround-41"
> device.profile.description = "Surround analogico 4.1"
> device.description = "Audio interno Surround analogico 4.1"
>
> **** List of PLAYBACK Hardware Devices ****
> card 0: CS46xx [Sound Fusion CS46xx], device 0: CS46xx [CS46xx]
> Subdevices: 31/31
> card 0: CS46xx [Sound Fusion CS46xx], device 1: CS46xx - Rear [CS46xx - Rear]
> Subdevices: 31/31
> card 0: CS46xx [Sound Fusion CS46xx], device 2: CS46xx - IEC958 [CS46xx - IEC958]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> card 0: CS46xx [Sound Fusion CS46xx], device 3: CS46xx - Center LFE [CS46xx - Center LFE]
> Subdevices: 31/31
>

stef@no (stefano-papo) wrote :
Download full text (4.5 KiB)

first of all, thank you for aswering and please, forgive my very bad
english :-(

On 08/09/2012 02:15, Raymond wrote:
 > which 4.1 surround speaker do you have and how many audio jacks
 > (green/back) ?
I have not 4.1 system, but just 2.1 Creative Soundworks SW310.
Unfortunately I can't find the setting for this equipment in ubuntu
softwares. A green jack start from surround speaker ending in the desk
rack of my Hercules Game Theater XP
(http://ixbtlabs.com/articles/herculesgametheaterxp/index.html)
from this rack start a very complex cable connecting the real audio card
in the case.

 > cs4630 require firmware to support multi-channels
 > can you post the verbose pulseaudio log?
well, I hope I have followed correctly the instructions because it's
really disappointing:

pulseaudio: unrecognized option '--log-timeLANG=C'
E: [pulseaudio] main.c: Failed to parse command line.

But a news happens trying pulseaudio: now the song is not interrupted
but the sound level is very very low.
how can I proceed?
Thanks in advance

Stefano Cocchia

 >
 > since cs46xx use multi plugin to use three stereo device 0,1,3 for
 > surround5.1
 >
 >
 > device.string = "surround41:0"
 > device.buffering.buffer_size = "163840"
 > device.buffering.fragment_size = "5120"
 > device.access_mode = "mmap+timer"
 > device.profile.name = "analog-surround-41"
 > device.profile.description = "Surround analogico 4.1"
 > device.description = "Audio interno Surround analogico 4.1"
 >
 > **** List of PLAYBACK Hardware Devices ****
 > card 0: CS46xx [Sound Fusion CS46xx], device 0: CS46xx [CS46xx]
 > Subdevices: 31/31
 > card 0: CS46xx [Sound Fusion CS46xx], device 1: CS46xx - Rear [CS46xx
- Rear]
 > Subdevices: 31/31
 > card 0: CS46xx [Sound Fusion CS46xx], device 2: CS46xx - IEC958
[CS46xx - IEC958]
 > Subdevices: 1/1
 > Subdevice #0: subdevice #0
 > card 0: CS46xx [Sound Fusion CS46xx], device 3: CS46xx - Center LFE
[CS46xx - Center LFE]
 > Subdevices: 31/31
 >

-- You received this bug notification because you are subscribed to the
bug report. https://bugs.launchpad.net/bugs/1047543 Title: [CS46xx -
Sound Fusion CS46xx, playback] fails after a while Status in
“alsa-driver” package in Ubuntu: New Bug description: to tell the
thruth, is several years and several ubuntu versions I can't find peace
with sound. In the past I was able to ear one song moving the volume
cursor (but I had to repeat it for each song). Now I can ear just some
second of music followed by silence. Thank in advance ProblemType: Bug
DistroRelease: Ubuntu 12.04 Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic-pae 3.2.27 Uname: Linux
3.2.0-30-generic-pae i686 NonfreeKernelModules: nvidia AlsaVersion:
Advanced Linux Sound Architecture Driver Version 1.0.24. ApportVersion:
2.0.1-0ubuntu13 Architecture: i386 ArecordDevices: **** List of CAPTURE
Hardware Devices **** card 0: CS46xx [Sound Fusion CS46xx], device 0:
CS46xx [CS46xx] Subdevices: 1/1 Subdevice #0: subdevice #0
AudioDevicesInUse: USER PID ACCESS COMMAND /dev/snd/controlC0: stefano
20593 F.... pulseaudio Card0.Amixer.info: Card hw:0 'CS46xx'/'Sound
Fusion CS46xx at 0x...

Read more...

Raymond (superquad-vortex2) wrote :

http://www.dearhoney.idv.tw/Speakers/SW310/

all 2.1 speaker set only need the green jack since the signal of subwoofer is generated fron the stereo (front) by hardware and the volume of the subwoofer is controled by hardware knob of the speaker sets

the subwoofer of those creative 4.1 speaker is also controled by the hardware knob of the speaker

https://wiki.ubuntu.com/PulseAudio/Log

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/428619

stef@no (stefano-papo) wrote :

On 10/09/2012 05:01, Raymond wrote:
> http://www.dearhoney.idv.tw/Speakers/SW310/
>
> all 2.1 speaker set only need the green jack since the signal of
> subwoofer is generated fron the stereo (front) by hardware and the
> volume of the subwoofer is controled by hardware knob of the speaker
> sets
>
> the subwoofer of those creative 4.1 speaker is also controled by the
> hardware knob of the speaker
>
>
> https://wiki.ubuntu.com/PulseAudio/Log
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/428619
>
dear Raymond,
I have not altered the pc since your last message; I don't know what I
did but I think the procedure for pulseaudio and the restarting have
deleted the lines of code that upset the signal; all works perfectly
now. Thank you very very much.
Regards
Stefano Cocchia

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers