[tegra-alc5632 - tegra-alc5632, recording] The default settings should allow recording, or it should be easy to configure

Bug #1046412 reported by Ivan Zakharyaschev
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
AC100_enablement
Low
Oliver Grawert
alsa-driver (Ubuntu)
Low
Oliver Grawert

Bug Description

I've installed Ubuntu 12.04 for Toshiba AC100.
My history is described here -- https://answers.launchpad.net/ac100/+question/207758 :

before turned on a lot of switches in alsamixer, no sound could be recorded.

I couldn't turn capturing the sound on through the sound settings menu in the panel.

I suggest that either the default settings allow recording, or there is a simple way to switch it on through the settings menu (without having to look at a whole lot of switches in alsamixer, not understanding their meaning).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
Uname: Linux 3.0.27-1-ac100 armv7l
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: tegraalc5632 [tegra-alc5632], device 0: ALC5632 PCM alc5632-hifi-0 []
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu13
Architecture: armhf
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: tegraalc5632 [tegra-alc5632], device 0: ALC5632 PCM alc5632-hifi-0 []
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: imz 2410 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'tegraalc5632'/'tegra-alc5632'
   Mixer name : ''
   Components : ''
   Controls : 67
   Simple ctrls : 62
Date: Thu Sep 6 02:59:56 2012
PackageArchitecture: all
PciMultimedia:

SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:tegraalc5632 failed
Symptom_Card: tegra-alc5632 - tegra-alc5632
Symptom_DevicesInUse:
 2410/dev/snd/controlC0: imz F.... pulseaudio
 AND
Symptom_Type: No sound at all
Title: [tegra-alc5632 - tegra-alc5632, recording] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Ivan Zakharyaschev (imz) wrote :
Revision history for this message
Leon Romanovsky (leonro) wrote : Re: [Ac100] [Bug 1046412] Re: [tegra-alc5632 - tegra-alc5632, recording] The default settings should allow recording, or it should be easy to configure

On Wed, Sep 5, 2012 at 7:14 PM, Ivan Zakharyaschev
<email address hidden> wrote:
>
> ** Also affects: ac100
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of AC100
> Team, which is subscribed to AC100_enablement.
> https://bugs.launchpad.net/bugs/1046412
>
> Title:
> [tegra-alc5632 - tegra-alc5632, recording] The default settings should
> allow recording, or it should be easy to configure
I don't think that it is a bug.

> I suggest that either the default settings allow recording, or there
> is a simple way to switch it on through the settings menu (without
> having to look at a whole lot of switches in alsamixer, not
> understanding their meaning).

--
Leon Romanovsky | Independent Linux Consultant
        www.leon.nu | <email address hidden>

Revision history for this message
Andrey Danin (danindrey) wrote :

Ubuntu for ac100 uses ucm config (placed in /usr/share/alsa/ucm/) for audio device (thanks to ogra!).
So I suppose we just need to add few lines to the config to enable internal mic (dmic):
                cset "name='DMIC En Capture Switch' on"
                cset "name='DMIC PreFilter Capture Switch' on"
                cset "name='DMICL Mix DMICL2ADC Capture Switch' on"
                cset "name='I2SOut Mux' 'ADC LR'"
                cset "name='DMIC Boost Volume' 100,100"
                cset "name='Rec Capture Volume' 100,100"
I'm not sure about Volume values (I don't have my ac100 with me and can't check what values are good - very high values can produse noise).

Useful links:
http://ac100.wikispaces.com/alsa_ucm
http://ac100.grandou.net/mixer_settings#recording_sound_from_integrated_dmic

Revision history for this message
Ivan Zakharyaschev (imz) wrote :

Re: it's not a bug

I think that it's a kind of a bug of the distro that the microphone (neither external nor internal) can't be turned on in the "standard" settings menu exposed to the users.

So, perhaps, such a simple setting should be there in the sound settings menu, or the microphines should just be enabled by default, as danindrey@ suggests above.

Revision history for this message
Andrey Danin (danindrey) wrote :
Revision history for this message
Oliver Grawert (ogra) wrote :

alsa-lib (1.0.25-3ubuntu3) quantal; urgency=low

  * debian/ucm/tegraalc5632/tegraalc5632.conf: fix recording, set sane volume
    defaults (LP: #1046412)

Date: Wed, 12 Sep 2012 12:10:18 +0200
Changed-By: Oliver Grawert <email address hidden>

Changed in ac100:
assignee: nobody → Oliver Grawert (ogra)
Changed in alsa-driver (Ubuntu):
assignee: nobody → Oliver Grawert (ogra)
Changed in ac100:
importance: Undecided → Low
Changed in alsa-driver (Ubuntu):
importance: Undecided → Low
Changed in ac100:
status: New → Fix Released
Changed in alsa-driver (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions