[M17xR4, Creative CA0132, Green Headphone Out, Front] No automute

Bug #1043621 reported by Gerardo Cordova on 2012-08-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Originally there was no sound, I modified the file /etc/modprobe.d/alsa-base.conf adding the following: "snd-hda-intel index=0 model=intel" and now I have sound (maybe that model is not the best option), but when I plug the headphones there is sound from the speakers and the headphones. I installed gnome alsa mixer but it doesn't open. thanks

using ubuntu 12.04.1 LTS

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gerardo 1836 F.... pulseaudio
 /dev/snd/pcmC0D0p: gerardo 1836 F...m pulseaudio
Card0.Amixer.info:
 Error: command ['amixer', '-c', '0', 'info'] failed with exit code 1: amixer: Mixer load hw:0 error: Invalid argument
 Card hw:0 'PCH'/'HDA Intel PCH at 0xd2710000 irq 48'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:11020011,1028057b,00100918 HDA:80862806,1028057b,00100000'
   Controls : 27
Card0.Amixer.values: Error: command ['amixer', '-c', '0'] failed with exit code 1: amixer: Mixer hw:0 load error: Invalid argument
Date: Wed Aug 29 21:42:38 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_Jack: Green Headphone Out, Front
Symptom_Type: No auto-mute between outputs
Symptom_amixerStderr: a m i x e r : M i x e r h w : P C H l o a d e r r o r : I n v a l i d a r g u m e n t
Title: [M17xR4, Creative CA0132, Green Headphone Out, Front] No automute
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/08/2012
dmi.bios.vendor: Alienware
dmi.bios.version: A02
dmi.board.name: M17xR4
dmi.board.vendor: Alienware
dmi.board.version: A02
dmi.chassis.type: 8
dmi.chassis.vendor: Alienware
dmi.chassis.version: A02
dmi.modalias: dmi:bvnAlienware:bvrA02:bd02/08/2012:svnAlienware:pnM17xR4:pvrA02:rvnAlienware:rnM17xR4:rvrA02:cvnAlienware:ct8:cvrA02:
dmi.product.name: M17xR4
dmi.product.version: A02
dmi.sys.vendor: Alienware
mtime.conffile..etc.modprobe.d.alsa.base.conf: 2012-08-24T17:11:29.363163

Gerardo Cordova (cordovagera) wrote :
user (captain-hair) wrote :

Hi, I'm running into the same issue, first on 13.04 now 12.10. I'm making this a dual boot with win7 and this is my nth attempt to get ubuntu working. Very similar, if not same machine. I'm not sure what the link is for, is that a replacement for the driver. If there are any commands I need to run, let me know. I know in the alsamixer it's possible to mute the speaker, but when I unplug and replug my headphones, alsamixer shows it's still muted but sound comes out of both speakers and headphones.

I've tried adding this line to alsa-base.conf
options snd-hda-intel model=auto probe_mask=1

and also following this set of instructions
http://askubuntu.com/questions/276170/speakers-and-headphones-at-the-same-time-when-using-a-dv6-2170

Can you give me any pointers on how to fix it without muting the speakers each time?

user (captain-hair) wrote :

Ok I saved the patch file to the location /sound/pci/hda/ based on the page that I see. Do I need to recompile the kernel/alsa for it to be used? And if so, what are the commands/ switches I need to use?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
user (captain-hair) wrote :

I followed the instructions on the page selecting the quantal-all deb and attempted to install. This was the result at the end of the process

...
depmod....

DKMS: install completed.
Building initial module for 3.6.0-030600-generic
Error! The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which
does not match this kernel/arch. This indicates that it should not be built.
dpkg: error processing oem-audio-hda-daily-dkms (--configure):
 subprocess installed post-installation script returned error exit status 9
Errors were encountered while processing:
 oem-audio-hda-daily-dkms

On the page it lists that it was only built for i386, I tried to installed ia32-libs and it spits back the same message. Are there any other steps I can do to to fix this?

madbiologist (me-again) wrote :

Firmware files for the Creative CA0132 HD-audio codec were added in linux-firmware 1.107. Ubuntu 13.04 "Raring Ringtail" is using the older linux-firmware 1.106 package.

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 12.04 (precise) reached end-of-life on April 28, 2017.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in and change the bug status to Confirmed.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions