Activity log for bug #1040873

Date Who What changed Old value New value Message
2012-08-23 20:55:13 sami bug added bug
2012-08-23 20:56:36 sami description Hi, this bug is a fork of https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/871808 because #871808 stands for a different hardware with a different solution, so people may get confused. Here is a summary (see post #48 to #54 of #871808): The subwoofer of Asus N56VZ laptop doesn't work "out of the box". #sudo hda-jack-sense-test -a : *** Without subwoofer: Pin 0x1e (Black SPDIF Out): present = No *** With subwoofer: Pin 0x1e (Black SPDIF Out): present = Yes --> There are two ways of making it work: #1 a. Add to rc.local : echo 0x1e 0x99130112 > /sys/class/sound/hwC0D0/user_pin_configs echo 1 > /sys/class/sound/hwC0D0/reconfig b. Add options snd-hda-intel model=asus-mode4 in /etc/modprobe.d/alsa-base.conf c. Reboot d. Set the mode to "Analog Stereo Output" and then to "Analog Surround 5.1 output" in the sound settings panel. You have to do this each time you reboot!!! #2 a. Add to rc.local : echo 0x16 0x99130111 > /sys/class/sound/hwC0D0/user_pin_configs echo 0x1e 0x99130112 > /sys/class/sound/hwC0D0/user_pin_configs echo 1 > /sys/class/sound/hwC0D0/reconfig b. Reboot c. Set the mode to "Analog Stereo Output" and then to "Analog Surround 5.1 output" in the sound settings panel. You have to do this each time you reboot!!! Both give the same results and fix the bug. --> Can you make it work out of the box? There is still two other bugs on this laptop : - crackling audio when playing with sound volume: see https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040867 - When I put the omputer in sleep mode, there is no way to get sound working on resume: should I open a new bug to investigate this? Regards Sam ProblemType: Bug DistroRelease: Ubuntu 12.04 Package: alsa-base 1.0.25+dfsg-0ubuntu1 ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24 Uname: Linux 3.2.0-29-generic x86_64 AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24. AplayDevices: **** List of PLAYBACK Hardware Devices **** card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 ApportVersion: 2.0.1-0ubuntu12 Architecture: amd64 ArecordDevices: **** List of CAPTURE Hardware Devices **** card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 AudioDevicesInUse: USER PID ACCESS COMMAND /dev/snd/controlC0: sam 1898 F.... pulseaudio Card0.Amixer.info: Card hw:0 'PCH'/'HDA Intel PCH at 0xf7a10000 irq 47' Mixer name : 'Realtek ALC663' Components : 'HDA:10ec0663,10431477,00100002' Controls : 23 Simple ctrls : 13 CheckboxSubmission: 54021779511d0213081a2b1707bf951c CheckboxSystem: 4c773cd91921f9618cc2f1893bc1a87a Date: Thu Aug 23 22:38:00 2012 InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425) PackageArchitecture: all ProcEnviron: TERM=xterm PATH=(custom, no user) LANG=en_US.UTF-8 SHELL=/bin/bash SourcePackage: alsa-driver Symptom: audio Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed Symptom_Card: Built-in Audio - HDA Intel PCH Symptom_DevicesInUse: 1898 sam F.... pulseaudio PID ACCESS COMMAND Symptom_Jack: Black Headphone Out, Right Symptom_Type: No sound at all Title: [N56VZ, Realtek ALC663, Black Headphone Out, Right] No sound at all UpgradeStatus: No upgrade log present (probably fresh install) dmi.bios.date: 05/11/2012 dmi.bios.vendor: American Megatrends Inc. dmi.bios.version: N56VZ.204 dmi.board.asset.tag: ATN12345678901234567 dmi.board.name: N56VZ dmi.board.vendor: ASUSTeK COMPUTER INC. dmi.board.version: 1.0 dmi.chassis.asset.tag: No Asset Tag dmi.chassis.type: 10 dmi.chassis.vendor: ASUSTeK COMPUTER INC. dmi.chassis.version: 1.0 dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN56VZ.204:bd05/11/2012:svnASUSTeKCOMPUTERINC.:pnN56VZ:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnN56VZ:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0: dmi.product.name: N56VZ dmi.product.version: 1.0 dmi.sys.vendor: ASUSTeK COMPUTER INC. modified.conffile..etc.modprobe.d.alsa.base.conf: [modified] mtime.conffile..etc.modprobe.d.alsa.base.conf: 2012-08-23T22:27:03.314416 Hi, this bug is a fork of https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/871808 because #871808 stands for a different hardware with a different solution, so people may get confused. Here is a summary (see post #48 to #54 of #871808): The subwoofer of Asus N56VZ laptop doesn't work "out of the box". #sudo hda-jack-sense-test -a : *** Without subwoofer: Pin 0x1e (Black SPDIF Out): present = No *** With subwoofer: Pin 0x1e (Black SPDIF Out): present = Yes http://www.alsa-project.org/db/?f=2778e7f430aa95ae219d0b2bc3cb5e46abd0a33a --> There are two ways of making it work: #1 a. Add to rc.local : echo 0x1e 0x99130112 > /sys/class/sound/hwC0D0/user_pin_configs echo 1 > /sys/class/sound/hwC0D0/reconfig b. Add options snd-hda-intel model=asus-mode4 in /etc/modprobe.d/alsa-base.conf c. Reboot d. Set the mode to "Analog Stereo Output" and then to "Analog Surround 5.1 output" in the sound settings panel. You have to do this each time you reboot!!! #2 a. Add to rc.local : echo 0x16 0x99130111 > /sys/class/sound/hwC0D0/user_pin_configs echo 0x1e 0x99130112 > /sys/class/sound/hwC0D0/user_pin_configs echo 1 > /sys/class/sound/hwC0D0/reconfig b. Reboot c. Set the mode to "Analog Stereo Output" and then to "Analog Surround 5.1 output" in the sound settings panel. You have to do this each time you reboot!!! Both give the same results and fix the bug. --> Can you make it work out of the box? There is still two other bugs on this laptop : - crackling audio when playing with sound volume: see https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040867 - When I put the omputer in sleep mode, there is no way to get sound working on resume: should I open a new bug to investigate this? Regards Sam ProblemType: Bug DistroRelease: Ubuntu 12.04 Package: alsa-base 1.0.25+dfsg-0ubuntu1 ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24 Uname: Linux 3.2.0-29-generic x86_64 AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24. AplayDevices:  **** List of PLAYBACK Hardware Devices ****  card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog]    Subdevices: 1/1    Subdevice #0: subdevice #0 ApportVersion: 2.0.1-0ubuntu12 Architecture: amd64 ArecordDevices:  **** List of CAPTURE Hardware Devices ****  card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog]    Subdevices: 1/1    Subdevice #0: subdevice #0 AudioDevicesInUse:  USER PID ACCESS COMMAND  /dev/snd/controlC0: sam 1898 F.... pulseaudio Card0.Amixer.info:  Card hw:0 'PCH'/'HDA Intel PCH at 0xf7a10000 irq 47'    Mixer name : 'Realtek ALC663'    Components : 'HDA:10ec0663,10431477,00100002'    Controls : 23    Simple ctrls : 13 CheckboxSubmission: 54021779511d0213081a2b1707bf951c CheckboxSystem: 4c773cd91921f9618cc2f1893bc1a87a Date: Thu Aug 23 22:38:00 2012 InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425) PackageArchitecture: all ProcEnviron:  TERM=xterm  PATH=(custom, no user)  LANG=en_US.UTF-8  SHELL=/bin/bash SourcePackage: alsa-driver Symptom: audio Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed Symptom_Card: Built-in Audio - HDA Intel PCH Symptom_DevicesInUse:  1898 sam F.... pulseaudio      PID ACCESS COMMAND Symptom_Jack: Black Headphone Out, Right Symptom_Type: No sound at all Title: [N56VZ, Realtek ALC663, Black Headphone Out, Right] No sound at all UpgradeStatus: No upgrade log present (probably fresh install) dmi.bios.date: 05/11/2012 dmi.bios.vendor: American Megatrends Inc. dmi.bios.version: N56VZ.204 dmi.board.asset.tag: ATN12345678901234567 dmi.board.name: N56VZ dmi.board.vendor: ASUSTeK COMPUTER INC. dmi.board.version: 1.0 dmi.chassis.asset.tag: No Asset Tag dmi.chassis.type: 10 dmi.chassis.vendor: ASUSTeK COMPUTER INC. dmi.chassis.version: 1.0 dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN56VZ.204:bd05/11/2012:svnASUSTeKCOMPUTERINC.:pnN56VZ:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnN56VZ:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0: dmi.product.name: N56VZ dmi.product.version: 1.0 dmi.sys.vendor: ASUSTeK COMPUTER INC. modified.conffile..etc.modprobe.d.alsa.base.conf: [modified] mtime.conffile..etc.modprobe.d.alsa.base.conf: 2012-08-23T22:27:03.314416
2012-09-29 14:25:12 BenTheLightman bug added subscriber Ben Spoor
2012-09-30 10:05:24 Launchpad Janitor alsa-driver (Ubuntu): status New Confirmed
2012-10-03 01:41:06 Leonardo Di Donato bug added subscriber Leonardo Di Donato
2012-10-22 00:09:41 Thiago Martins bug added subscriber Thiago Martins
2012-10-23 20:16:33 Guillaume Yvenou bug added subscriber Guillaume Yvenou
2012-10-24 16:52:04 Thiago Martins attachment added Script to be placed in /etc/pm/sleep.d that will atempt hda pin reconfiguration on a resume with pulseaudio running. https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3411970/+files/99_reconf_sndpins_pa
2013-01-16 03:16:24 bobzer bug added subscriber bobzer
2013-06-08 21:26:27 krustymars attachment added wooferDaemon.sh https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3698359/+files/wooferDaemon.sh
2013-10-12 13:39:55 meomic attachment added wooferDaemon.sh https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3875829/+files/wooferDaemon.sh
2013-10-13 16:52:08 meomic attachment added alsa-info.txt https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3876820/+files/alsa-info.txt
2013-10-14 01:04:20 Raymond bug watch added https://bugzilla.novell.com/show_bug.cgi?id=841645
2013-10-14 08:14:18 madbiologist bug added subscriber madbiologist
2013-10-17 23:40:21 meomic bug watch added https://bugzilla.novell.com/show_bug.cgi?id=846529
2013-10-17 23:40:21 meomic bug watch added https://bugzilla.novell.com/show_bug.cgi?id=846531
2014-01-25 22:58:56 Svetoslav Stefanov bug added subscriber Svetoslav Stefanov
2014-02-07 10:31:14 David Henningsson alsa-driver (Ubuntu): status Confirmed Triaged
2014-02-08 12:35:11 sami attachment added syslog with oem-audio-hda-daily-lts-saucy-dkms_0.201402051426~ubuntu12.04.1_all.deb https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3973792/+files/syslog.test
2014-02-11 00:11:41 meomic attachment added daemon.conf https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3976357/+files/daemon.conf
2014-02-11 01:48:43 meomic attachment added pulseverbose.log https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3976366/+files/pulseverbose.log
2014-02-11 02:02:19 meomic attachment added pulseverbose.log https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3976370/+files/pulseverbose.log
2014-02-14 21:33:41 sami attachment added pulseverbose.log.comment96 https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/3981193/+files/pulseverbose.log.comment96
2015-04-26 21:15:14 sami attachment added 15_04_pactlListSinks.txt https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/4385008/+files/15_04_pactlListSinks.txt
2015-04-26 21:15:44 sami attachment added 15_04_pulseverbose.log https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1040873/+attachment/4385009/+files/15_04_pulseverbose.log
2015-08-05 20:05:57 sami bug watch added https://bugs.freedesktop.org/show_bug.cgi?id=91568