[N56VZ, Realtek ALC663, Speaker, Internal] crackling audio when playing with volume

Bug #1040867 reported by sami
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

When I play with the "output volume" in the sound settings panel, it sometimes make the sound become completely crushed (noisy, high pitch peaks).
It won't become normal until I set the mode to "Analog Stereo Output" first and then back to "Analog Surround 5.1 output" (or if I restart).

I tried this: https://wiki.ubuntu.com/Audio/PositionReporting
In the end, options snd-hda-intel position_fix=1 in /etc/modprobe.d/alsa-base.conf works perfectly (no crackling audio anymore).
I also tried options snd-hda-intel position_fix=2 and the bug came back.

--> Can you make a fix so it works out of the box ?

Regards.
Sam

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: sam 1898 F...m pulseaudio
 /dev/snd/controlC0: sam 1898 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7a10000 irq 47'
   Mixer name : 'Realtek ALC663'
   Components : 'HDA:10ec0663,10431477,00100002'
   Controls : 23
   Simple ctrls : 13
CheckboxSubmission: 54021779511d0213081a2b1707bf951c
CheckboxSystem: 4c773cd91921f9618cc2f1893bc1a87a
Date: Thu Aug 23 22:29:46 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_Jack: Speaker, Internal
Symptom_Type: Volume slider, or mixer problems
Title: [N56VZ, Realtek ALC663, Speaker, Internal] volume slider problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/11/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: N56VZ.204
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: N56VZ
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN56VZ.204:bd05/11/2012:svnASUSTeKCOMPUTERINC.:pnN56VZ:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnN56VZ:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: N56VZ
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
modified.conffile..etc.modprobe.d.alsa.base.conf: [modified]
mtime.conffile..etc.modprobe.d.alsa.base.conf: 2012-08-23T22:27:03.314416

Revision history for this message
sami (miaousami) wrote :
Revision history for this message
David Henningsson (diwic) wrote :

Thanks for your bug report. Actually, I think this is already fixed in later kernels.

You can verify this by upgrading your alsa drivers: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

Revision history for this message
sami (miaousami) wrote :

Hi David,

indeed I just installed alsa-hda-dkms_0.201208251224~precise1_all.deb and it is fixed.
One last question: do you have any idea of when it will be available in:
- "default" ubuntu kernel 3.2
- vanilla kernel?

Regards.

Revision history for this message
David Henningsson (diwic) wrote :

It looks like it is scheduled for the 3.6 kernel, so it won't reach us until 13.04 unless we do an active backport.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for alsa-driver (Ubuntu) because there has been no activity for 60 days.]

Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers