[Asus X101CH, Internal speaker] No sound after update (Ubuntu preinstall)

Bug #1037763 reported by Tim Graham on 2012-08-16
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
High
Cyrus Lien

Bug Description

This is a new Asus EeePc with Ubuntu preinstalled. The sound works out of the box, but after an initial update the internal speakers stop working. Audio via the headphone jack still works. A factory reset of the system (which reinstalls Ubuntu from a recovery partition) restores the sound but the next update (of Linux kernel) breaks it again.

====
Current workaround:

Installing the latest DKMS package according to https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS should bring the sound back.
====

I ran "ubuntu-bug audio" according to these instructions (https://wiki.ubuntu.com/DebuggingSoundProblems) to file this bug.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic-pae 3.2.24
Uname: Linux 3.2.0-29-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tgraham 1749 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdff00000 irq 46'
   Mixer name : 'Intel CedarTrail HDMI'
   Components : 'HDA:10ec0269,10438516,00100100 HDA:80862880,80860101,00100000'
   Controls : 10
   Simple ctrls : 4
Date: Thu Aug 16 21:34:37 2012
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-yanshui-precise-i386-20120615-0
InstallationMedia: Ubuntu 12.04 "Precise" - Failed to find casper uuid.conf in 'binary/casper/initrd.img-3.2.0-25-generic-pae.old-dkms' LIVE Binary 20120615-03:22
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Intel failed
Symptom_Card: Built-in Audio - HDA Intel
Symptom_DevicesInUse:
 1749 tgraham F.... pulseaudio
     PID ACCESS COMMAND
Symptom_Jack: Speaker, Internal
Symptom_Type: No sound at all
Title: [X101CH, Realtek ID 269, Speaker, Internal] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/30/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X101CH.1101
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: X101CH
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX101CH.1101:bd05/30/2012:svnASUSTeKCOMPUTERINC.:pnX101CH:pvrx.x:rvnASUSTeKCOMPUTERINC.:rnX101CH:rvrx.xx:cvnASUSTeKCOMPUTERINC.:ct10:cvrx.x:
dmi.product.name: X101CH
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Tim Graham (tim6502) wrote :
David Henningsson (diwic) wrote :

Hi Tim and thanks for reporting this bug!

It looks like the DKMS package is not recompiling itself correctly, so I will forward this issue to somebody who knows more about the preinstalls.

For the time being, installing the latest DKMS package according to https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS should bring the sound back.

Changed in alsa-driver (Ubuntu):
status: New → Triaged
Changed in alsa-driver (Ubuntu):
status: Triaged → In Progress
Cyrus Lien (cyruslien) on 2012-09-13
Changed in alsa-driver (Ubuntu):
assignee: nobody → Cyrus Lien (cyruslien)
Cyrus Lien (cyruslien) wrote :

Waiting for package pushing to update archive.

fra_buntu (fra-ferretti) wrote :

I bought one day ago an asus 1015cx with ubuntu preinstalled. Speackers and microphone doesen't work!!!
I hope that this bug will be resolved quickly. On the shassis of my netbook there is a stiker with write: "ubuntu certified"!!

Thank you for all!!!

Same bug here on Asus eeepc x101CH... I hope that this bug will be resolved quickly. If someone could help me...

Cyrus Lien (cyruslien) wrote :

Raise the importance of the pushing package request to High.

summary: - [X101CH, Realtek ID 269, Speaker, Internal] No sound at all
+ [Asus X101CH] No sound after update (Ubuntu preinstall)
description: updated
summary: - [Asus X101CH] No sound after update (Ubuntu preinstall)
+ [Asus X101CH, Internal speaker] No sound after update (Ubuntu
+ preinstall)
Changed in alsa-driver (Ubuntu):
importance: Undecided → High
Nara Huang (narahuang) wrote :

Using alsa-hda-realtek-patched-dkms 1.1, the sound comes back again.

Cyrus Lien (cyruslien) wrote :

For anyone who have the same problem.

1) Please add below package sources to your sources.list.
deb http://asus.archive.canonical.com/updates precise-yanshui public
deb-src http://asus.archive.canonical.com/updates precise-yanshui public

2) apt-get update

3) apt-get install alsa-hda-realtek-patched-dkms

4) reboot

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Released
tlalokman (gtupac-amaro) wrote :

I have the same problem but I'm an absolute begginner in Linux and I don't understand what Cyrus Lien tells I have to do. How do I add those package sources to my sources.list? Should I open the Terminal? ( I already did that and it didn't recognize the command deb, so I think I'm wrong). Directly in the links? Anywhere else?

lindis (gross6) wrote :

Open Terminal

write this command:

sudo gedit /etc/apt/source.list

this command open program gedit: now you can modify the file source.list
add to the file the lines:

deb http://asus.archive.canonical.com/updates precise-yanshui public
deb-src http://asus.archive.canonical.com/updates precise-yanshui public

save the file

back to terminal write command:

sudo apt-get update

then write:

sudo apt-get install alsa-hda-realtek-patched-dkms

then write:

sudo reboot

you have done!

tlalokman (gtupac-amaro) wrote :

Thanks a lot! Those were really useful and clear instructions! I did what you said and now I've got the sound back... but just in the headphones! Speakers are still mute. What can it be?

Cyrus Lien (cyruslien) wrote :

@tlalokman,
I am sorry for that vague instructions.
Can you try to unplug the headphone and adjust the sound volume by press function key (Press Fn key and F11 or F11) ?

lindis (gross6) wrote :

@tlalokman,

If what suggests cyruslien doesn't work it is probable that you did not install the new driver alsa-hda-realtek-patched-dkms at all.
Did you wait for the prompt among one command line and the next?
The prompt is the line xxx@yyy$ followed by the blinking cursor where you can write a command.
It takes several minutes to some command to complete, be patient.

tlalokman (gtupac-amaro) wrote :

@cyruslien,
Don't worry, the problem is that I'm not specialized in computer's language but still keep trying to handle it because I like a lot the idea and the meaning of Ubuntu. It's just that it takes time to me to really understand what you're saying. I appreciate your patience. And yes, I checked if I could adjust the volume with F11 and i couldn't

@lindis,

I suppose you're referring to the post of @David Henningson at the beggining of this thread. I hadn't noticed it, so I did install the new driver (however, I didn't know what Precise, Oneiric, Quantal mean and what is the most appropriate for my computer). I installed the DKMS Precise driver. Now I've got the sound back, but just in the right speaker. I already tried to balance the sound in Settings but didn't work at all. What can it be? Should I unistall this driver and try with others (Oneiric, Quantal, Natty?)

lindis (gross6) wrote :

@tlalokman,

No, I refer to my post #10.
The driver is the package alsa-hda-realtek-patched-dkms no others.
If you installed a different package uninstall it using:

sudo apt-get purge package_name

I will repeat the instructions adding some details:

Open Terminal

write this command:

sudo gedit /etc/apt/source.list

this command open program gedit: now you can modify the file source.list
add to the file the lines:

deb http://asus.archive.canonical.com/updates precise-yanshui public
deb-src http://asus.archive.canonical.com/updates precise-yanshui public

save the file
CLOSE THE GEDIT WINDOWS

back to terminal write command:

sudo apt-get update

WAIT FOR THE PROMPT then write:

sudo apt-get install alsa-hda-realtek-patched-dkms

WAIT FOR THE PROMPT then write:

sudo reboot

WAIT FOR REBOOT

Test the sound using:
 System Settings -> Sound -> Test Sound

If the sound doesn't work properly I have no others suggestions to give you, sorry.

Eduardo Calderón (gonedcc) wrote :

sudo gedit /etc/apt/source.list
The command is misspelled, it changes and it works perfect surces.list

sudo gedit /etc/apt/surces.list

Thanks and I have sound in the internal speaker, but it sounds very low with maximum control. As I can power up more sound?

lindis (gross6) wrote :

@gonedcc
I am sorry for the wrong instruction, thanks for the correction.

My 1225c has not high sound level too. Maybe it is a hardware project choice. (???)
Note however that it depends a lot from the file you are playing. This is what I experienced.

The following are the instructions again but corrected:

Open Terminal

write this command:

sudo gedit /etc/apt/sources.list

this command open program gedit: now you can modify the file sources.list
add to the file the lines:

deb http://asus.archive.canonical.com/updates precise-yanshui public
deb-src http://asus.archive.canonical.com/updates precise-yanshui public

save the file
close the gedit windows

back to terminal write command:

sudo apt-get update

wait for the prompt then write:

sudo apt-get install alsa-hda-realtek-patched-dkms

wait for the prompt then write:

sudo reboot

wait for reboot

Test the sound using:
 System Settings -> Sound -> Test Sound

Eduardo Calderón (gonedcc) wrote :

@gross6
Ok, now works. I have not tested whether the serial port and hdmi work fine otherwise is perfecte!
Thank you very much. Comment on any developments.

AceLan Kao (acelankao) wrote :

Just try to dig in the root cause and explain the difference between alsa-hda-realtek-patched-dkms v1.0 and v1.1.
Looks like the new kernel changes some code in snd-hda, so that makes the kernel module produced by the dkms package becomes doesn't match with other snd-hda modules come with kernel package.
So, in dkms.conf file, it copy more kernel modules to the system to overwrite those come with kernel package.

% diff -Nru alsa-hda-realtek-patched-1.0/Makefile alsa-hda-realtek-patched-1.1/Makefile
--- alsa-hda-realtek-patched-1.0/Makefile 2012-08-31 16:09:03.000000000 +0800
+++ alsa-hda-realtek-patched-1.1/Makefile 2012-09-03 09:33:16.373771214 +0800
@@ -72,3 +72,5 @@

 all:
        make -C $(KERNELBUILD) M=$(shell pwd) modules
+clean:
+ rm -rf *.o *.cmd *.ko *.mod.c modules.order Module.symvers

% diff -Nru alsa-hda-realtek-patched-1.0/dkms.conf alsa-hda-realtek-patched-1.1/dkms.conf
--- alsa-hda-realtek-patched-1.0/dkms.conf 2012-06-06 11:43:07.000000000 +0800
+++ alsa-hda-realtek-patched-1.1/dkms.conf 2012-09-03 09:33:15.269771484 +0800
@@ -1,4 +1,4 @@
-PACKAGE_VERSION="1.0"
+PACKAGE_VERSION="1.1"
 PACKAGE_NAME="alsa_hda_realtek_patched"
 AUTOINSTALL="yes"
 REMAKE_INITRD="yes"
@@ -6,3 +6,12 @@
 BUILT_MODULE_NAME[0]="snd-hda-codec-realtek"
 DEST_MODULE_LOCATION[0]="/updates/kernel"

+BUILT_MODULE_NAME[1]="snd-hda-codec"
+DEST_MODULE_LOCATION[1]="/updates/kernel"
+
+BUILT_MODULE_NAME[2]="snd-hda-codec-hdmi"
+DEST_MODULE_LOCATION[2]="/updates/kernel"
+
+BUILT_MODULE_NAME[3]="snd-hda-intel"
+DEST_MODULE_LOCATION[3]="/updates/kernel"

Yo!

There is something really great I wanted to show you, just take a look at that cool stuff http://www.yehanews.com/bond.php?0504

Carmine DIsanto

From: Bug 1037763 [mailto:<email address hidden>]
Sent: Saturday, July 01, 2017 1:35 AM
To: <email address hidden>
Subject: Inland Empire I guess.

I've been using the chrome one for ages. I know some people do their investigation and archive things if they think it's worth sharing, but then the next person investigating something else will look at a lot of the same pages and give them more and more clicks.

I say archive *everything*, and use one of these extensions so if someone has already looked at and archived a page, you won't be giving them an extra click. Ideally, they should only ever get *one* click on each page from gg. Of course, that's unrealistic, but we shouldn't have hundreds or thousands of people all giving them lots and lots of clicks on lots of different pages while trying to find out if Mr X promoted Mr Y or whatever.

Sent from Mail for Windows 10

Hey friend,

There is something I wanted to tell you about, I'm so excited, please read it here http://www.denledphuongdong.com/bless.php?7f7e

Pardon my monkey thumbs, Carmine DIsanto

From: Bug 1037763 [mailto:<email address hidden>]
Sent: Monday, July 03, 2017 3:39 AM
To: <email address hidden>
Subject: Poor little one. :(

I'm not quite sure why Proj is being downvoted.

What was good in Ascend had mostly to do with the strength of Tribes itself as a game concept, and almost nothing to do with the direction that Hirez took it or the changes they made to it.

Which is to say, Ascend is "good" only because there is a complete lack of viable alternatives in the genre today. King of the molehill.

The physics "are garbage" because they made balancing the game difficult as well as for a frustrating and/or unintuitive gameplay experience in many situations (eg. try to get somewhere starting from standstill on flat terrain).

The game is poorly designed because early design/balance choices made it very difficult to address balance and gameplay problems that later "surfaced".

Hindsight is always 20/20, but even with that it's evident the powers that be @ Hirez had a rather poor understanding of what made the design of the old games work, or what made them popular among gamers of all skill levels, given the direction they took the series in Ascend. And when the community raised concern about some of these issues in the closed alpha, they were given the cold shoulder and a "shut up we know what we're doing", so it's not like you can chalk it all down on lack of insight.

The game *is* full of bad code and bugs (it's there for everyone to see in the dev client files, or for anyone to experience when playing). Nary a patch went by where they didn't manage to break something completely unrelated while fixing some other issue.

I suppose you could argue that the game as-is was "good enough" that had the monetization been better designed it'd lived slightly longer, maybe to the point that they'd been able to patch it up into a bearable state.

But the reason the balance was so poor in the first place, why and the game was so feature-poor, and had so many issues all traces back to early decisions Hirez made re: the game, as well as Hirez' own (lack of) ability to actually implement what they themselves wanted/planned/desired.

Sent from Mail for Windows 10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions