Ubuntu

Invalid end-of-line backslash in Build-Depends

Reported by Andrew Sayers on 2009-06-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alpine (Debian)
Fix Released
Undecided
Unassigned
alpine (Ubuntu)
Undecided
Andrew Starr-Bochicchio
Karmic
Undecided
Andrew Starr-Bochicchio

Bug Description

Binary package hint: alpine

This bug was sent manually, but the text was written to a template, as I have several similar bugs to report today. Please see my recent bug reports for a list, or bug #391165 for the root cause.

Versions 2.00+dfsg-1~hardy1, 2.00+dfsg-2ubuntu2, and 2.00+dfsg-1 of alpine have a backslash at the end of the line(s) in the "Build-Dependencies" section of debian/control. There shouldn't be a backslash in the area(s) marked by ***asterisks***:

Build-Depends: debhelper (>= 5), libldap2-dev, libpam0g-dev, libncurses-dev, ***\***
 libssl-dev, autotools-dev, ca-certificates, automake, autoconf, libtool, libkrb5-dev, ***\***
 quilt, cdbs, aspell

This is currently allowed because of bug #391165. However, alpine will fail to build once that bug has been fixed. This bug can be fixed by removing all end-of-line backslashes.

Related branches

Asheesh Laroia (paulproteus) wrote :

2.00+dfsg-4 in Debian (to be uploaded within a day) will fix this.

David Stansby (dstansby) on 2009-07-08
Changed in alpine (Debian):
status: New → Fix Committed
Changed in alpine (Ubuntu Karmic):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alpine - 2.00+dfsg-4ubuntu1

---------------
alpine (2.00+dfsg-4ubuntu1) karmic; urgency=low

  * Merge from debian unstable (LP: #393053), remaining changes:
   - Build-depend and depend on aspell so that its detected
     at build time and used.

alpine (2.00+dfsg-4) unstable; urgency=low

  * Changed debian/control to not use backslashes for line
    continuations. Thanks to Cyril Brulebois (kibi)! (Closes: #535279).

 -- Andrew Starr-Bochicchio <email address hidden> Sat, 11 Jul 2009 19:35:36 -0400

Changed in alpine (Ubuntu Karmic):
status: In Progress → Fix Released
David Stansby (dstansby) on 2009-07-14
Changed in alpine (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers