Ubuntu

[Hardy, Intrepid SRU] alpine wants Build-Depends and Depends: aspell

Reported by Geoffrey Thomas on 2009-03-11
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alpine (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: alpine

BUG: alpine currently is configured to use aspell as its spell checking engine. However, since alpine isn't a build-dependency or dependency of aspell, spell checking in alpine breaks

DEVELOPMENT: This bug was fixed in 2.00+dfsg-2ubuntu2 for Jaunty. I'm suggesting that the patch introduced in that revision be backported for Hardy and Intrepid.

PATCH: Patches are in the comments for Hardy (http://launchpadlibrarian.net/24819523/alpine_1.0%2Bdfsg-3ubuntu0.2.debdiff) and Intrepid (http://launchpadlibrarian.net/24819529/alpine_2.00%2Bdfsg-1ubuntu0.1.debdiff).

I've also uploaded packages with those patches to my PPA (https://launchpad.net/~broder/+archive/ppa). If you check the build logs, you can see that ./configure successfully found aspell as the spell check engine.

TEST CASE: On an unpatched system, run "alpine <email address hidden>". Add some text to the body of the e-mail then press C-t, for spell check. Observe that the spell check fails to run.

REGRESSIONS: Potential seems limited, since there are no actual code changes.

====

alpine's debian/rules configures it it
  --with-spellcheck-program=aspell
which according to the changelog has been in Debian since 0.82+dfsg-4.

However, if you build it without aspell installed on your local system, ./configure reports:
  checking for aspell... no
  checking for ispell... no
  checking for spell... no
  checking for aspell... no
  checking for ispell... no
and then builds the resulting binary without spell-checking support. You can confirm this by installing alpine, starting the composer with "alpine <email address hidden>", scrolling to the message body, and pressing Ctrl-T.

If you install aspell on the build system before configuring, the build process successfully finds aspell, and Ctrl-T works in the resulting binary. I've only tested this on a build server in an Intrepid chroot, building in a clean environment and then after manually installing aspell, but I believe the same packaging bug applies to Hardy as well.

So, alpine's package needs to Build-Depend on aspell, so it's present for ./configure, and to Depend on (or at least Recommend) aspell, so it's available for use on the target system.

Asheesh Laroia (paulproteus) wrote :

You're totally right. I'll make sure the next Debian release fixes this, and it'll get slurped into Debian.

Changed in alpine:
assignee: nobody → paulproteus
status: New → Confirmed
Evan Broder (broder) wrote :

Here's a patch that fixes the problem - Ubuntu can drop it once Asheesh updates the Debian package, but it would be nice to get this fixed in Jaunty.

Since it's a missing {build-,}dependency, I don't believe this needs a feature freeze exception, so I'm subscribing ubuntu-universe-sponsors

I've tested building with this patch under sbuild, and I've also tested that spell-check works in the package sbuild generated.

John Dong (jdong) wrote :

Agree with Evan's judgement -- Bugfix in nature, not subject to feature freeze; In universe and not in any CD seeds either for freeze.

Uploaded into Jaunty.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alpine - 2.00+dfsg-2ubuntu1

---------------
alpine (2.00+dfsg-2ubuntu1) jaunty; urgency=low

  * Build-depend and depend on aspell so that its detected at build time
    and used. Reported by Geoffrey Thomas. (LP: #340993)

 -- Evan Broder <email address hidden> Wed, 11 Mar 2009 22:26:13 -0400

Changed in alpine:
status: Confirmed → Fix Released
Evan Broder (broder) wrote :

Here's a patch for a Hardy SRU.

Evan Broder (broder) wrote :

And a patch for an Intrepid SRU.

Evan Broder (broder) wrote :

(Marking as confirmed so the SRU team doesn't miss it)

description: updated
tags: added: patch
summary: - alpine's ./configure wants Build-Depends and Depends: aspell
+ [Hardy, Intrepid SRU] alpine wants Build-Depends and Depends: aspell
Changed in alpine (Ubuntu):
assignee: paulproteus → nobody
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alpine - 2.00+dfsg-3ubuntu1

---------------
alpine (2.00+dfsg-3ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    + Build-depend and depend on aspell so that its detected at build time
      and used. Reported by Geoffrey Thomas. (LP: #340993)

alpine (2.00+dfsg-3) unstable; urgency=low

  * Add Barry deFreese's little patch to fix building on Debian GNU/Hurd.
    (Closes: #532533)

alpine (2.00+dfsg-2ubuntu2) jaunty; urgency=low

  * No-change rebuild to fix lpia shared library dependencies.

 -- Stephan Hermann <email address hidden> Wed, 24 Jun 2009 18:31:17 +0000

Changed in alpine (Ubuntu):
status: Confirmed → Fix Released
John Dong (jdong) wrote :

ACK from MOTU-SRU

Evan Broder (broder) on 2009-11-30
Changed in alpine (Ubuntu Hardy):
status: New → Confirmed
Changed in alpine (Ubuntu Intrepid):
status: New → Confirmed

Accepted alpine into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in alpine (Ubuntu Hardy):
status: Confirmed → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Since this is more like a feature and not a critical bug, I rejected the intrepid update. Fixing hardy is okay, with being an LTS and all that.

Changed in alpine (Ubuntu Intrepid):
status: Confirmed → Won't Fix
Evan Broder (broder) wrote :

Fix from -proposed works for me on Hardy.

Martin Pitt (pitti) on 2009-12-10
tags: added: verification-done
removed: verification-needed
Asheesh Laroia (paulproteus) wrote :

Fixed in Debian. Please do a sync into Ubuntu!

Asheesh - I'll request the sync as soon as your new version hits Squeeze.

On Fri, Dec 11, 2009 at 9:41 PM, Asheesh Laroia <email address hidden> wrote:
> Fixed in Debian. Please do a sync into Ubuntu!
>
> --
> [Hardy, Intrepid SRU] alpine wants Build-Depends and Depends: aspell
> https://bugs.launchpad.net/bugs/340993
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Asheesh Laroia (paulproteus) wrote :

Problem is, it won't hit squeeze easily.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=551900

I'd suggest just doing the sync sooner rather than later.

Steve Langasek (vorlon) wrote :

I agree that it's better to sync this package sooner rather than later, if the fixes are present now in Debian; that saves us from having to wait until it shows up on someone's radar for a merge later. There's no policy against taking syncs/merges from unstable if appropriate, the only policy is that we aren't *auto*syncing from unstable for Lucid.

So I've gone ahead with syncing alpine 2.00+dfsg-6 to Lucid.

Asheesh, in general it would probably be helpful if you could follow http://wiki.ubuntu.com/SyncRequestProcess for such requests; requesting this in a comment on a bug that's already closed in the current development distroseries has a high risk of being overlooked.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alpine - 1.0+dfsg-3ubuntu0.2

---------------
alpine (1.0+dfsg-3ubuntu0.2) hardy-proposed; urgency=low

  * Build-depend and depend on aspell so that it's detected at build time
    and used. Reported by Geoffrey Thomas. (LP: #340993)
 -- Evan Broder <email address hidden> Sat, 04 Apr 2009 18:47:09 -0400

Changed in alpine (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.