AllTray does not work with OpenBox

Bug #301636 reported by Bronsen on 2008-11-24
Affects Status Importance Assigned to Milestone
alltray (Ubuntu)

Bug Description

Binary package hint: alltray

I start "alltray gnome-terminal" and see the icon in my tray. When I click the icon, gnome-terminal is shown as expected.

However, when I click on the close button or on the icon again, the window is not closed to tray; instead it is simply minimized and still visible in the window list. The icon in the tray area remains and clicking it does restore the window from its minimized state.

I had expected gnome-terminal to be minimized to tray, so it won't show in the window list anymore until I restore it by clicking on the icon in the tray bar.

Version Information:

housetier@reliant:~$ LANG=C apt-cache policy alltray
  Installed: 0.69-1ubuntu2
  Candidate: 0.69-1ubuntu2
  Version table:
 *** 0.69-1ubuntu2 0
        500 intrepid/universe Packages
        100 /var/lib/dpkg/status

Bronsen (housetier) wrote :

I see the same behavior with firefox: when first launching "alltray firefox -no-remote -P default" I see firefox's icon in the tray. Once I click it, firefox's window is displayed and a button is added to the Window List on my panel. This button then remains regardless of the state of its window: shown, minimized, closed to tray.

This behavior defeats the purpose of alltray, which in my case was to unclutter my window list.

Michael B. Trausch (mtrausch) wrote :

What window manager are you using, compiz, metacity, or something else altogether?

Changed in alltray:
status: New → Incomplete
Bronsen (housetier) wrote :

I use openbox as window manager

Changed in alltray:
importance: Undecided → Medium
milestone: none → alltray-0.8.0
status: Incomplete → Triaged
Miloud B. (goundy) wrote :


I'm getting exactly the same problem here. it works when I start a gnome session, but if I start a gnome/openbox session it no longer works...
I tried with any program but get the same result... the windows remain in the "task bar" so it's just minimized...
That'd be nice to have a fix for this

Michael B. Trausch (mtrausch) wrote :

There is a testing release of AllTray available (0.7.2dev) that is working towards the next stable, 0.8.0, available. It does not have all of the features of the current AllTray, and so I don't recommend it for general use just yet, but could someone test it against the GNOME/Openbox combination to determine if it makes progress towards solving this bug? Thanks!

Download information:

Michael B. Trausch (mtrausch) wrote :

One additional note: GNOME Terminal uses a setup wherein when you start a new GNOME Terminal, and you already have other ones running, the new process just asks the old one to open a new window and exits. So, prior to testing for this bug's resolution in the development version of AllTray, be sure to not have any GNOME terminal windows open. A workaround will make it into the new AllTray later to try to change this behavior, though that fix depends on another issue in that release that needs a resolution.

A decent way to test it is to start an xterm and start "alltray gnome-terminal" from within xterm.

Michael B. Trausch (mtrausch) wrote :

Just tested AllTray 0.7.3dev with OpenBox, which indeed does not work. It would appear that there is an issue with the interaction between the two pieces of software, which is documented in a rather old bug in OpenBox's tracker; I will add that bug to the watch list for this, and have asked for the OpenBox developer's assistance in trying to track this one down.

summary: - alltray does not close gnome-terminal to tray
+ AllTray does not work with OpenBox
Michael B. Trausch (mtrausch) wrote :

As this would seem to be dependent on a fix from upstream with perhaps some collaboration, I'm going to mark this bug as “incomplete” for the time being, at least until such time as I have a better idea of the disposition of this bug. If I can't raise a response in a reasonable period of time, though, it'll be up to the OpenBox users to follow the issue there and I'll eventually close this bug. Hopefully, that doesn't happen.

Changed in alltray:
importance: Medium → Wishlist
milestone: 0.8.0 → none
status: Triaged → Incomplete
Michael B. Trausch (mtrausch) wrote :

Okay, so I'm a douche. I have fixed this in AllTray's trunk, and will look at a fix for the old-maintenance branch soon; someone may be able to advocate for this being pushed to Jaunty via an SRU.

Changed in alltray:
milestone: none → 0.7.4dev
status: Incomplete → Fix Committed
Changed in openbox:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Changed in alltray:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.