show/hide doesn't work, to show the application, I have to undock

Bug #226297 reported by clarezoe on 2008-05-03
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
AllTray
Low
Unassigned
alltray (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using xubuntu 8.04 hardy, it worked fine before I changed to xubuntu. But now I have to undock the application, then it will be shown, the show/hide option doesn't work.

Michael B. Trausch (mtrausch) wrote :

Thank you for reporting your bug and helping to make Ubuntu better. However, more information is needed to determine whether this bug has been reported before:

 * Does AllTray consume 100% of your CPU time (on one core, if you have a multi-core system)? You can determine this by looking at "top" or "htop" and seeing if AllTray rises to somewhere near the top position with a high CPU usage. If so, this bug is likely a duplicate of bug 223270 (which may itself be a duplicate of bug 106583).
 * Does installing the build available at https://edge.launchpad.net/~mtrausch/+archive fix your problem and resolve the issue? If so, this bug is likely a duplicate of bug 106583.

Also, you can acquire more information that would be helpful by running AllTray from the terminal. If you are using "click mode", where you dock an already running application, could you run "alltray -d > alltray_debug.log" in a terminal and attach that as a file to this report?

If you are using AllTray to instead dock a new program, could you run "alltray -d NAME_OF_PROGRAM > alltray_debug.log" in a terminal and attach that as a file to this report?

Thanks!

Changed in alltray:
status: New → Incomplete
clarezoe (clarezoe) wrote :

* Does AllTray consume 100% of your CPU time
No, alltray never showed up.

* Does installing the build available at https://edge.launchpad.net/~mtrausch/+archive fix your problem and resolve the issue?
No, I've added it and updated alltray, still the same problem.

I used "alltray -d firefox > alltray_debug.log
First, it works fine, I mean the show/hide, the windows can show/hide when I click the icon in the task bar, but then if I click the "close" button, alltray crashed.

Thanks!

Michael B. Trausch (mtrausch) wrote :

Having taken a look at the log you submitted, it looks like AllTray is crashing because the application closed when you clicked the close button on the window. (Of course, that's not supposed to happen.)

To clarify, though, the show/hide feature now works, but you cannot close the window without killing AllTray; that is different from the original issue, is that correct?

Is your setup customized at all, or is it a fairly stock Xubuntu configuration? If the latter, I can set up a virtual machine and try to do some more intense debugging there to duplicate the issue and isolate it.

clarezoe (clarezoe) wrote :

No. I think it's still the same issue, because if I use alltray and click the window I want to dock, it still doesn't work, and there's no information from the terminal either.

I installed my Xubuntu by install package xubuntu-desktop and some relevant environment package. I know it might cause the inconvenient, but thank you very much for your concerning.

Jayson Rowe (jayson.rowe) wrote :

Since it's been a very long time since any additional info was added to this bug, I'm just checking to see if this is still an issue, and find out what additional work should be done on this bug.

Michael B. Trausch (mtrausch) wrote :

Hi JaysonRowe,

I haven't been able to figure out just why this is happening, but as no code changes have been made, the issue should still be present, along with a number of other minor, yet extremely annoying, bugs.

I keep running into problems trying to debug the program, though, with strange interactions that seemingly cannot be predicted. As soon as my current project is finished, I intend to take some time to study the software itself, and the underlying principles, and see whether cleaning up AllTray or simply rewriting it from scratch is the better of the options. There are some other pieces of software that do the same thing and claim more functionality, at least one of which is KDE based, but I intend on looking at how they do things as well, to see if maybe they have some of the same issues (and if not, why not).

However, if you've the time and/or the ability to work on this, it'd be greatly appreciated. I probably won't be finished with my current project until the first or second quarter of 2009.

Michael B. Trausch (mtrausch) wrote :

Marking the bug confirmed—I forgot to do so prior to now.

Changed in alltray:
status: Incomplete → Confirmed
Jayson Rowe (jayson.rowe) wrote :

Michael - I have the time, not so sure about the ability - I was simply checking on old bugs marked for expiration to ensure valid bugs did not die :-)

Thanks for confirming the bug.

Changed in alltray:
importance: Undecided → Low
milestone: none → alltray-0.8.0
status: New → Confirmed
Michael B. Trausch (mtrausch) wrote :

This bug has a fix that is present in the development tree which will become 0.8.0; marking the fix committed. It will be generally available when 0.8.0 is released.

Changed in alltray:
status: Confirmed → Fix Committed
Changed in alltray:
status: Fix Committed → Fix Released
Ignace Mouzannar (ghantoos) wrote :

Hello Mike,

One of the Debian users encountered a similar bug when using alltray with fluxbox (as WM) and docker (as systray) [1].

I was able to reproduce this. Please find attached the output of "alltray -d" when the bug appears.

Are these bugs related? Could this be fixed in the old-maintenance branch?

If you need more information, don't hesitate to ask here, or on the Debian BTS thread.

Thank you for your consideration.

Cheers,
 Ignace M

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=553314

On Mon, 2010-05-03 at 22:12 +0000, ghantoos wrote:
> One of the Debian users encountered a similar bug when using alltray
> with fluxbox (as WM) and docker (as systray) [1].
>
> I was able to reproduce this. Please find attached the output of
> "alltray -d" when the bug appears.
>
> Are these bugs related? Could this be fixed in the old-maintenance
> branch?
>
> If you need more information, don't hesitate to ask here, or on the
> Debian BTS thread.
>
> Thank you for your consideration.

I will take a look at this this evening. Thanks for the pointer!

 --- Mike

--
Even if their crude and anticompetitive business practices don't make
you think about using their software, their use of sweatshops and child
labor should: boycott Microsoft like you would any other amoral child
abuser: http://is.gd/btW8m

k anliot (mistertwig) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.