Alltray "close button minimizes to notification area" does not work when window button arrangement has been chagned from default.

Bug #192963 reported by JDS on 2008-02-18
4
Affects Status Importance Assigned to Milestone
AllTray
Medium
Unassigned
alltray (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: alltray

I like to have my window "close button" in the upper-left corner of my windows, ala Mac OS.

Alltray seems to assume that the "close button" is always going to be located in the upper-right corner of the window.

When I click on the close button, the app closes. But when I click on the button that is in the upper-right corner of the window, the app minimizes to the notification area.

The default window title/button order for Ubuntu is:

(Top Left -- middle -- Top Right)
menu -- Title -- minimize;maximize;close

MY window title/button layout is:

(Top Left -- middle -- Top Right)
close;menu -- Title -- minimize;maximize

Thus, when I click on the maximize button, the window actually minimizes to notification area.

Steps to Reproduce:

1) Configure window buttons. For example, with gconf-editor, change
/apps/metacity/general -> button_layout
to
"close,menu:minimize,maximize"

2) "Alltray" an application

3) Click on upper-right window button

Michael B. Trausch (mtrausch) wrote :

Reproducible in Hardy with the latest available Alltray package and the Metacity window manager under GNOME. Does not occur, however, when Compiz is the window manager.

Changed in alltray:
status: New → Confirmed
Changed in alltray:
importance: Undecided → Medium
milestone: none → alltray-0.8.0
status: New → Confirmed
Changed in alltray:
milestone: 0.8.0 → 0.7.4dev
Michael B. Trausch (mtrausch) wrote :

Hrm, looking at this, there have been changes made in releases up to Jaunty. Is this still an issue with the latest release of AllTray contained in the latest release of Ubuntu (9.04)?

Changed in alltray:
status: Confirmed → Incomplete
JDS (jsilveronnelly) wrote :

Yes, in Ubuntu 9.04, this bug is present as described. I haven't tried it in Ubunut 9.10 yet.

My system info:

 jeff@jeff-laptop:~
> cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"
 jeff@jeff-laptop:~
> alltray -v

Alltray version 0.69

Michael B. Trausch (mtrausch) wrote :

This is getting marked "confirmed", and targeted to 0.7.5dev, because this bug fix will be part of the close-to-tray support in AllTray's current development releases.

Changed in alltray:
milestone: 0.7.4dev → 0.7.5dev
status: Incomplete → Confirmed
Michael B. Trausch (mtrausch) wrote :

New AllTray is not affected by this problem. Old AllTray does make these assumptions and while patches will be accepted to fix them (perhaps from someone for Ubuntu?), new AllTray is quickly approaching globally usable and therefore this bug is considered "fix committed' in upstream AllTray.

Changed in alltray:
status: Confirmed → Fix Committed
Changed in alltray:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers