alien 8.95.3 cannot create any debs

Bug #1922996 reported by Rich on 2021-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alien (Ubuntu)
Undecided
Unassigned

Bug Description

As described in Debian bugs [1] and [2], alien 8.95.3 (and .1 and .2, but those aren't being shipped by any release of Ubuntu) cannot successfully generate any debs, ever - with neither bug patched, it will error out on attempting to generate any deb at all due to a syntax error in the debian/rules it generates, and with that fixed, it will incorrectly locate the files to be installed (e.g. /usr/include files will end up in /include, and so on).

Please package 8.95.4 for Hirsute, or anyone who wants to use alien to generate debs on Hirsute will be quite sad.

(Yes, to be clear, I did verify these bugs reproduce on Ubuntu's 8.95.3 alien package, though it was sort of a foregone conclusion, since Ubuntu doesn't appear to patch it at all.)

[1] - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=983492
[2] - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=985835

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers