[karmic] New upstream version available

Bug #346565 reported by Michael Kuhn on 2009-03-22
6
Affects Status Importance Assigned to Milestone
alexandria (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: alexandria

Version 0.6.4.1 has been released. It would be nice if the package could be updated.

Notable changes in 0.6.4.1:

    * Better GUI feedback when adding books by ISBN.
    * More stable (fixing or working around the "Icon view tooltips" crashes).
    * Removes the old, obsolete Amazon (AWS 3.x) provider and replaces it with the new Amazon AWS 4 provider.
    * Better handling of character encodings.
    * Added sounds to the "Acquire from Scanner" dialog for better feedback
    * New Greek, Macedonian, Norwegian (Bokmål) and Slovakian translations and updated translations for Italian, Polish, Portuguese (Brazil), French and Swedish.

Also see http://alexandria.rubyforge.org/news/2009-03-14--0.6.4-released.html.

Related branches

Michael Kuhn (suraia) on 2009-03-22
description: updated
Brian Curtis (bcurtiswx) wrote :

This is a wishlist item, marking as so

Changed in alexandria:
importance: Undecided → Wishlist
Michael Kuhn (suraia) wrote :

I took a shot at it, .diff.gz attached.
.orig.tar.gz from http://rubyforge.org/frs/download.php/53230/alexandria-0.6.4.1.tar.gz

It would be nice if someone could take a look at it. Package can be found in my PPA, and works fine here.

Brian Curtis (bcurtiswx) wrote :

Thank you for the diff and the bug report! We look forwards to your future reports.

Changed in alexandria:
status: New → Triaged
Lennart Karssen (l.c.karssen) wrote :

Hi Michael,

Thanks for packaging the latest version of Alexandria! Unfortunately I haven't yet found the time to learn how to make a decent package myself.

I've tried to install you package on a machine that has not had Alexandria installed before and there was a problem with the dependencies:

# aptitude install alexandria
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  alexandria
The following NEW packages will be installed:
  libruby1.8{a} ruby1.8{a}
0 packages upgraded, 3 newly installed, 0 to remove and 6 not upgraded.
Need to get 1470kB/4193kB of archives. After unpacking 11.1MB will be used.
The following packages have unmet dependencies:
  alexandria: Depends: libgnome2-ruby (>= 0.12.0) which is a virtual package.
              Depends: libglade2-ruby (>= 0.12.0) which is a virtual package.
              Depends: libgconf2-ruby (>= 0.12.0) which is a virtual package.
              Depends: libgettext-ruby1.8 (>= 1.7.0) which is a virtual package.
              Depends: libhpricot-ruby which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
alexandria [Not Installed]

Score is -9879

Accept this solution? [Y/n/q/?]

Could you have a look at this?
Thanks!

Michael Kuhn (suraia) wrote :

The dependencies look fine. I guess you do not have the universe component enabled. See https://help.ubuntu.com/community/Repositories/Ubuntu.

Lennart Karssen (l.c.karssen) wrote :

Thanks. I did have Universe enabled, so I must have made another mistake. The problem seems to have vanished although I don't know how exactly. But I've been messing with my repotories lately :-).

Michael Kuhn (suraia) wrote :

The new version is basically a maintenance release to bring all book metadata providers up to date and fix some stability problems.

The updated package was tested thoroughly using two large book libraries without any problems.

The build log can be found here: https://launchpad.net/%7Esuraia/+archive/ppa/+build/914818/+files/buildlog_ubuntu-jaunty-i386.alexandria_0.6.4.1-0ubuntu1~jaunty1_FULLYBUILT.txt.gz (This is just a PPA version of the package above.)

Michael Kuhn (suraia) wrote :
Michael Kuhn (suraia) wrote :

does the current version still work with amazon?

Yes, it does work with Amazon.

If the old version works, can this wait for the next Ubuntu release?

The old versions seems to work (though it did crash randomly while testing it :-)), so I guess this can wait for a bit longer.

Iain Lane (laney) wrote :

Deferring to Karmic per the latest comments. Thanks for your contribution!

summary: - New upstream version available
+ [karmic] New upstream version available
Scott Kitterman (kitterman) wrote :

Unsubscribing motu-release. If it's important for Jaunty, you can request a backport once it's in Karmic.

Michael Kuhn (suraia) wrote :

Could somebody take a look at this now that karmic is open? Thanks.

Andreas Moog (ampelbein) wrote :

Will work on the update.

Changed in alexandria (Ubuntu):
assignee: nobody → Andreas Moog (amoog)
status: Triaged → In Progress
Andreas Moog (ampelbein) on 2009-06-29
Changed in alexandria (Ubuntu):
assignee: Andreas Moog (amoog) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alexandria - 0.6.4.1-0ubuntu1

---------------
alexandria (0.6.4.1-0ubuntu1) karmic; urgency=low

  * New upstream release: (LP: #346565)
    - Better GUI feedback when adding books by ISBN
    - Removed the obsolete Amazon (ECS) provider and replaced it with the new
      AWS-based Amazon provider
    - Fixed several book providers (DeaStore, Siciliano, AdLibris & WorldCat)
    - Temporarily removed some broken providers
    - Now supports non-CueCat "keyboard wedge" barcode scanners;
      no settings interface yet, but you can run gconf-editor /apps/alexandria
      and set barcode_scanner to KeyboardWedge
    - Better (though not perfect) handling of character encoding
    - Improved stability (fewer crashes)
    - Bug fixes:
      [#19042] Icon view tooltips cause crashes on x86_64 (LP: #218715)
               [Work-around for an issue with ruby-gnome2 (pre 0.17.0)]
      [#20080] Icon view tooltips cause crashes when publisher not defined
      [#23908] Adding manually without ISBN is unstable
      [#10929] Usability: advanced settings checkbox invisible without Ruby/ZOOM
      [#20168] Cannot use non-western characters in Library names
      [#16707] Cancelling image change in book properties not as expected
      [#20201] Cannot export to ONIX or Tellico format
      [#9010] Crashes when cancelling a library import
  * debian/control:
    - bump Depends on ruby-gnome to 0.16
    - add Depends on libhtmlentities-ruby
    - add misc:Depends
  * debian/rules:
    - no longer move debian/tmp to debian/alexandria, that's not needed anymore
    - don't call dh_desktop

 -- Andreas Moog <email address hidden> Mon, 29 Jun 2009 16:29:43 +0200

Changed in alexandria (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers