ftbfs with python2.7

Bug #747225 reported by Matthias Klose on 2011-04-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
albatross (Ubuntu)
Medium
Unassigned

Bug Description

needs to use the old package python-old-doctools

https://launchpad.net/ubuntu/+archive/test-rebuild-20110329/+buildjob/2387934

DATE="`date +'%B %d, %Y'`"; \
 VERSION="`awk '/__version__/ {print $3}' ../albatross/__init__.py`"; \
 VERSION="`echo $VERSION | sed s/\\'//g`"; \
 cat albatross.tex | sed s/\\release.*/\\release\{$VERSION\}/ >albatross.tex2; \
 cat albatross.tex2 | sed s/\\date.*/\\date\{"$DATE"\}/ >albatross.tex
/usr/lib/python2.7/doc/tools/mkhowto --pdf --a4 albatross.tex
make[1]: /usr/lib/python2.7/doc/tools/mkhowto: Command not found
make[1]: *** [pdf] Error 127
make[1]: Leaving directory `/build/buildd/albatross-1.36/doc'
make: *** [build-doc-stamp] Error 2

Related branches

Barry Warsaw (barry) wrote :

I think it's worse than that. albatross already build-depends-indep on python-old-doctools, but the latter only provides /usr/lib/python2.5/doc/tools/mkhowto

Barry Warsaw (barry) wrote :

Okay, a simple fix is to hard-code the path to mkhowto provided by python-old-doctools. doc/Makefile already tries to guess where it is, but on Natty, this guess is incorrect because it comes up with Python 2.7 paths that don't exist.

Because albatross is having package-importer failures, no branch is available. I'll attach a debdiff.

Barry Warsaw (barry) wrote :
Changed in albatross (Ubuntu):
status: New → In Progress
assignee: nobody → Barry Warsaw (barry)
milestone: none → ubuntu-11.04-beta-2
importance: Undecided → Medium
assignee: Barry Warsaw (barry) → nobody
status: In Progress → Confirmed
Barry Warsaw (barry) on 2011-04-05
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package albatross - 1.36-5.4ubuntu1

---------------
albatross (1.36-5.4ubuntu1) natty; urgency=low

  * doc/Makefile: Hard code path to mkhowto for natty's
    python-old-doctools package. (LP: #747225)
 -- Barry Warsaw <email address hidden> Tue, 05 Apr 2011 18:29:14 -0400

Changed in albatross (Ubuntu):
status: Confirmed → Fix Released
Oussama BOUNAIM (obounaim) wrote :

Does this bug still apply for newer Ubuntu versions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers