Ubuntu

Please merge albatross 1.36-5.5 (universe) from Debian unstable (main)

Reported by Prasad Murthy on 2013-06-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
albatross (Ubuntu)
Undecided
Unassigned

Bug Description

Please merge albatross 1.36-5.5 (universe) from Debian unstable (main)

Prasad Murthy (murthy) on 2013-06-11
Changed in albatross (Ubuntu):
assignee: nobody → Prasad Murthy (murthy)
status: New → In Progress
Prasad Murthy (murthy) wrote :

Attached debdiff of debian and the new one

Prasad Murthy (murthy) wrote :

Added debdiff of old ubuntu and the new one

Changed in albatross (Ubuntu):
assignee: Prasad Murthy (murthy) → nobody
status: In Progress → Confirmed
Didier Roche (didrocks) wrote :

Hey Prasad, thanks for looking at this merge and help to make ubuntu better.

It's normally a good practice to relist in the changelog the diff with debian. For instance:

  * Merge from Debian unstable (LP: #1189942), remaining diff:
     - add the "foo" option to configure…
     - don't install "bar" functionality…

This enables then to just look at one changelog entry to know exactly why we have the diff to Debian, and eventually will be easier to upstream those.

Mind doing that? (I'm unsuscribing sponsors for now, feel free to rsubscribe them again once the fix is there)

Prasad Murthy (murthy) on 2013-06-13
Changed in albatross (Ubuntu):
assignee: nobody → Prasad Murthy (murthy)
Prasad Murthy (murthy) wrote :

Attached an debdiff of debian and the new one, requested changes are implemented.

Prasad Murthy (murthy) wrote :

Attached debdiff of old ubuntu and the new one, requested changes are implemented.

Prasad Murthy (murthy) wrote :

I have updated the changelog as requested and attached the new debdiffs.

Changed in albatross (Ubuntu):
assignee: Prasad Murthy (murthy) → nobody
Jeremy Bicha (jbicha) wrote :

Your remaining diff is:

* Set X-Python-Version: >=2.5
- That's an optional field and is unnecessary since both Debian & Ubuntu have Python 2.7 as the default Python (and there won't be a newer major Python 2 release).

* Break python-albatross-common (<< 1.36-5.4ubuntu2)
- That version was shipped before the most recent LTS and we do not support upgrades from pre-Ubuntu 12.04 LTS unless you upgrade to 12.04 LTS first.

We can drop both of those changes. However, there's one more change (from 1.36-5.4ubuntu2) that seems necessary to actually build this package in Ubuntu. Could you please resubmit your merge proposal with just this one change and then re-subscribe ~ubuntu-sponsors one more time.

Jackson Doak (noskcaj) wrote :

I've fixed the changelog in the linked branch, but didn't fully look into the package. I hope that's enough

Dmitry Shachnev (mitya57) wrote :

The third change mentioned by Jeremy is no longer needed, so I synced the package.

Changed in albatross (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers