Installing alacarte installs half of GNOME

Bug #925801 reported by Pasi Lallinaho
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alacarte (Ubuntu)
Wishlist
Lionel Le Folgoc

Bug Description

Installing alacarte in Xubuntu installs half of GNOME, including Unity and Compiz. This can be worked around by using --no-install-recommends, but since alacarte is a menu editor that should work with all desktop environments, this shouldn't be needed.

The packages which ultimately lead to installing Unity and Compiz should be removed from recommends. If that is not possible (something in Alacarte breaks when doing that), the parts that Alacarte need should probably be moved to their own packages.

This happens at least on 11.10.

Related branches

Unit 193 (unit193)
Changed in alacarte (Ubuntu):
status: New → Confirmed
Changed in alacarte (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Wishlist
assignee: nobody → Lionel Le Folgoc (mrpouit)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alacarte - 0.13.2-2ubuntu4

---------------
alacarte (0.13.2-2ubuntu4) precise; urgency=low

  * debian/patches/40-call-exo-d-i-e-on-xfce.patch: call exo-desktop-item-edit
    instead of gnome-desktop-item-edit when XDG_CURRENT_DESKTOP=XFCE.
  * debian/control: add alternate deps on libgarcon-common for gnome-menus and
    alternate recommends on exo-utils for gnome-panel as they provide the
    features needed by alacarte to work on Xfce. lp: #925801
 -- Lionel Le Folgoc <email address hidden> Sun, 05 Feb 2012 18:25:05 +0100

Changed in alacarte (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints