Ubuntu

When clicking "new separator", alacarte crashed with ValueError in __positionItem(): ('Separator',) is not in list

Reported by 702 Central on 2011-02-10
110
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Alacarte Menu Editor
Fix Released
Low
alacarte (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: alacarte

while editing the main menu could not add separators or new folders. Menu is rather large. Limitation to number of entries?

You are using Ubuntu 10.10 - the Maverick Meerkat - released in October 2010 and supported until April 2012.
alacarte ver 0.13.2-1ubuntu2

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: alacarte 0.13.2-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
Uname: Linux 2.6.38-2-generic i686
Architecture: i386
Date: Thu Feb 10 01:33:07 2011
ExecutablePath: /usr/bin/alacarte
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100831.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python -OOt /usr/bin/alacarte
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/alacarte']
SourcePackage: alacarte
Title: alacarte crashed with ValueError in __positionItem(): ('Separator',) is not in list
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video

702 Central (gary-mors) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Pedro Villavicencio (pedro) wrote :

maybe caused by debian/patches/01-new_item_location.patch

Changed in alacarte (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Hans Joachim Desserud (hjd) wrote :

Note that this does not seem to trigger a crash anymore (at least on Ubuntu 11.10 and later). However, nothing happens when clicking on "New separator" and the same error message as in the attached TraceBack is still printed.

tags: added: oneiric precise
summary: - alacarte crashed with ValueError in __positionItem(): ('Separator',) is
- not in list
+ When clicking "new separator", alacarte crashed with ValueError in
+ __positionItem(): ('Separator',) is not in list
Vadim Rutkovsky (roignac) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at https://bugzilla.gnome.org/show_bug.cgi?id=671384

Changed in alacarte:
importance: Unknown → Low
status: Unknown → New
Changed in alacarte:
status: New → Fix Released
Hans Joachim Desserud (hjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This issue has been fixed upstream and adding new separators now work as expected in alacarte 3.5.5-0ubuntu1.1 available in Ubuntu 12.10 and later releases. Thus, I am closing this bug as fixed.

However, it seems to still be present in Ubuntu 12.04 and earlier releases, so if you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "Requesting a Backport" at https://wiki.ubuntu.com/UbuntuBackports#Requesting_a_Backport

Changed in alacarte (Ubuntu):
status: Confirmed → Fix Released
LeeU (leeu) wrote :

This is a bit confusing. I am using Ubuntu 12.04 LTS, which is supposed to be supported until the middle of 2017 and is not updated with a new LTS until the middle of 2014, yet, according to Hans (Comment #5), an update for this problem won't be provided until the user's system is updated to one after 12.10? I know Hans said that a backport can be requested but there doesn't seem to be clear instructions: "Backports are requested by filing a bug against the appropriate backports project, as listed here" but when I click on the link this bug is not listed. In addition, I don't have a "ubuntu-dev-tools" in the Package manager. Plus, I want to get an update as Ubuntu states; I don't really want to be a tester ("As backports require testing before they can be approved, the backports team recommends that requesters of backports also test them when possible.").

Is there really any way to obtain this fix for v. 12.04?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.