Akregator corrupts the opml file and crashes, always.

Bug #1728347 reported by wens on 2017-10-29
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
akregator (Ubuntu)
Status tracked in Bionic
Artful
Critical
Simon Quigley
Bionic
Critical
Simon Quigley

Bug Description

[Impact]

Without this fix, Akregator can start crashing on initialization and corrupt data. Without a backup, this means data loss, and it also means a non-working Akregator.

[Test Case]

1. Launch Akregator and create a handful of feeds.
2. Restart Akregator several times.

Nothing should happen, but it will crash sometimes.

[Regression Potential]

Little to none. The contents of the if (app.isSessionRestored()) conditional is the same with the exception of the window being initialized before Akregator is restored.

[Original Description]

I noticed that Akregator started to crash on initialization. Then I noticed that it had corrupted to a small size my RSS feed file.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: akregator 4:17.04.3-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Oct 29 11:53:56 2017
InstallationDate: Installed on 2017-08-21 (68 days ago)
InstallationMedia: Kubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
SourcePackage: akregator
UpgradeStatus: Upgraded to artful on 2017-10-19 (9 days ago)

wens (alex-volegov) wrote :
description: updated
description: updated
wens (alex-volegov) wrote :
wens (alex-volegov) on 2017-10-29
tags: added: kubuntu-bugs
wens (alex-volegov) on 2017-12-15
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in akregator (Ubuntu):
status: New → Confirmed
Simon Quigley (tsimonq2) on 2018-01-21
Changed in akregator (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) wrote :

Bionic ships with a fixed version, Artful does not.

Changed in akregator (Ubuntu Artful):
assignee: nobody → Simon Quigley (tsimonq2)
importance: Undecided → Medium
status: New → Confirmed
Changed in akregator (Ubuntu Bionic):
status: Confirmed → In Progress
status: In Progress → Fix Released
Changed in akregator (Ubuntu Artful):
status: Confirmed → In Progress
Simon Quigley (tsimonq2) on 2018-03-19
Changed in akregator (Ubuntu Bionic):
importance: Medium → Critical
Changed in akregator (Ubuntu Artful):
importance: Medium → Critical
description: updated
Simon Quigley (tsimonq2) wrote :

Uploaded.

Hello wens, or anyone else affected,

Accepted akregator into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/akregator/4:17.04.3-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in akregator (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
wens (alex-volegov) wrote :

akregator (4:17.04.3-0ubuntu1.1) tested. 2 times corrupted opml files after reboot system.

tags: added: verification-failed-artful
removed: verification-needed-artful
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers