Ubuntu

akonadi fails if backend is switched because of dependencies

Reported by grou on 2012-01-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
akonadi (Ubuntu)
Medium
Unassigned

Bug Description

I installed kubuntu-desktop in Precise Pangolin (12.04), and kmail did not work out of the box.

It appeared that it needs the package akonadi-backend-mysql to work, but it is not in its dependencies nor it is in its dependencies' dependencies :

akonadi-backend-mysql is in "suggests" of akonadi-server.

Package: kmail
Priority: optional
Section: mail
Installed-Size: 3379
Maintainer: Kubuntu Developers <email address hidden>
Original-Maintainer: Debian Qt/KDE Maintainers <email address hidden>
Architecture: i386
Source: kdepim
Version: 4:4.8.0a-0ubuntu1
Replaces: akonadi-kde (<< 4:4.1.3), kmailcvt (<< 4:3.90.0), kontact (<< 4:4.2.85)
Provides: imap-client, mail-reader
Depends: kde-runtime, kdepim-runtime, kdepimlibs-kio-plugins, libakonadi-contact4 (>= 4:4.8), libakonadi-kde4 (>= 4:4.8), libakonadi-kmime4 (>= 4:4.8), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libgpgme++2 (>= 4:4.8), libkabc4 (>= 4:4.8), libkcalcore4 (>= 4:4.5.86), libkcalutils4 (>= 4:4.5.86), libkcmutils4 (>= 4:4.8), libkdecore5 (>= 4:4.8), libkdepim4 (= 4:4.8.0a-0ubuntu1), libkdeui5 (>= 4:4.8), libkio5 (>= 4:4.8), libkleo4 (= 4:4.8.0a-0ubuntu1), libkmime4 (>= 4:4.8), libknotifyconfig4 (>= 4:4.8), libkontactinterface4 (>= 4:4.8), libkparts4 (>= 4:4.8), libkpgp4 (= 4:4.8.0a-0ubuntu1), libkpimidentities4 (>= 4:4.8), libkpimtextedit4 (>= 4:4.8), libkpimutils4 (>= 4:4.8), libksieveui4 (= 4:4.8.0a-0ubuntu1), libmailcommon4 (= 4:4.8.0a-0ubuntu1), libmailtransport4 (>= 4:4.8), libmessagecomposer4 (= 4:4.8.0a-0ubuntu1), libmessagecore4 (= 4:4.8.0a-0ubuntu1), libmessagelist4 (= 4:4.8.0a-0ubuntu1), libmessageviewer4 (= 4:4.8.0a-0ubuntu1), libnepomuk4 (>= 4:4.8), libqt4-dbus (>= 4:4.5.3), libqt4-network (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.8.0), libsolid4 (>= 4:4.8), libstdc++6 (>= 4.6), libstreamanalyzer0 (>= 0.7.7), libstreams0 (>= 0.7.7), libtemplateparser4 (= 4:4.8.0a-0ubuntu1), perl
Recommends: gnupg2, gnupg-agent, pinentry-qt4
Suggests: kaddressbook, kleopatra, spamassassin | bogofilter | spambayes | bsfilter | crm114, clamav, procmail
Breaks: akonadi-kde (<< 4:4.1.3), kmailcvt (<< 4:3.90.0), kontact (<< 4:4.2.85)
Filename: pool/main/k/kdepim/kmail_4.8.0a-0ubuntu1_i386.deb
Size: 969418
MD5sum: 6bff7b5ed81cb03b0ece74f2b485b876
SHA1: f3d58004a8413728dd3672be984700c4a556eea5
SHA256: 91b754068b4f5ac9945ac3b1635c69565edecf924f4178a6fb5cd6ad3c0eabf6
Description-en: full featured graphical email client
 KMail is a fully-featured email client that fits nicely into the KDE
 desktop. It has features such as support for IMAP, POP3, multiple accounts,
 mail filtering and sorting, PGP/GnuPG privacy, and inline attachments.
 .
 This package also contains Nepomuk EMail Feeder Akonadi Agent.
 .
 This package is part of the KDE PIM module.
Homepage: http://kontact.kde.org/kmail/
Description-md5: de6424691ace5b563c821de50a5124f4
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 18m
Task: kubuntu-desktop, kubuntu-full, kubuntu-mobile-desktop, kubuntu-mobile-full, edubuntu-desktop-kde

Package: kdepim-runtime
Priority: optional
Section: kde
Installed-Size: 10391
Maintainer: Kubuntu Developers <email address hidden>
Original-Maintainer: Debian Qt/KDE Maintainers <email address hidden>
Architecture: i386
Version: 4:4.8.0a-0ubuntu2
Replaces: akonadi-kde, libmaildir4
Depends: kde-runtime, kdepimlibs-kio-plugins, libakonadi-calendar4 (>= 4:4.7.90), libakonadi-contact4 (>= 4:4.8), libakonadi-kabc4 (>= 4:4.8), libakonadi-kcal4 (>= 4:4.8), libakonadi-kde4 (>= 4:4.8), libakonadi-kmime4 (>= 4:4.8), libakonadi-notes4, libakonadiprotocolinternals1 (>= 1.5.1), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libkabc4 (>= 4:4.8), libkalarmcal2, libkcal4 (>= 4:4.8), libkcalcore4 (>= 4:4.7.0), libkcalutils4 (>= 4:4.5.86), libkcmutils4 (>= 4:4.8), libkdecore5 (>= 4:4.8), libkdeui5 (>= 4:4.8), libkidletime4 (>= 4:4.8), libkimap4 (>= 4:4.8), libkio5 (>= 4:4.8), libkmbox4 (>= 4:4.5.86), libkmime4 (>= 4:4.8), libknewstuff3-4 (>= 4:4.8), libknotifyconfig4 (>= 4:4.8), libkpimidentities4 (>= 4:4.8), libkpimtextedit4 (>= 4:4.8), libkpimutils4 (>= 4:4.8), libkresources4 (>= 4:4.8), libkrosscore4 (>= 4:4.8), libmailtransport4 (>= 4:4.8), libmicroblog4 (>= 4:4.8), libnepomuk4 (>= 4:4.8), libqt4-dbus (>= 4:4.5.3), libqt4-declarative (>= 4:4.7.0~rc1), libqt4-network (>= 4:4.5.3), libqt4-script (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqt4-xmlpatterns (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libsolid4 (>= 4:4.8), libsoprano4 (>= 2.4.3), libstdc++6 (>= 4.1.1), libxml2 (>= 2.7.4), akonadi-server (>= 1.3)
Breaks: akonadi-kde, kdepimlibs5 (<< 4:4.4), libmaildir4
Filename: pool/main/k/kdepim-runtime/kdepim-runtime_4.8.0a-0ubuntu2_i386.deb
Size: 2426286
MD5sum: 67fbbe865e06813c7c8a93149c9eeb64
SHA1: 15a6d92fafc422f81457b337d78ecf01bba4626a
SHA256: 1d5b9591a42f285d98828dba73a08301590a19c56a64c15b7a189fe0b15976a9
Description-en: Runtime components for akonadi-kde
 This package contains akonadi agents written using kdelibs.
 Any package that uses akonadi should probably pull this in as a dependency.
 The kres-bridges is also parts of this package.
 .
 This package is part of the kdepim-runtime module.
Description-md5: 1801103f9c4a5ceecb862bc3abf077c2
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 5y
Task: kubuntu-desktop, kubuntu-mobile-desktop, kubuntu-mobile, edubuntu-desktop-kde, edubuntu-desktop-gnome

Package: akonadi-server
Priority: extra
Section: net
Installed-Size: 2181
Maintainer: Kubuntu Developers <email address hidden>
Original-Maintainer: Debian Qt/KDE Maintainers <email address hidden>
Architecture: i386
Source: akonadi
Version: 1.7.0-0ubuntu1
Depends: libakonadiprotocolinternals1 (= 1.7.0-0ubuntu1), libboost-program-options1.46.1 (>= 1.46.1-1), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libqt4-dbus (>= 4:4.6.1), libqt4-network (>= 4:4.6.0), libqt4-sql (>= 4:4.6.0), libqt4-xml (>= 4:4.6.0), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.6.0), libsoprano4 (>= 2.2.69), libstdc++6 (>= 4.4.0), akonadi-backend-mysql (= 1.7.0-0ubuntu1) | akonadi-backend-sqlite (= 1.7.0-0ubuntu1) | akonadi-backend-postgresql (= 1.7.0-0ubuntu1)
Suggests: akonadi-backend-mysql (= 1.7.0-0ubuntu1), akonadi-backend-sqlite (= 1.7.0-0ubuntu1), akonadi-backend-postgresql (= 1.7.0-0ubuntu1)
Filename: pool/main/a/akonadi/akonadi-server_1.7.0-0ubuntu1_i386.deb
Size: 585612
MD5sum: 57a665309bd28e121af609477af41c1c
SHA1: 9692012549e515a67c1d2adbea5c46ef3cb4de8e
SHA256: 787ef8790c540a20678fbd84fab7ac05b32c5ce391a4af6879f2bd86c1b38001
Description-en: Akonadi PIM storage service
 Akonadi is an extensible cross-desktop Personal Information Management (PIM)
 storage service. It provides a common framework for applications to store and
 access mail, calendars, addressbooks, and other PIM data.
 .
 This package contains the Akonadi PIM storage server and associated programs.
Homepage: http://pim.kde.org/akonadi
Description-md5: 80144a9a021e5f971cbb61777684d38e
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 5y
Task: kubuntu-desktop, kubuntu-mobile-desktop, kubuntu-mobile, edubuntu-desktop-kde, edubuntu-desktop-gnome

Related branches

Philip Muškovac (yofel) wrote :

Thank you for reporting this issue and helping to make K/Ubuntu better. Can you please check if 'akonadi-server' is installed? And if yes, which backend? (akonadi-backend-mysql/-sqlite/-postgresql - mysql probably not as that's what your problem seems to be) Thanks.

Changed in kdepim (Ubuntu):
status: New → Incomplete
grou (grou) wrote :

akonadi-server was installed, but not akonadi-backend-mysql.

It works fine since I installed akonadi-backend-mysql (but I had to it manually)

grou (grou) wrote :

About akonadi-backend-postgresql and -sqlite, I can't remember if they were installed when this problem ocurred. So I reproduced it :

apt-get remove kmail akonadi-server akonadi-backend-mysql

Then I reinstalled akonadi-server and kmail -> kmail does not work saying "The Akonadi personnal information management service is not operational" (Akonadi Server Self-Test return this report : see attachment)

Then, I reinstalled akonadi-backend-mysql and "akonadictl restart", relaunched kmail, and yet it works.

The issue may be that the package akonadi-backend-mysql is both in depends and in suggests of akonadi-server.

Philip Muškovac (yofel) wrote :

Well, it depends on one backend, and suggests all of them which is fine per se. The problem is that once you decide on a backend in the settings removing that specific backend will render akonadi unfunctional even if another backend is installed instead.

summary: - kmail crash at startup : dependencies issue
+ akonadi fails if backend is switched because of dependencies
affects: kdepim (Ubuntu) → akonadi (Ubuntu)
Changed in akonadi (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package akonadi - 1.7.0-0ubuntu3

---------------
akonadi (1.7.0-0ubuntu3) precise; urgency=low

  * make akonadi-server require the mysql backend. It's the only one really
    supported upstream and as the default backend has to be installed.
    (LP: #923189)
 -- Philip Muskovac <email address hidden> Mon, 09 Apr 2012 18:49:42 +0200

Changed in akonadi (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers