Ubuntu

cant find resource agents

Reported by Giulio Spinozzi on 2010-04-03
246
This bug affects 47 people
Affects Status Importance Assigned to Milestone
akonadi (Ubuntu)
Medium
Harald Sitter
Lucid
Medium
Harald Sitter

Bug Description

THIS IS A META BUG!

The "cant find resource agents" has loads of different causes as seen in the various comments.

https://bugs.launchpad.net/bugs/583735
Presents a cause where the startup would time out and trigger the error dialog, even though there was really no error, but akonadi just did not finish starting at the time of testing.

Other issues seem to be mostly mysql related.

PLEASE DO REPORT NEW BUGS instead of tossing your stuff in here.

tags: added: kmail
tags: added: akonadi
affects: kubuntu-default-settings (Ubuntu) → akonadi (Ubuntu)
summary: - Kmail crash for akonadi error in XDG_DATA_DIRS
+ cant find resource agents
Bernhard (b.a.koenig) wrote :

I have this also at the start of Kmail and I still get the "MySQL server failed" message (akonadi-server 1.3.1-0ubuntu2). The most annoying part of it is that if I hit "Cancel" at the akonadi message, then it quits Kmail!

Changed in akonadi (Ubuntu):
status: New → Confirmed
Luis Silva (lacsilva) wrote :

I suspect this is a libakonadi problem as it happens with kaddressbbok too.

Changed in akonadi (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
importance: Undecided → Medium
assignee: nobody → Harald Sitter (apachelogger)
milestone: none → ubuntu-10.04
Changed in akonadi (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package akonadi - 1.3.1-0ubuntu3

---------------
akonadi (1.3.1-0ubuntu3) lucid; urgency=low

  * Set VCS fields to Bazaar branches
  * Sync kubuntu_01_fix_init.diff with upstream SVN as per KDE bug 185395.
    + akonadi-server depends on mysql-server-core-5.1 (>= 5.1.41-3ubuntu11)
    + akonadi-server depends on mysql-client-core-5.1 (>= 5.1.41-3ubuntu12)
  * Expand apparmor profile to silence apparmor complaints in syslog,
    additonally this seems to fix LP: #554514
 -- Harald Sitter <email address hidden> Mon, 12 Apr 2010 17:13:38 +0200

Changed in akonadi (Ubuntu Lucid):
status: Fix Committed → Fix Released

Do i have to remove my kde settings again to have the problem fixed?

I am using the most recent version and it's still there. But I am using this profile since Beta1.

Lothar (lothar-tradescape) wrote :

I am using Lucid since Alpha. Some update broke akonadi and it still does not work (yet). Let me know if I can provide any attachments that may help.

BTW; last week I have removed my .kde dir and all remaining directories mentioning akonadi in my home dir, deinstalled and purged all KDE packages and reinstalled the kdepim packages. Still the same problem :-(

Sad to see no PRogress here. The bug is not fixed and kontact is not usable for many people. IMHO this bug should have a higher priority and be reopened...

Harald Sitter (apachelogger) wrote :

Well, you know how it is, people say this and people say that and yet they do not attach akonadi self-test logs making it absolutely and completely impossible to do anything about this issue, other than bumping the timeout yet again, which of course does only solves 1 of 8 possible causes for the presented error.

Why don't you just ask for it. I don't see requests here for akonadi logs...

yannek (yannek) wrote :

I see the same error message on akonadi startup. My error log is practically the same.

Changed in akonadi (Ubuntu Lucid):
status: Fix Released → New
Marcus Ilgner (milgner) wrote :

I just came across this error, too. It seems to work now after changing XDG_DATA_DIRS to include /opt/kde/share as suggested by this posting

http://forum.kde.org/viewtopic.php?f=20&t=85072

Adrian Patzak (zoiss) wrote :

Hi guys, the same problem for me. Tried several stuff but nothing helped. Unfortunately I'm not able to use Kontact properly now.
Also adding /opt/kde/share to XDG_DATA_DIRS did not work for me.

Well you can use kontact, it's just not possible to retrieve any addresses from the server, so if you want to write someone an email better have his address ready...
(And nepomuk/virtuoso drives me crazy after I start kontact, as it keepy one CPU busy for more than 16h now, but that's another story...)

Harald Sitter (apachelogger) wrote :

"XDG_DATA_DIRS to include /opt/kde/share" is not going to change anything, in the presented forum this ought to fix the issue because the user is running a gentoo-based system and hence his KDE is in a directory other than the default.

The reason it worked for Marcus is something I call the ghost problem. See, the error this bug report complains about, can have a billion reasons to occur and a lot of them involve previously unclean shutdowns or just general weirdness, which means that usually after a 2nd or 3rd start the ssue will not be there anymore because you stack the akonadi parts on top of each other...

Harald, when you have any hints what I could do to have a working akonadi, I'd do it. This really annoys me and prevents me from working normally...

Well, I have purged all kde packages and removed all kde settings and the problem occured again as soon as I have used kontact again.

Are there any options to raise the loglevel or something like that to help you track the problem?

I am (or we are?) willing to help, but I am just a kontact user, I have no clue what I can do to debug this myself.

Harald Sitter (apachelogger) wrote :

If anything you need to purge .local/share/akonadi and .config/akonadi, akonadi is KDE independent.

Anyhow, as for additional information for debugging...
1. kdebugdialog -> turn on everything
2. logout -> login
3. start akonadi by whatever means make sense (make sure the error occured)
4. logout
5. go to a terminal (tty, e.g. by pressing ctrl+alt+f1, you can go back with same for f7 OR f8) and secure the file ~/.xsession-errors
6. login
7. start akonadi (should spit out the error)
8. start akonadi again (should spit out the error or work)
9. start akonadi again (should work)
10. also secure current ~/.xsession-errors (can be from within the session)

Upload all .xsession-errors files AND the akonadi self-test reports (if possible). That should hopefully give an idea why your control process commits suicide and your error logs are dirty.

It is however, entirely possible that you just hit the startup timeout... another Kubuntu dev who is experiencing this issue is currently trying if raising the timeout helps.

Harald Sitter (apachelogger) wrote :

> If anything you need to purge .local/share/akonadi and .config/akonadi, akonadi is KDE independent.

That refers to resetting akonadi, it does however not help with debugging... in fact it is more of preventing debugging ;)

Minh Ha Duong (haduong) wrote :

Many useability bugs:
- The French localization strings orthographic issues "service...enregistrer" "assuez-vous"
- The error messages are not really helpful. I do not know what is "a resource agent", how and where to set "the XDG_DATA_DIRS environment variable", or how to check that it contains the Akonadi agents. Please someone provide a script.
- The official troubleshooting page says Nepomuk should be enabled in System Preferences/Advanced/Desktop search. That condition should be detected, and the information should be reminded where it matters (i.e. a warning when one is disabling Nepomuk on a system with Akonadi, and a warning when one is starting Akonadi on a system with Nepomuk disabled, with an option to start it.)

I hope the apparmor bugs have been fixed..

xapient (xapient) wrote :

akonadictl start | kontact

(just a small change to the desktop link to work around this bug)
In 2 cases i experienced the problem was that akonadi was not there when kontact loaded the contacts component.. starting akonadi before kontact makes the problem disappear..

Hmm Xapient, I can't imagine how this will solve a startup problem of akonadi. The problem with the missing resource agents seems to apear when you start just akonadi too...

OK, I did as you aseked and enabled debugging for everything.
The first xsession-errors was surprisingly short and contained only gnome stuff, but the second one shows interesting elements.
It appears that the timeout theory is not bad. Kontact logs that akonadi had 0 agents and after that akonadi starts to log stuff and reports the agent it found.

Harald Sitter (apachelogger) wrote :

Are you running GNOME as desktop?

correct, I'm running Ubuntu Lucid. Kontact and Amarok are the only kde programms that I use frequently. (Well, "kontact" daily, of course) ;-)

I have added the regular kde addressbook resource (with addressbook in imap folder option) and suddenly my contacts show up and I can see in akonadi console that the contacts were added.

I don't know why the kolab plugin itself didn't work, but at least I can work normally now... BTW: I have started kmail twice again to get akonadi to work without error.

Damn, the kde addressbook entry suddenly disappeared. :-(

I have added it again. We'll see how long that will stay there...

At least I have a work-around for a few minutes if I need an address.

Harald Sitter (apachelogger) wrote :

To be honest, from the xsession-errors and what you just wrote about the resource I would think that it is more of a migration issue in non-KDE systems... :/

That may be true, but nevertheless, it should be fixed ;-)
It's not uncommon to use kontact as gnome user (frankly evolution is IMHO unusable). And when you have to connect to a kolab server you have to use kontact, because it's the only client that supports mail/contacts/calendar besides the webclient, which doesn't support pgp/smime of course...

Mathias Dietrich (theghost) wrote :

Same Issue here on fresh Lucid install.

xapient (xapient) wrote :

@Patrick Cornelissen: on a fresh lucid install (twoday) (after adding an akonadi-resource in systemsettigs-advanced-kderesources, adding "personal contacts" and importing my contacts ) the problem exists only on first start of kontact... running "akonadictl start" before makes the problem dissapear .. this is just an observation (and therefore the little workaround does the trick for me)

sorry if i missunderstood the initial bugreport and i am dealing with an other/different situation

ArmiDuctor (armiductor) wrote :

Same problem here! I would like to help, but I don't know how to make akonadi self-test logs. Please tell us in detail what is needed to squash this bug!

Harald Sitter (apachelogger) wrote :

See. There is this self-test dialog, that this report is very based on, because otherwise everyone who is affected wouldnt know that they are affected because they simply wouldnt know that it is about resource agents.
So. This very dialog contains like 3 buttons, of which 2 are related to grab the whole log and post it somewhere, or save it. And that is how you make (or in this rather store) an akonadi self-test log.

Adrian Jadic (jadic) wrote :

just wanted to confirm the behaviour and clarify a few things.

1. If Kontact is started it displays the akonadi error as described above.
2. If Kontact is closed and restarted the problems multiply.
3. Reason for this is that contact continues to run after X-out. To verify, go to System monitor.
4. If in system monitor one kills kontact then when started again it starts ok
5. As mentioned by xapient these problems do not occur if Akonadi is started separately (ex: using the akonadi tray
utility) and kontact is started after akonadi.

I am using a fresh install of kubuntu 10.04 64-bit

Peter (jynyl) wrote :

Similar symptoms here, on fresh install of Kubuntu 10.04 AMD64.
Akonadi self test report attached. This is on restart after updates (including kernel, hence the restart), and the Akonadi in system tray said it was running. Kontact started, but Contacts didn't; just grayed out with the red square.

ArmiDuctor (armiductor) wrote :

Here is my Akonadi self-test report too.

rifd (rdohmeier) wrote :

On ins

rifd (rdohmeier) wrote :

On installing Lucid the link from my address book to the contact file was lost, and that was easy to reinstate. My Akonadi birthday resource reported the error that is the subject of this bug report. I followed the steps in https://bugs.launchpad.net/ubuntu/lucid/+source/akonadi/+bug/554514 and substituted the location of my address / contacts file in the command:
export XDG_DATA_DIRS="/location of my contacts file:$XDG_DATA_DIRS",
and all is well now.

tomwu (thomw) wrote :

I've got the same problem.
1. Right after starting kde
$ akonadictl status
Akonadi Control: stopped
Akonadi Server: stopped
Akonadi Server Search Support: available (backend: Virtuoso)

2. When I start kontact, akonadi displays the error: "No resource agents found". But executing again
$ akonadictl status
Akonadi Control: running
Akonadi Server: running
Akonadi Server Search Support: available (backend: Virtuoso)

3. Now closing kontact and starting it again akonadi is working, without an error.

My next try was just after logging into kde session
1. $ akonadictl start
Now akonadi is running, and kontact is working without errors.

So a possible work around may be to execute akonadictl start as a script in the autostart, right after logging in.

Vistaus (djmusic121) wrote :

I can confirm this problem.

It's solvable by doing right click on Akonadi in the system tray and choosing Configure.. and the hitting the Test..-button. Then restart Kontact and everything works. But you have to do that every time you log in to Kubuntu, so that's annoying.

Lothar (lothar-tradescape) wrote :

I did the sequence in #16 and here are the akonadi logs
@Harald Sitter: I did not attach the xsession-error files publicly, as they contain a lot of private paths. I can send them to you by mail if you want them .

Marco Cimmino (cimmo) wrote :

> To be honest, from the xsession-errors and what you just wrote about the resource I would think that it is more of a migration issue in non-KDE systems... :/

No, my is 100% kubuntu/kde system and I have this error message at every startup of Kontact, attaching selftest.

Peter (peterroots) wrote :

Just to add to what has already been said - I have this same problem. I am using akonadi to link to a google calender and addressbook but not to my standard kde address book and calendar (I was but stopped because of the problems I was having every time I started up my computer).
I can confirm that if I stop anything and everything related to Kontact, stop Akonadi, start Akonadi, start Koantact all works as expected. But if I let things happen as normal Akonadi complains of no resource agents.
If I stop Kontact and Akonadi and then start Kontact I get the error as well (which I how I generated the selftest attached)

tomwu (thomw) wrote :

@Peter, try putting the following script in ~/.kde/Autostart and of course make it executable.
------
#!/bin/bash

/usr/bin/akonadictl start
------

It's not a solution, but it works for me.
It maybe fail, if kontact is also started at the beginning of your kde session automatically.

Peter (peterroots) wrote :

sorry tried to get self test and mysql error and ended up with nothing

Peter (peterroots) wrote :
Peter (peterroots) wrote :

tomwu - thanks for the suggestion but Kontact starts as it is normally running when I shutdown (the reminder daemon is running) but I will see if I can force akonadi to start first

Nick Sanders (nicksanders11) wrote :

tomwu - thanks
That works for me too

wj.Bijl (wj-bijl) wrote :

Possible workout:
do not use kontact anymore, only use korganizer: the problem is bypassed... (;--/))
or
first start kaddressbook and wait till the error message disappears (and solves the problem) and then start kontact.

Peter (peterroots) wrote :

wj - that is even worse a situation. Start korganizer - no errors, akonadi resouce is ticked but no events show up. Untick, tick and the events now show up. shut down korganizer and I am told there is an error saving akonadi resource when not connected (even though the akonadi tray icon shows it is up and running.

tomwu - just set up your fix, will report back after reboot

Peter (peterroots) wrote :

tomwu - worked fine after a reboot, I was worried the session restore (or whatever it is that brings up kontact) would get in first but it does not so no extra fiddling required to make your fix work. Thanks

wj.Bijl (wj-bijl) wrote :

Peter - You're right. So i've also tried tomwu's solution... and that worked fine. Thanks.

Peter (peterroots) wrote :

Think I spoke too soon - I have done a lot of reboots, trying to fix a sound problem, and I get akonadi up ok about 1 in 4 times

Peter (peterroots) wrote :

Now I am back to a failure every time again - just stopping akonadi and starting it again fixes it though (using akonadi tray) (still have the autostart script though)

Kevin Funk (krf) wrote :

Just curious, does this bug affect new installs (when installing from Kubuntu 10.04 release)?
I'm also affected by this bug caused by some update while running alpha version.

Yes the problem also occurs on fresh installs

Am 19.05.2010 19:55 schrieb "Kevin Funk" <email address hidden>:

Just curious, does this bug affect new installs (when installing from
Kubuntu 10.04 release)?
I'm also affected by this bug caused by some update while running alpha
version.

--
cant find resource agents
https://bugs.launchpad.net/bugs/554514
You received this bug notifica...

Kevin Funk (krf) wrote :

Then I'd consider this bug's importance as pretty high, Kontact and components are not usable at all. That's _really_ inconvenient for new users.

Peter (peterroots) wrote :

and it mucks up Kopete if the addressbook links are used - it is a real killer if you can't make sensible use of PIM applications
Stoping and starting Akonadi every time you start your computer really would send a new user right back where they came from and is highly irritating for old users who are used to a system that worked before they installed the 'new improved' version (LTS for stability and reliability)

Harald Sitter (apachelogger) wrote :

Please take a look at https://bugs.edge.launchpad.net/ubuntu/+source/kdepimlibs/+bug/583735 and add your logs there if you think you are affected by this particular cause. I'll try to get that issue resolved ASAP, but for that I need more logs and know who exactly is affected by that issue.

Rafal-maj-it (rafal-maj-it) wrote :

Akonadi and Nepomuku, this makes me want to sepuku ;)

This is critical bug, people can't use kde applications!

I recently installed a fresh kubuntu 10.04 and couldn't use kmail because of this bug. I followed some of the steps in
http://userbase.kde.org/Akonadi_4.4/Troubleshooting and https://bugs.launchpad.net/ubuntu/+source/akonadi/+bug/578357
in particular:

akonadictl stop
rm -r /storage/home/nuno/.local/share/akonadi/db_data

sudo aa-complain mysqld
sudo aa-complain mysqld-akonadi
sudo /etc/init.d/apparmor reload

mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data

akonadictl start

and it solved the problem. I honestly think that this should be considered a high priority bug, since a new user would be baffled for the needs to go through all the hoops to have basic functionality (email!) working...

Harald Sitter (apachelogger) wrote :

Until some of you confirm that you are affected by https://bugs.edge.launchpad.net/ubuntu/+source/kdepimlibs/+bug/583735 the major cause of this issue cannot be fixed.

Please confirm the bug by posting your akonadi self-test log (only if it matches the description of course ;)).

Changed in akonadi (Ubuntu Lucid):
status: New → Invalid

Kontact doesn't close when the timeout happens, but the the rest of the mentioned bug looks exactly like this bug here and our described behaviour. Or am I missing a point here?

IMHO the other bug is a duplicate to this.

I'm affected by this as well. When I start kaddressbook, I get these errors and none of my addressbooks don't appear.

I suggest the Importance be raised from Medium to Critical 32 people are marked as being affected, and in some cases the bug represents a major data loss-- my workaround will likely be find the raw data file, and import them to Evolution.

description: updated
jp.seixas (joaopseixas) wrote :

After a fresh install on 2 different machines, I've got "Akonadi is not operational" error message when I try to use Kontact. It says that "no resource agents have been found".

Kubuntu 10.04 is simply not usable for professional purposes. :-(

Sanjaya Karunasena (sanjayak) wrote :

I too have the same issue. The workaround given by tomwu @ https://bugs.launchpad.net/ubuntu/lucid/+source/akonadi/+bug/554514/comments/42 works. I don't know the implementation details but confident that there must be an easy way to check the akonadi process states before trying to use it and wait for it to start without relying on timing.

However, let's appreciate what we get for free and help improve it collectively. :-)

schwein (schwoz) wrote :

Guys this bug should be highest priority, it is a SHOWSTOPPER!!
An operating system without mail and addresses is doomed! Such a fragile Framework such as akonadi shoud be removed from the distro at this stage of development, it messes it up!
Not only for newcomers, I have accumulated hundrets of addresses o9ver the past years and currently cannot access them!!! this is crazy!

I have installed Lucid on 3 computers, and on non of them akonadi works. All 3 have been new installes but used home dirs from 9.04 and 8.04 kubuntu.

I have tried a lot of things that I found on the web. Some of them could fix the problem only temporarily. (like putting the path on XDG_DATA_DIRS=/usr/share:/usr/share:/usr/local/share
or autostart akonadi).

After I put exported XDG_DATA_DIRS=/usr/share:/usr/share:/usr/local/share my old addresses showed up but the next time I logged in akonadi was dead again, showing me some database issues.

checking strigi in Nepomog config worked for 1 session then nothing worked anymore, but I am not sure whether strigi has been the reason as it appears inactive!?

autostart akonadi did not work

Below some more logs in the hope this might help.

Here is akonadiserver.error:
Database process exited unexpectedly during initial connection!
executable: "/usr/sbin/mysqld-akonadi"
arguments: ("--defaults-file=/home/joerg/.local/share/akonadi//mysql.conf", "--datadir=/home/joerg/.local/share/akonadi/db_data/", "--socket=/home/joerg/.local/share/akonadi/db_misc/mysql.socket")
stdout: ""
stderr: ""
exit code: 1
process error: "Unknown error"

Here is a log after $ akonadictl start
[akonadiserver] /usr/bin/mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/home/xxx/.local/share/akonadi/db_misc/mysql.socket' (2) when trying to connect
[akonadiserver] FATAL ERROR: Upgrade failed
[akonadiserver] Database process exited unexpectedly during initial connection!

comment mysql.socket does not exist in '/home/xxx/.local/share/akonadi/db_misc/'

Hi!

2010/7/6 schwein <email address hidden>:
> Guys this bug should be highest priority, it is a SHOWSTOPPER!!
> An operating system without mail and addresses is doomed! Such a fragile Framework such as akonadi shoud be removed from the distro at this stage of development, it messes it up!
> Not only for newcomers, I have accumulated hundrets of addresses o9ver the past years and  currently cannot access them!!! this is crazy!

My current workaround is:
1. start kontact
2. wait until akonadi error dialog appears
3. close (only!) kontact
4. start kontact

Then you have your contacts again.

BTW: The higher timeout doesn't help, the error messages comes anyway.
It now just takes longer. looks like kontact does something wrong very
early on.

--
Mit freundlichen Grüßen, // Bye,
  Patrick Cornelißen
  http://www.openprojectguide.org
  http://www.pcornelissen.de http://code.google.com/p/gloudy/

Kent57 (kent5700) wrote :

I figured I had it fixed but it's started again! Akonadi error messages and NO Kontacts. This is really frustrating. Now I have to go searching for the problem again.
Thankfully Patrick's workaround above gets my addresses back.
Not what you would call ready for prime time.

I've solved finally!!!!
I've upgraded KDE to 4.5, from backports, and now the problem is solved, for me.

Harald Sitter (apachelogger) wrote :

Maverick carries KDE 4.5 and this should indeed not be appearing there anymore. Closing.

Changed in akonadi (Ubuntu):
status: New → Fix Released
Ype (ykingma) wrote :

I'm using KMail 1.13.5 from Gnome (Ubuntu 10.10).

To start KMail at login the following command works nicely:

bash -c "akonadictl start; sleep 5; kmail"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.