[SRU artful] korganiser reminders do not trigger with 17.04.3

Bug #1730513 reported by Rik Mills
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Akonadi
Fix Released
Medium
akonadi (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

akonadi: 4:17.04.3-0ubuntu in artful and 4:17.04.3-0ubuntu1 and ubuntu2 in bionic

When the korganizer tray daemon (koragc) is set to enable event reminders, these silently fail to appear.

Seemingly upstream KDE bug: https://bugs.kde.org/show_bug.cgi?id=384212

With back-portable fix from the 17.08 branch: https://cgit.kde.org/akonadi.git/commit/?h=Applications/17.08&id=d3c6ba904798768b0c83c2e182c27b1c624f78ca

Test build for artful in: https://launchpad.net/~rikmills/+archive/ubuntu/akonadi-bug

*** SRU information ***

[Impact]

 * An expected and relied on feature of KDE PIM (appointment and event reminders) shown on the desktop etc does not work.

 * Fix is a single non extensive commit that the upstream KDE developer considers is likely to be safe to backport.

[Test Case]

 * Use korganiser to set a calendar item with a reminder

 * Make sure the organiser tray daemeon is running (koragc), and that reminders are enabled.

 * Test if a reminder is shown at the selected appropriate time relative to the event (can be a few mins delay in some cases)

 * In addition, generally test that adding, modifying, viewing event information works as before.

* Test other KDE PIM applications as much as is practical

[Regression Potential]

 * Single commit that upstream considers should not be problematic to backport.

 * As akonagi acts as the storage backend for PIM generally, it is unlikely but possible there could be unintended impacts. Testing of other parts of the PIM stack, as much as is practical is advisable.

Rik Mills (rikmills)
Changed in akonadi (Ubuntu Artful):
status: New → Confirmed
description: updated
Changed in akonadi:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Andrzej Kornaszewski (kajko) wrote :

Artful test build restores Korganiser reminders.

Revision history for this message
flamboyant (flamboyant) wrote :

the fix in the test build for Artful worked for me.

Rik Mills (rikmills)
Changed in akonadi (Ubuntu Bionic):
status: New → Fix Committed
Changed in akonadi (Ubuntu Artful):
status: Confirmed → In Progress
Rik Mills (rikmills)
summary: - korganiser reminders do not trigger with 17.04.3
+ [SRU artful] korganiser reminders do not trigger with 17.04.3
Rik Mills (rikmills)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package akonadi - 4:17.04.3-0ubuntu3

---------------
akonadi (4:17.04.3-0ubuntu3) bionic; urgency=medium

  * debian/patches: Add upstream_fix_korganiser_reminders.patch
    Backport upstream fix for KDE Bug:384212 so the korganiser daemon
    can access and act on reminders (LP: #1730513)

 -- Rik Mills <email address hidden> Tue, 07 Nov 2017 12:44:50 +0000

Changed in akonadi (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Travis Odom (travis-a-odom) wrote :

Was this ever going to get pulled into Artful? "Reminders don't work at all" seems like a big thing to just sit with an available fix for 5 months now

Revision history for this message
maslobojik (maslobojik) wrote :

notifications do not work!!!!!!!!!!!

Rik Mills (rikmills)
Changed in akonadi (Ubuntu Artful):
status: In Progress → Won't Fix
Revision history for this message
maslobojik (maslobojik) wrote :

a piece of shit

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.