akonadi-server too dependent on MySQL and prevent percona instalation

Bug #1336005 reported by Raul Dias on 2014-06-30
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
akonadi (Ubuntu)
Medium
Philip Muškovac
Trusty
Medium
Unassigned

Bug Description

There are a few serious packaging problems with akonadi:

1 - akonadi-server depends on akonadi-backend-mysql.
      It can also work with postgresql and sqllite, but mysql is mandatory, it should be optional.

2 - akonadi-backend depends on either mysql-server-core-5.5 or mariadb-server-core-5.5

2.1 - depending on a specific version of mysql is very bad. If there is a need for a feature on 5.5, it should be something like:
mysql-server-core >= 5.5. As 5.6 has all feature of 5.5, it still cannot be installed.
The same goes to the clients too.

2.2 - the percona-server-(server|client) should be added to the mix.
PPA: http://www.percona.com/doc/percona-server/5.5/installation/apt_repo.html

Basically the choice is either use mysql|mariadb 5.5 or no kde.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: akonadi-server 1.12.1-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.13.0-30.54-generic 3.13.11.2
Uname: Linux 3.13.0-30-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Jun 30 16:56:55 2014
InstallationDate: Installed on 2014-05-12 (49 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: akonadi
UpgradeStatus: No upgrade log present (probably fresh install)

Raul Dias (rsd) wrote :

Confirmed, this bug prevents users from replacing mysql with percona packages. A quick fix is to extract akonadi -backend-mysql page, modify control file (change Depends), repack .deb file and reinstall (the solution below is more or less working - I'm tweaking the Depends section now)

apt-get install --reinstall --download-only akonadi-backend-mysql
mv /var/cache/apt/archives/akonadi-backend-mysql_1.12.1-0ubuntu1.1_all.deb .
ar x akonadi-backend-mysql_1.12.1-0ubuntu1.1_all.deb
tar xvzf control.tar.gz
vi control
Depends: virtual-mysql-server-core | mariadb-server-core-5.5 | percona-server-server, mysql-client-core-5.5 | mariadb-client-core-5.5 | percona-server-client-5.6, libqt4-sql-mysql
rm control.tar.gz
tar c postinst postrm md5sums control conffiles | gzip -c > control.tar.gz
ar rcs akonadi-backend-mysql_1.12.1-0ubuntu1.1_percona_all.deb debian-binary control.tar.gz data.tar.xz
dpkg -i akonadi-backend-mysql_1.12.1-0ubuntu1.1_percona_all.deb

apt-get install percona-server-server-5.6 percona-server-client-5.6

For the above to work with percona-server, control file in percona-server-server package MUST list , mysql-server-core-5.5, mysql-server-core-5.6 in both Replaces and Provides sections

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in akonadi (Ubuntu):
status: New → Confirmed
Philip Muškovac (yofel) on 2015-04-14
Changed in akonadi (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
importance: Undecided → Medium
status: Confirmed → In Progress
Philip Muškovac (yofel) on 2015-04-15
Changed in akonadi (Ubuntu Trusty):
assignee: nobody → Philip Muškovac (yofel)
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package akonadi - 1.13.0-2ubuntu3

---------------
akonadi (1.13.0-2ubuntu3) vivid; urgency=medium

  * Still prefer mysql 5.6, but allow any mysql implementation that provides
    virtual-mysql-server-core and virtual-mysql-client-core
    (LP: #1336005)
  * Force dependency on akonadi-backend-mysql for akonadi-server.
    (was accidentally dropped in the last debian merge)
 -- Philip Muskovac <email address hidden> Wed, 15 Apr 2015 16:57:20 +0200

Changed in akonadi (Ubuntu):
status: In Progress → Fix Released
Rafael Kassner (kassner) wrote :

Can we expect to see this in trusty?

Alex (alex00888) wrote :

+1 for trusty, can't work without it

willfe (willfe) wrote :

Any chance this can also be updated to support MariaDB installations? Or is there an alternate way for MariaDB to provide virtual-mysql-[client|server]-core to satisfy akonadi-backend-mysql's dependencies?

willfe (willfe) wrote :

Scratch that -- I'm running MariaDB's own .debs instead of Ubuntu's; it looks like the stock Ubuntu .debs are set up properly.

Philip Muškovac (yofel) on 2016-11-30
Changed in akonadi (Ubuntu Trusty):
assignee: Philip Muškovac (yofel) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers