Akonadi/MySQL 5.6 conflict

Bug #1330180 reported by Simon Smithson
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
akonadi (Ubuntu)
Medium
Philip Muškovac
Trusty
Undecided
Scarlett Gately Moore

Bug Description

After a fresh Kubuntu 14.04 install a conflict between mysql-server-5.6 and akonadi-backend-mysql exists.

The dependencies for akonadi are
$ apt-cache depends akonadi-backend-mysql
akonadi-backend-mysql
 |Depends: mysql-server-core-5.5
  Depends: mariadb-server-core-5.5
 |Depends: mysql-client-core-5.5
  Depends: mariadb-client-core-5.5
  Depends: libqt4-sql-mysql
  Recommends: akonadi-server
  Breaks: akonadi-server
  Breaks: akonadi-server:i386
  Replaces: akonadi-server
  Replaces: akonadi-server:i386

and an attempt to upgrade install mysql-server-5.6 will result in
$ sudo apt-get install mysql-server-5.6
[sudo] password for simon:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 mysql-server-5.6 : Depends: mysql-client-5.6 (>= 5.6.17-0ubuntu0.14.04.1) but it is not going to be installed
                    Depends: mysql-server-core-5.6 (= 5.6.17-0ubuntu0.14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Installation of mysql-client-5.6 will result in
$ sudo apt-get install mysql-client-5.6 mysql-client-core-5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  gstreamer0.10-qapt kde-artwork-active ksplash-theme-active libdeclarative-multimedia libmariadbclient18 libnepomukdatamodel0 libqtmultimediakit1 libqtwebkit-qmlwebkitplugin mariadb-common plasma-active-data
  plasma-active-metadatamodels plasma-active-mobilecomponents plasma-active-settings plasma-active-webbrowser plasma-widgets-active share-like-connect share-like-connect-data startactive-data
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  gstreamer0.10-qapt ksysguardd libdbd-mysql-perl libdbi-perl libkephal4abi1 libksgrd4 libksignalplotter4 libplasma-geolocation-interface4 libplasmaclock4abi4 libprocesscore4abi1 libqt4-declarative-gestures
  libtaskmanager4abi5 libterm-readkey-perl libweather-ion6 mysql-common-5.6 python3-apport usb-creator-common
Suggested packages:
  libmldbm-perl libnet-daemon-perl libplrpc-perl libsql-statement-perl python3-launchpadlib
The following packages will be REMOVED
  akonadi-backend-mysql akonadi-server akregator apport-kde apturl-kde kaddressbook kde-config-pimactivity kde-config-telepathy-accounts kde-telepathy kde-telepathy-auth-handler kde-telepathy-contact-list
  kde-telepathy-declarative kde-telepathy-desktop-applets kde-telepathy-filetransfer-handler kde-telepathy-integration-module kde-telepathy-minimal kde-telepathy-send-file kde-telepathy-text-ui kde-workspace
  kde-workspace-bin kdepim-kresources kdepim-runtime kmail knotes kontact korganizer ksysguard kubuntu-desktop libcalendarsupport4 libeventviews4 libincidenceeditorsng4 libkdepim4 libkdepimdbusinterfaces4 libkpeople3
  libksieveui4 libktpcommoninternalsprivate7 libmailcommon4 libmailimporter4 libmessagecomposer4 libmessagecore4 libmessagelist4 libmessageviewer4 libmuonprivate2 libnoteshared4 libpimactivity4 libpimcommon4 libprocessui4a
  libtemplateparser4 muon-discover muon-notifier muon-updater mysql-client-core-5.5 plasma-dataengines-workspace plasma-desktop plasma-netbook plasma-runner-telepathy-contact plasma-widgets-addons plasma-widgets-workspace
  python3-pykde4 software-properties-kde ubuntu-release-upgrader-qt usb-creator-kde
The following NEW packages will be installed
  gstreamer0.10-qapt libdbd-mysql-perl libdbi-perl libqt4-declarative-gestures libterm-readkey-perl mysql-client-5.6 mysql-client-core-5.6 mysql-common-5.6
The following packages will be upgraded:
  ksysguardd libkephal4abi1 libksgrd4 libksignalplotter4 libplasma-geolocation-interface4 libplasmaclock4abi4 libprocesscore4abi1 libtaskmanager4abi5 libweather-ion6 python3-apport usb-creator-common
11 to upgrade, 8 to newly install, 62 to remove and 193 not to upgrade.
Need to get 10.9 MB/11.2 MB of archives.
After this operation, 33.9 MB disk space will be freed.
Do you want to continue? [Y/n]

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: akonadi-backend-mysql 1.12.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Jun 15 13:30:23 2014
InstallationDate: Installed on 2014-06-15 (0 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.1)
PackageArchitecture: all
SourcePackage: akonadi
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Simon Smithson (smithsos) wrote :
Revision history for this message
Philip Muškovac (yofel) wrote :

Thanks for taking your time to report this bug and helping to make Kubuntu better.

We'll fix this in utopic for now and if a quick test shows no issues update it for trusty.

Changed in akonadi (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package akonadi - 1.12.1-1ubuntu3

---------------
akonadi (1.12.1-1ubuntu3) utopic; urgency=medium

  * Allow using mysql 5.6 as DB for akonadi-backend-mysql (LP: #1330180)
 -- Philip Muskovac <email address hidden> Wed, 18 Jun 2014 14:14:01 +0200

Changed in akonadi (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Zaar Hai (haizaar) wrote :

Please push this release to ppa:kubuntu-ppa/backports for Trusty.

Thank you!

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in akonadi (Ubuntu Trusty):
status: New → Confirmed
Revision history for this message
Pablo de Haro (pdeharo) wrote :

Is there a workaround for this? I really need to use MySQL 5.6 on my computer, because of the new GIS features.

Thanks in advance!

Revision history for this message
Simon Smithson (smithsos) wrote :

You can use these instructions to work around the issue by updating the dependency manually. Worked for me but YMMV.

https://geekwentfreak-raviteja.rhcloud.com/blog/2012/10/10/modify-dependencies-addremove-files-of-debian-deb-package/

Revision history for this message
Miguel Zabala (miguel-zabala) wrote :

Ei guys, any news?

Revision history for this message
mrmango (register-coloniesonline) wrote :

Yes, affects me also. No fix for Trusty? This is LTS and I would assume should be added.

Revision history for this message
Tomasz Kalkosiński (tomasz2k) wrote :

This affects me also. Please backport to Trusty ASAP.

Revision history for this message
Michael Lee (mlee-personal) wrote :

Any update on this?

Revision history for this message
Scarlett Gately Moore (sgclark) wrote :

I can do the backport, I need confirmation from <yofel> that no issues arose first. Hope to get this out ASAP

Revision history for this message
Scarlett Gately Moore (sgclark) wrote :

Hello! I merged debian version 1.13.0 akonadi today, it just needs to be reviewed. Once approved I will backport -> utopic --> trusty.
I don't think they will get to reviewing it until Monday though. This will fix your issue though. Sorry for the delay.
Scarlett

Changed in akonadi (Ubuntu Trusty):
status: Confirmed → In Progress
assignee: nobody → Scarlett Clark (sgclark)
Revision history for this message
Scarlett Gately Moore (sgclark) wrote :

This can be found in the backports ppa.

Changed in akonadi (Ubuntu Trusty):
status: In Progress → Fix Released
Revision history for this message
rdbert (tohyf-w) wrote :

Can this be backported to Precise? I am having similar problem on Precise.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers