Failed to convert old config. Alarm Templates. Post 10.04-12.04 upgrade.

Bug #1008507 reported by JW
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
akonadi (Ubuntu)
New
Undecided
Unassigned

Bug Description

I upgraded from Kubuntu 10.04 to 12.04 (64 bit). I did have a PPA enabled for an updated version of KDE.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"
(Actually, Kubuntu)

KDE/Kubuntu PPA:
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu lucid main

Akonadi information:
ii akonadi-backend-mysql 1.7.2-0ubuntu1 MySQL storage backend for Akonadi
ii akonadi-kde-resource-googledata 1.2.0-1 Google calendar and contacts resource for Akonadi
ii akonadi-server 1.7.2-0ubuntu1 Akonadi PIM storage service
ii akonadiconsole 4:4.8.3-0ubuntu0.1 management and debugging console for akonadi

akonadi-backend-mysql:
  Installed: 1.7.2-0ubuntu1
  Candidate: 1.7.2-0ubuntu1
  Version table:
 *** 1.7.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

akonadi-kde-resource-googledata:
  Installed: 1.2.0-1
  Candidate: 1.2.0-1
  Version table:
 *** 1.2.0-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

akonadi-server:
  Installed: 1.7.2-0ubuntu1
  Candidate: 1.7.2-0ubuntu1
  Version table:
 *** 1.7.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

akonadiconsole:
  Installed: 4:4.8.3-0ubuntu0.1
  Candidate: 4:4.8.3-0ubuntu0.1
  Version table:
 *** 4:4.8.3-0ubuntu0.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     4:4.8.2-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

After the upgrade, I am getting errors about the "Alarm Template" (and a couple other Alarm...) from Akonadi. If I quit the program that is in my system-tray, the three messages come back only once in the form of error dialogs. If I do not do this, I am constantly alerted about these errors.

For better or worse, I deleted the three things from the Akonadi config, but it makes no difference on the alerts.

What should I do to fix this?

Otherwise, the upgrade seems to have gone quite well.

Revision history for this message
JW (arch0njw) wrote :

Here is one of the dialogs:

- - -
Title: Error - KAlarm
Message: Failed to convert old configuration for calendar "Alarm Templates". Please use Import Alarms to lad its alarms into a new or existing calendar.

Location: file:///home/ME/.kde/share/apps/kalarm/template.ics
(Unknown error. (Unknown resource))
- - -

I receive the same for "Active Alarms", and "Archived Alarms".

I tried starting kontact (kmail2) and the migration of my old content failed. "Migration to KMail 2 failed. In case you want to try again, run 'kmail-migrator --interactive' manually.

Okay... but why did it fail? What do I need to fix? And where do I need to look to get a log file of use in determining that?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers