[FFe] Add a token based check and a global idle timeout to ajaxterm

Bug #741619 reported by Soren Hansen
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ajaxterm (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: ajaxterm

Openstack Nova currently ships a copy of ajaxterm with a few patches in its tarball. (It's not included in any of the nova binary packages). To support bug #741616, I'd like to ask permission to add these extra features to the ajaxterm packages so that we don't have to ship a separate version of it. I'm attaching the two patches.

Related branches

Revision history for this message
Soren Hansen (soren) wrote :
Revision history for this message
Soren Hansen (soren) wrote :
Revision history for this message
Scott Kitterman (kitterman) wrote :

What's the status of these patches upstream with ajaxterm? Since they affect API, it would be good if we knew upstream was going to support it.

Changed in ajaxterm (Ubuntu):
status: New → Incomplete
Revision history for this message
Soren Hansen (soren) wrote : Re: [Bug 741619] Re: [FFe] Add a token based check and a global idle timeout to ajaxterm

2011/3/24 Scott Kitterman <email address hidden>:
> What's the status of these patches upstream with ajaxterm?  Since they
> affect API, it would be good if we knew upstream was going to support
> it.

Upstream seems dead. There's a bunch of patches in the Debian package
already (some feature enhancements, some bug fixes, and even a fix for
a major CVE).

It's worth noting though, that I made sure to write these patches so
that unless explicitly enabled by passing extra arguments to ajaxterm,
they're no-ops.

--
Soren Hansen        | http://linux2go.dk/
Ubuntu Developer    | http://www.ubuntu.com/
OpenStack Developer | http://www.openstack.org/

Revision history for this message
Scott Kitterman (kitterman) wrote :

Ack. Approved. Please send the patch to Debian.

Changed in ajaxterm (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ajaxterm - 0.10-10ubuntu2

---------------
ajaxterm (0.10-10ubuntu2) natty; urgency=low

  * Properly escape arguments to ajaxterm.py in /usr/bin wrapper (LP:
    #750040)
  * 90_token_based_access_control.diff (LP: #741619):
    - Add a -t option to pass a token that must be passed by clients
      to get access.
  * 91_terminate_on_idle.diff (LP: #741619):
    - Add -T option to terminate ajaxterm itself if idle for extended
      periods of time.
 -- Soren Hansen <email address hidden> Mon, 04 Apr 2011 10:14:32 +0200

Changed in ajaxterm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers