not possible to login in both opera & konqueror

Bug #120240 reported by Khaled Khalil on 2007-06-13
4
Affects Status Importance Assigned to Milestone
ajaxterm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ajaxterm

whenever you go to http://localhost:8022/ in opera or konqueror, Ajaxterm start and takes login name normaly, but when it comes to un-echoed password it doesn't accept it, or may be it didn't tooked it even !
works fine in mozilla !! is it writen exclusively for it ?

julienfr112 (julienfr112) wrote :

I'd the same problem

But the solution is here :

http://wiki.ubuntu.org.cn/UbuntuHelp:AjaxTerm

And the solution is :

sudo nano -w /etc/ssh/ssh_config
//uncomment: PasswordAuthentication yes

Yohanan (comm-challenge-me) wrote :

I have the same problem.
It's come from [SHIFT] key.

If you use [CAPSLOCK] it's working.

I don't know why but [SHIFT] key is like [UP ARROW] on Ajaxterm.

I think I figured out the shift key thing. If you go to the javascript and turn on debugging, it turns out that "shift" is interpreted as a separate keystroke. I put in a clumsy fix to intercept the shift key and make it a no-op , and it works fine now. For the code example, see:

http://www.billoblog.com/?p=855

billo

Sérgio Faria (sergio91pt) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in ajaxterm (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers