AisleRiot: Card style will not install properly

Bug #699893 reported by dave olson
120
This bug affects 28 people
Affects Status Importance Assigned to Milestone
GNOME Games
Expired
Medium
OEM Priority Project
Medium
Canonical Platform QA Team
Oneiric
Undecided
Unassigned
aisleriot (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-games

aisle riot solitare runs well yet when I try to install card style the installer fails to do so .this is done from the menu after the game is opened .Ubuntu 10.10 runs very well on Gigabyte GA-MA770 with no other issues.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: aisleriot 1:2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Fri Jan 7 09:55:33 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-games

Related branches

Revision history for this message
dave olson (websterfield) wrote :
Revision history for this message
Javier Moreno (elpasmo) wrote :

Confirmed on maverick 10.10 same version.

When you go to the menu View->Card Styles->Install card themes... a windows popup buthttps://bugs.launchpad.net/ubuntu/+source/gnome-games/+bug/699893 the install button is never set enabled.

Changed in gnome-games (Ubuntu):
status: New → Confirmed
Revision history for this message
Javier Moreno (elpasmo) wrote :

I'm sorry for the error in my previous comment, what I was trying to say is:

When you go to the menu View->Card Styles->Install card themes... a windows
popup but the install button is never set enabled.

I've pushed it upstream.

summary: - card style will not install properly
+ AisleRiot: Card style will not install properly
Changed in gnome-games:
importance: Unknown → Medium
status: Unknown → Incomplete
Revision history for this message
jgjoy (freyjoy) wrote :
Shang Wu (shangwu)
Changed in oem-priority:
importance: Undecided → Medium
Changed in gnome-games:
status: Incomplete → Expired
Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Found the problem, at build time gnome-games checks what distro this is, to work out what packages to install.

The build log shows:
checking for lsb_release... false
checking for LSB distributor...
checking for LSB distribution...

So we just need to add lsb-release to the build-depends

Changed in gnome-games (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Note that aisleriot has been split out of GNOME Games for the 3.1 release, so it's important that this change is made to the new aisleriot package when it is packaged.

Changed in gnome-games (Ubuntu):
assignee: Ubuntu Desktop (ubuntu-desktop) → Canonical Desktop Team (canonical-desktop-team)
Steve Magoun (smagoun)
Changed in oem-priority:
status: New → Confirmed
Jeremy Bicha (jbicha)
affects: gnome-games (Ubuntu) → aisleriot (Ubuntu)
Changed in aisleriot (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: Triaged → Fix Released
Changed in oem-priority:
status: Confirmed → Fix Released
Revision history for this message
Wolter Hellmund (wolterh) wrote :

On what version has this been fixed? I am running version 3.4.1 and this bug is still present.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Wolter, where did you get Aisleriot 3.4.1 from?

On my computer, I just need to click View>Card Style>Install Card Themes and then click to install gnome-cards-data to get the card sets increased from 2 to about 11.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.