Ubuntu

FFe: Update to 3.6.2

Reported by Robert Ancell on 2012-07-20
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aisleriot (Ubuntu)
Wishlist
Unassigned

Bug Description

Justification for Feature Freeze Exception:
We didn't ship a newer aisleriot previously in Ubuntu because we were waiting for guile-2.0 to build on all Ubuntu arches and get promoted to main (bug 1020139). These have both happened. We have been running the new aisleriot versions for quite a while in the GNOME3 PPAs without a problem.

Aisleriot 3.6.2
===============
- translation updates

Aisleriot 3.6.1
===============
- translation updates

Aisleriot 3.6.0
===============
- fix help link
- translation updates

Aisleriot 3.5.90
================
- many games fixes (Vincent Povirk)
- translation updates

Aisleriot 3.5.0
===============
- build fixes
- many games fixes (Vincent Povirk)
- many translation updates

Aisleriot 3.3.2
===============
- Misc improvements and bug fixes
- Translation updates

Aisleriot 3.3.1
===============
- Aisleriot now requires guile >= 2.0
- Many improvements and bug fixes
- Translation updates

Aisleriot 3.3.0
===============
- Change card theme format
- Many game fixes (Vincent Povirk)
- Translation updates

Robert Ancell (robert-ancell) wrote :

This is being held back as we don't want to ship both guile 2.0 and 1.x. To update this all other guile users need to update too.

Changed in aisleriot (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
tags: added: upgrade-software-version
removed: desktop-upgrade
summary: - Update to 3.5.0
+ Update to 3.6
Changed in aisleriot (Ubuntu):
status: Triaged → Fix Committed
Robert Ancell (robert-ancell) wrote :

MIR for guile-2.0 is bug 1081812

Robert Ancell (robert-ancell) wrote :

Nothing else on the CD depends on guile-1.8, so this won't add a second implementation onto the CD.

Jeremy Bicha (jbicha) on 2013-04-05
summary: - Update to 3.6
+ FFe: Update to 3.6.2
Changed in aisleriot (Ubuntu):
status: Fix Committed → Confirmed
Jeremy Bicha (jbicha) on 2013-04-05
description: updated
Scott Kitterman (kitterman) wrote :

Ack. Approved.

Changed in aisleriot (Ubuntu):
status: Confirmed → Triaged
dino99 (9d9) wrote :

Hopes these new libs will fix that issue into aisleriot on RR i386 + gnome3-team ppas : grabbing cards is very hard, and tweaking the mouse settings does not help (was also true when the ppas was not used)

Jeremy Bicha (jbicha) wrote :

Uploaded to raring-proposed queue.

Changed in aisleriot (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aisleriot - 1:3.6.2-0ubuntu1

---------------
aisleriot (1:3.6.2-0ubuntu1) raring; urgency=low

  [ Jeremy Bicha ]
  * Revert back to 1:3.4.1-1 packaging since guile-2.0 is in main now
    - Remaining change:
      + debian/control.in: Remove obsolete libgstreamer build-depends
  * New upstream release (LP: #1026854)

  [ Robert Ancell ]
  * debian/aisleriot.install:
  * debian/aisleriot.menu:
  * debian/patches/02_desktop-path.patch:
  * debian/pixmaps/freecell.xpm:
    - Updated as freecell.desktop is removed

  [ Rico Tzschichholz ]
  * debian/control.in: Bump Build-Deps on libgtk-3-dev (>= 3.4.0),
    libglib2.0-dev (>= 2.32.0)
 -- Jeremy Bicha <email address hidden> Fri, 05 Apr 2013 11:32:43 -0400

Changed in aisleriot (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers