Please sync airstrike 0.99+1.0pre6a-3.1 from Debian unstable main

Bug #157745 reported by Siegfried Gevatter on 2007-10-27
4
Affects Status Importance Assigned to Milestone
airstrike (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: airstrike

DEBIAN CHANGELOG
---------------------------

airstrike (0.99+1.0pre6a-3.1) unstable; urgency=low

  * NMU with current maintainer's authorization.
  * Set Maintainer to the Debian Games Team.
  * Add a .desktop and an icon. (Closes: #359279, #432842)
    - debian/dirs: Update.
    - debian/rules: Install .desktop and icon.
  * debian/rules: generate airstrike-common in binary-arch target.
    (Closes: #304116)
  * debian/control:
    - Add quilt (>= 0.40) to Build-Depends.
    - Update debhelper version.
    - Update Standards-Version.
    - Add Homepage.
  * debian/patches/series: Add.
    - fix-red-baron-has-unlimited-bombs.diff: Add. (Closes: #340167)
    - fix-buffer-overflow.diff: Add. (Closes: #290423)
    - fix-unusable-on-amd64.diff: Add. (Closes: #406879)
    - fix-segfault-on-close.diff: Add. (Closes: #418192)
  * debian/rules:
    - Remove deprecated DH_COMPAT.
    - Update CFLAGS.
    - Remove unused configure target.
    - Fix debian-rules-ignore-make-clean-errors.
    - Remove useless comments.
    - Don't install menu file anymore since there is a .desktop now.
  * debian/copyright:
    - Add missing copyright.
    - Update FSF address.
  * debian/compat: Add.

 -- Arthur Loiret <email address hidden> Tue, 09 Oct 2007 12:40:20 +0200

UBUNTU CHANGES:
--------------------------

- src/sprite_types/biplane.c - Patch up unlimited bombs bug
Fixed with fix-red-baron-has-unlimited-bombs.diff

- Bump standards version to 3.7.2
Done in Debian.

- Update debhelper b-d to 5
Done in Debian.

- Add a desktop file
Same file add in Debian.

Changed in airstrike:
importance: Undecided → Wishlist
Cesare Tirabassi (norsetto) wrote :

Good work.

Have you also checked that the package builds? If so, please attach the build log to the bug report.

Thanks.

Changed in airstrike:
assignee: nobody → rainct
status: New → Incomplete
Siegfried Gevatter (rainct) wrote :

Yes (had to rebuild since I deleted the test folder).

$ dget http://ftp.de.debian.org/debian/pool/main/a/airstrike/airstrike_0.99+1.0pre6a-3.1.dsc
$ dpkg-source -x airstrike_0.99+1.0pre6a-3.1.dsc
$ cd airstrike-0.99+1.0pre6a/
$ dpkg-buildpackage -rfakeroot > ../buildlog 2>&1

Build log attached. Binary .deb files «airstrike_0.99+1.0pre6a-3.1_i386.deb» and «airstrike-common_0.99+1.0pre6a-3.1_all.deb» are successfully created, and can be installed with gdebi (no irresolvable dependency).

Cesare Tirabassi (norsetto) wrote :

Confirmed for Ubuntu archive to sync,

Changed in airstrike:
assignee: rainct → nobody
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

[Updating] airstrike (0.99+1.0pre6a-3ubuntu3 [Ubuntu] < 0.99+1.0pre6a-3.1 [Debian])
 * Trying to add airstrike...
  - <airstrike_0.99+1.0pre6a-3.1.dsc: downloading from http://ftp.debian.org/debian/>
  - <airstrike_0.99+1.0pre6a-3.1.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <airstrike_0.99+1.0pre6a.orig.tar.gz: already in distro - downloading from librarian>
I: airstrike [universe] -> airstrike_0.99+1.0pre6a-3ubuntu3 [universe].
I: airstrike [universe] -> airstrike-common_0.99+1.0pre6a-3ubuntu3 [universe].

Changed in airstrike:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments