airdriver-ng install fails with unhelpful message

Bug #499513 reported by Václav Šmilauer
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aircrack-ng (Ubuntu)
Undecided
carloslp

Bug Description

Binary package hint: aircrack-ng

Trying to install patched driver for iwl4965:

# airdriver-ng install 14
Driver "Intel Pro Wireless 4965 A/B/G/N" specified for installation.
Your current GCC version doesn't match the version your kernel was compiled with.
The build modules will probably not load into the running kernel.
DI_DRIVERPATH1[14] isn't set, you need at least one driver source!
Running "depmod -ae"...
WARNING: -e needs -E or -FFailed to install the driver.
Look through "/var/log/airdriver" for errors.

There is no indication on how and where set driver sources (man pages doesn't mention requirement for succesful functioning either, nor possible causes of errors).

Apart from that, airdriver-ng should probably depend on distribution kernel source and apply patches there, if possible.

ProblemType: Bug
Architecture: i386
Date: Tue Dec 22 17:20:58 2009
DistroRelease: Ubuntu 9.10
Package: aircrack-ng 1:1.0-1
ProcEnviron:
 PATH=(custom, no user)
 LANG=cs_CZ.UTF-8
 SHELL=/bin/zsh
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: aircrack-ng
Uname: Linux 2.6.31-16-generic i686

Related branches

Revision history for this message
Václav Šmilauer (eudoxos) wrote :
carloslp (carloslp)
Changed in aircrack-ng (Ubuntu):
assignee: nobody → carloslp (carloslp)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aircrack-ng (Ubuntu):
status: New → Confirmed
Revision history for this message
Joao S Veiga (jsveiga-it) wrote :

Got the same problem on 14.04:
ii aircrack-ng 1:1.1-6 amd64 wireless WEP/WPA cracking utilities
ii gcc 4:4.8.2-1ubuntu6 amd64 GNU C compiler
ii gcc-4.8 4.8.2-19ubuntu1 amd64 GNU C compiler

The problem is that in /usr/sbin/airdriver-ng we have this:

#check if gcc version matches the kernel gcc version
    gccvers="`$GCC --version | head -n 1 | sed 's/^[^ ]* [^ ]* \([2-4]..*\)$/\1/'`"
    ret="`cat /proc/version | grep "$gccvers"`"

    if [ x"$ret" == x ]
    then
        echo "Your current GCC version doesn't match the version your kernel was compiled with."
        echo "The build modules will probably not load into the running kernel."
    fi

but

root@dell:~# gcc --version | head -n 1 | sed 's/^[^ ]* [^ ]* \([2-4]..*\)$/\1/'
4.8.2-19ubuntu1) 4.8.2
root@dell:~# cat /proc/version
Linux version 3.13.0-24-generic (buildd@panlong) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014

so the version check fails although the versions match.

Changing the sed to 's/^[^ ]* [^ ]* \([2-4]..*\)).*$/\1/' gets you past that point, but then (on kubuntu 14.04) if you don't have the kernel sources in place you hit

1. Getting the source...Couldn't find the correct driver file: linux-3.3.13.0-24-generic.3.13.0-24-generic.tar.bz2

because the script can't handle the 3.xx.x kernel version string and looks for
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-3.3.13.0-24-generic.3.13.0-24-generic.tar.bz2

"v2.6" is hardcoded in the script, so it won't work for 3.x source fetching.

Then looking furhter in the script I found that at least for my case (broadcom chipset), it probably will fail the kernel patching, because the script also has the patch for kernel 2.6 hardcoded:

DI_PATCHFILE[$i]="bcm43xx-injection-linux-2.6.20.patch"

At this point I conclude that aircrack-ng was poorly (or not at all) integrated to ubuntu, so I'm going to look for a live dvd pentest distro for my tests.

Revision history for this message
carloslp (carloslp) wrote :

I think airdriver-ng should be removed from the package. Is probably obsolete and not longer makes much sense.

The patches it tries to load are so older that is is almost impossible they will work with a modern kernel. Check the timestamps at http://patches.aircrack-ng.org/

My understanding is that most of this patches are already integrated into upstream kernel, so not patching of the driver should be needed.

And for the ones that are still not integrated I would be interested in integrating them into the kernel.

Which driver does your wireless card use? Doesn't it allow injection out of the box?

If the answer to the second question is no, then were you able to make it inject using some patch or a different kernel/driver? Which one?

Revision history for this message
Joao S Veiga (jsveiga-it) wrote :

@carloslp

You are right, airdriver-ng should be retired - as it is, it seems to be just causing confusion (as it did to me and to the original reporter) - it does not work, so either it has to be fixed (if still needed) or removed.

I was just starting to play with aircrack-ng, and as my card is a BCM43228 I assumed I needed the bcm43xx driver installed from airdriver-ng - hadn't even tried injection (and probably won't; I'm just looking for channel/AP usage).

I just tested, and the driver from broadcom (wl) does seem to support injection (at least I got no errors from "aireplay-ng -9 prism0").

So I'm still with kubuntu 14.04 for the tests.

Thanks!

Revision history for this message
carloslp (carloslp) wrote :

I will be removing airdriver-ng from the next release of the package aircrack-ng.

I also have open the following upstream bug on the matter: http://trac.aircrack-ng.org/ticket/1317

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aircrack-ng - 1:1.2-0~beta3-1

---------------
aircrack-ng (1:1.2-0~beta3-1) unstable; urgency=low

  * New upstream release.
    * Remove all Debian patches that are now merged upstream.
  * Apply: "wrap-and-sort -sa"
  * Build with PCRE: Add support for regular expression matching for ESSID
    in airodump-ng.
  * Build with libgcrypt20 by default, but allow to use libgcrypt11 otherwise.
  * Fix libnl detection (Debian patches 002-fix-libnl-detection.diff and
    003-dont-abort-libnl-nolinux.diff).
  * Add build dependency on libnl-genl-3-dev.
  * Remove airdriver-ng (LP: #499513) (Closes: #449299).
  * Not longer recommend wget, because we don't ship airdriver-ng neither
    airoump-ng-oui-update.
  * Recommend the Debian package ieee-data that contains the OUI data.
    Add Debian patch 001-Airodump_whitespace_oui.diff to correctly parse it.
    Not longer ship airodump-ng-oui-update (Use update-oui instead).
    (Closes: #739199)
  * Switch to debhelper 9 and enable all hardening flags (PIE works now).
  * Update debian/watch and debian/copyright.
  * Upgrade to new standards version.

 -- Carlos Alberto Lopez Perez <email address hidden> Fri, 30 May 2014 19:21:38 +0200

Changed in aircrack-ng (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.