package aiccu 20070115-14.1ubuntu2 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 143 zurück

Bug #970054 reported by Ralf Hildebrandt
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aiccu (Ubuntu)
Fix Released
Undecided
Lars Düsing

Bug Description

During the upgrade, aiccu wouldn't restart.

Manually trying
% service aiccu start
as root also fails (meaning: it never returns to the shell).

At the same time, aiccu seems to be working, since I do have IPv6 connectivity.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: aiccu 20070115-14.1ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
NonfreeKernelModules: zfs zcommon znvpair zavl zunicode
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
Date: Fri Mar 30 23:18:59 2012
ErrorMessage: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 143 zurück
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
SourcePackage: aiccu
Title: package aiccu 20070115-14.1ubuntu2 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 143 zurück
UpgradeStatus: Upgraded to precise on 2012-02-21 (38 days ago)
modified.conffile..etc.aiccu.conf: [modified]
mtime.conffile..etc.aiccu.conf: 2012-03-17T22:46:41.994221

Related branches

Revision history for this message
Ralf Hildebrandt (ralf-hildebrandt) wrote :
Revision history for this message
Lars Düsing (lars.duesing) wrote :

Ralf, sorry, I had a weekend off :-)
I'm investigating this bug. Could reproduce it only once.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aiccu (Ubuntu):
status: New → Confirmed
Revision history for this message
Lars Düsing (lars.duesing) wrote :

Bug found. aiccu won't daemonize by itself.
Somehow this little "&" has fallen of the code...

Changed in aiccu (Ubuntu):
assignee: nobody → Lars Düsing (lars.duesing)
Revision history for this message
Lars Düsing (lars.duesing) wrote :

Patch

Revision history for this message
James Page (james-page) wrote :

Lars

I don't think that you should need todo the nohup ... & in the upstart configuration.

aiccu should daemonise itself so long as the:

  daemonize true

setting is present in /etc/aiccu.conf - and I think that this is the default.

Ralf - could you please check your configuration to check this setting.

Revision history for this message
James Page (james-page) wrote :

Looking at the init script:

    if [ `grep -c "^daemonize true" /etc/aiccu.conf 2>/dev/null` -ne 1 ]; then
            log_failure_msg "AICCU is not configured to daemonize on run"
            exit 1;
    fi

That would be a good check to have in the upstart configuration to avoid the need for nohup...

Revision history for this message
James Page (james-page) wrote :

Ralf - log file in /var/log/aiccu.log would be helpful as well.

Thanks

Revision history for this message
Lars Düsing (lars.duesing) wrote :

James, that was the problem LP #223825 vs. LP #406397 (esp. https://bugs.launchpad.net/ubuntu/+source/aiccu/+bug/223825/comments/56)

Revision history for this message
James Page (james-page) wrote :

Lars

Ah - I see - that reveals another bug because when I upgraded by system from oneiric->precise the daemonize flag was left as true and not changed to false.

Revision history for this message
Lars Düsing (lars.duesing) wrote :

so, after some discussion - a new patch...

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aiccu - 20070115-14.1ubuntu3

---------------
aiccu (20070115-14.1ubuntu3) precise; urgency=low

  [ Lars Duesing ]
  * Switch back to using "daemonize true" (LP: #970054):
    - d/patches/10_upstart.patch: Dropped - no longer required.
    - d/aiccu.upstart: check configuration for aiccu to daemonize itself.

  [ James Page ]
  * d/aiccu.upstart: Added check to ensure that server configuration has
    been specified before trying to check access.
 -- Lars Duesing <email address hidden> Mon, 02 Apr 2012 11:40:44 +0200

Changed in aiccu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers