aiccu.conf does not need server directive, while upstart script wants it

Bug #1007408 reported by Dawid Ciężarkiewicz
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aiccu (Ubuntu)
Fix Released
High
Lars Düsing
Precise
Fix Released
High
Lars Düsing

Bug Description

[Impact]
 * not all correct config-files are accepted by upstart-script: there is a default-server in aiccu.

[Test Case]
delete / comment out the line "server tic.sixxs.net" in /etc/aiccu.conf
start aiccu via upstart-script: An error is thrown in /var/log/aiccu.log and aiccu is not being started.
start aiccu via sudo /usr/sbin/aiccu start: aiccu is being started (no entries in aiccu.log due it is only written by upstart-script)

[Regression Potential]
 - low
  * aiccu could not being started by upstart-script.

[Original Report]
The /etc/init/aiccu.conf is failing if in /etc/aiccu.conf there is no "server" directive. The server directive is not neccessary and aiccu was working fine without it (before init script was transitioned to upstart). Please fix this.

If no server is specified in /etc/aiccu.conf , the /etc/init/aiccu.conf should assume "tic.sixxs.net", I guess.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: aiccu 20070115-14.1ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
Date: Fri Jun 1 15:09:41 2012
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/zsh
SourcePackage: aiccu
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Dawid Ciężarkiewicz (dpc-ucore) wrote :
summary: - aiccu.conf does not need server command
+ aiccu.conf does not need server directive, while upstart scripts wants
+ it
summary: - aiccu.conf does not need server directive, while upstart scripts wants
- it
+ aiccu.conf does not need server directive, while upstart script wants it
Revision history for this message
Lars Düsing (lars.duesing) wrote :

Ouch, yes. After browsing the code, I see it is correct.
Fixing it.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aiccu (Ubuntu):
status: New → Confirmed
James Page (james-page)
Changed in aiccu (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aiccu - 20070115-15ubuntu3

---------------
aiccu (20070115-15ubuntu3) quantal; urgency=low

  * upstart-script did not honour default server tic.sixxs.net
    (LP: #1007408)
 -- Lars Duesing <email address hidden> Fri, 15 Jun 2012 11:58:43 +0200

Changed in aiccu (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Lars Düsing (lars.duesing) wrote :

{preparation for SRU}
[Impact]
- Medium to Low impact
 * not all correct config-files are accepted by upstart-script: there is a default-server in aiccu.

[Test Case]
delete / comment out the line "server tic.sixxs.net" in /etc/aiccu.conf
start aiccu via upstart-script: An error is thrown in /var/log/aiccu.log and aiccu is not being started.
start aiccu via sudo /usr/sbin/aiccu start: aiccu is being started (no entries in aiccu.log due it is only written by upstart-script)

[Regression Potential]
 - low
 * aiccu could not being started by upstart-script.

Changed in aiccu (Ubuntu Precise):
assignee: nobody → Lars Düsing (lars.duesing)
Changed in aiccu (Ubuntu):
assignee: nobody → Lars Düsing (lars.duesing)
Vibhav Pant (vibhavp)
description: updated
Revision history for this message
Lars Düsing (lars.duesing) wrote :
Revision history for this message
Lars Düsing (lars.duesing) wrote :
Revision history for this message
Lars Düsing (lars.duesing) wrote :

(last line in SRU-Coment left out)

description: updated
Steve Langasek (vorlon)
Changed in aiccu (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
description: updated
Revision history for this message
Steve Langasek (vorlon) wrote :

SRU uploaded to the queue. Thank you for your contribution to Ubuntu!

Changed in aiccu (Ubuntu Precise):
status: Triaged → In Progress
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Dawid, or anyone else affected,

Accepted aiccu into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/aiccu/20070115-14.1ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in aiccu (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Lars Düsing (lars.duesing) wrote :

works here on multiple installations.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aiccu - 20070115-14.1ubuntu3.2

---------------
aiccu (20070115-14.1ubuntu3.2) precise-proposed; urgency=low

  * Fix upstart-script to honour default server tic.sixxs.net
    (LP: #1007408)
 -- Lars Duesing <email address hidden> Fri, 22 Jun 2012 16:11:05 +0200

Changed in aiccu (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers