FTBFS in zesty

Bug #1640317 reported by Dimitri John Ledkov on 2016-11-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
aethercast
Critical
Unassigned
aethercast (Ubuntu)
Critical
Unassigned

Bug Description

dh_install
dh_install: Cannot find (any matches for) "usr/lib/*/aethercast/tools/libaethercast-lttng.so" (tried in "." and "debian/tmp")
dh_install: aethercast-tools missing files: usr/lib/*/aethercast/tools/libaethercast-lttng.so
dh_install: aethercast/tools/libaethercast-lttng.so exists in debian/tmp but is not installed to anywhere
dh_install: missing files, aborting

Please see build logs in this no change rebuild https://launchpad.net/ubuntu/+source/aethercast/0.1+16.10.20160808-0ubuntu4

Please help fixing this bug.

Related branches

tags: added: boost1.62
Dimitri John Ledkov (xnox) wrote :

Hi, should aethercast be removed from the Ubuntu Archive?

Changed in aethercast (Ubuntu):
importance: Undecided → Critical
Changed in aethercast:
importance: Undecided → Critical
Changed in aethercast (Ubuntu):
status: New → Confirmed
Changed in aethercast:
status: New → Confirmed

from log I can see :
54:/usr/bin/x86_64-linux-gnu-ld.bfd.real: cannot find -lpthreads

it should be -lpthread, I think

but I didn't find where it is defined.

Dimitri John Ledkov (xnox) wrote :

Hm, maybe that is a red-herring?

Because it tries in a few places and eventually finds the right place (pthread)

-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found

The actual error seems to be with gmock?

CMake Error at /usr/src/googletest/googletest/cmake/internal_utils.cmake:149 (add_library):
  add_library cannot create target "gmock" because another target with the
  same name already exists. The existing target is a static library created
  in source directory "/usr/src/googletest/googlemock". See documentation
  for policy CMP0002 for more details.
Call Stack (most recent call first):
  /usr/src/googletest/googletest/cmake/internal_utils.cmake:172 (cxx_library_with_type)
  /usr/src/gmock/CMakeLists.txt:84 (cxx_library)

CMake Error at /usr/src/googletest/googletest/cmake/internal_utils.cmake:149 (add_library):
  add_library cannot create target "gmock_main" because another target with
  the same name already exists. The existing target is a static library
  created in source directory "/usr/src/googletest/googlemock". See
  documentation for policy CMP0002 for more details.
Call Stack (most recent call first):
  /usr/src/googletest/googletest/cmake/internal_utils.cmake:172 (cxx_library_with_type)
  /usr/src/gmock/CMakeLists.txt:89 (cxx_library)

Balint Reczey (rbalint) on 2017-03-22
Changed in aethercast (Ubuntu):
assignee: nobody → Balint Reczey (rbalint)
Balint Reczey (rbalint) wrote :

Patch fixing all build issues

Changed in aethercast (Ubuntu):
status: Confirmed → In Progress
Balint Reczey (rbalint) wrote :

.. in chroot, sbuild failed, will update the patch soon.

The attachment "debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Balint Reczey (rbalint) wrote :

Sbuild had a local problem only, now the package builds nicely.
Attaching a new patch anyway to drop libgtest-dev, too.

Balint Reczey (rbalint) wrote :

I'm trying the different approach, the one to be taken by location-service and others to keep the code in sync.
Please don't upload this patch yet.

Changed in aethercast:
status: Confirmed → In Progress
assignee: nobody → Balint Reczey (rbalint)

ping please :)

Balint Reczey (rbalint) wrote :

I have no upload rights yet, and the review is pending.

Changed in aethercast:
assignee: Balint Reczey (rbalint) → nobody
Changed in aethercast (Ubuntu):
assignee: Balint Reczey (rbalint) → nobody
Changed in aethercast:
status: In Progress → Confirmed
Changed in aethercast (Ubuntu):
status: In Progress → Confirmed
Nish Aravamudan (nacc) wrote :

@rbalint: I'm unsubscribing sponsors based upon c8.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aethercast - 0.1+17.04.20170328.1-0ubuntu1

---------------
aethercast (0.1+17.04.20170328.1-0ubuntu1) zesty; urgency=medium

  [ Balint Reczey ]
  * Fix zesty FTBFS by replacing the bundling of googletest
    with find_package from cmake-extra. (LP: #1640317, LP: #1644062)
  * Fix installation to multiarch path during build

 -- morphis <email address hidden> Tue, 28 Mar 2017 05:51:12 +0000

Changed in aethercast (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers