package adzapper 20090301-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 100

Bug #658700 reported by Mathias Burén on 2010-10-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
adzapper (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: adzapper

There is no /etc/init.d/squid , I just "sudo touch /etc/init.d/squid" and it installed nicely.

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: adzapper 20090301-1
Uname: Linux 2.6.36-020636rc7-generic x86_64
NonfreeKernelModules: nvidia
AptOrdering:
 adzapper: Install
 adzapper: Configure
Architecture: amd64
Date: Mon Oct 11 21:19:37 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 100
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
PackageArchitecture: all
SourcePackage: adzapper
Title: package adzapper 20090301-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 100

Mathias Burén (mathias-buren) wrote :
Boris Däppen (boris-daeppen) wrote :

I also experienced this issue.
It causes me problems in my project.
I discuss the issue here: http://github.com/borisdaeppen/NaYaBoh/issues/#issue/33

What I have found out:
----------
adzapper has squid as a dependency. If you don't have squid installed, and then install adzapper so that squid is installed automatically - everything goes fine.

BUT:
if you install the squid package first and then afterwards install the adzapper package the installation fails with the following error messages:

No apport report written because MaxReports is reached already
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
invoke-rc.d: unknown initscript, /etc/init.d/squid not found.
dpkg: error processing adzapper (--configure):
subprocess installed post-installation script returned error exit status 100 Errors were encountered while processing:
adzapper
----------

Would be nice if the problem is solved, cause it makes that my project's installation fails.
Maybe I can "solve" the problem when I exchange the position of adzapper and squid in my dependencies-list so that adzapper comes first...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers