Settings freezes in Flash Player on Ubuntu 12.04

Bug #995699 reported by Jeb E. on 2012-05-07
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Epiphany Browser
Mozilla Firefox
adobe-flashplugin (Ubuntu)

Bug Description

Hey, running Ubuntu 12.04 here on multiple 64-bit machines, both Intel64 and AMD64, and both are experiencing the same problem, no matter on what web browser, including Google Chrome:

The Flash Player settings dialogue is unresponsive to mouse clicks, unless in full screen.

This makes a HUGE problem for my friend that has Ubuntu 12.04 x64 on her laptop that uses her webcam and microphone, because she can't enable them to be used in Flash, because the dialogue is unresponsive. I have the same problem on my Ubuntu 12.04 machine when I try to change the settings in my Flash Player. Even though I don't have a webcam or mic, it might be good to disable hardware acceleration someday, which I cannot currently do, due to the same issue. I have tried all sorts of things, like installing the i386 version of Chrome and forcing it to work, and installing older versions of Chrome and Flash, neither worked. The same happens on every single web browser I use on 12.04. This may cause a security vulnerability, as a website that currently has access to a person's webcam and mic cannot be denied of the access now.

This needs to be fixed. Now.

Jeb E. (jebeld17) wrote :
visibility: private → public
Jeb E. (jebeld17) on 2012-05-07
no longer affects: epiphany
Fahad Abid (drfahadabid) wrote :


"Linux ubuntu 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux"

Using Firefox 12

Cannot click flash player settings in samll flash player. Settings clickable in full screen flash.

Bug affecting unity 3d only.

Can click setting in unity 2d, kde , gnome3, cinnamon, lxde , xfce.

Please offer a solution because this effects webcam a lot.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in adobe-flashplugin (Ubuntu):
status: New → Confirmed
Devree-melvin (devree-melvin) wrote :

I used the Adobe website to change some of the settings that i needed to change.

Konstantin (kostua-p) wrote :


I have a same problem.

Ubuntu 12.04

Linux 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

This problem has appeared for me in Ubuntu 11.10.

"I used the Adobe website to change some of the settings that i needed to change." it's not work.

Workaround is login to ubuntu 2d session.

Anthony LoRe (someitalian123) wrote :

This problem appeared for me a while ago. The work around was to use unity 2d, but now in 12.04 it won't even work in unity 2d anymore.

Anthony LoRe (someitalian123) wrote :

NVM, it's working apparently in unity 2d, I don't know what I did to fix it. Haven't tried in unity 3d though.

Littleteo (falematte) wrote :

When I installed Ubuntu i didn't have this problem, it started after update&&upgrade. Which one was the starting Flash player? (I installed restricted extras)

Hugh Nelson (hughnelson) wrote :

On Ubuntu 12.04 64 bit the Youtube webcam works once you change the browser setting ONLINE - there are no offline settings to change.
This changes the flash settings within the browser - whether it is firefox or chrome

robbielink (robbielink) wrote :

Having same problem Lubuntu 12.04 64 bit in Chromium

gargolito (gargolito) wrote :


You can enable/disable hardware acceleration by going to any video that let's you go full screen. Once in full screen while video is playing, right click and you should be able to enable/disable hardware acceleration.

Confirmed in:
OS: 3.2.0-30-generic #48-Ubuntu Precise 12.04.1 64bit
Browser: Google Chrome Version 21.0.1180.77
Package: adobe-flashplugin
Maintainer: DL-Flash Player Ubuntu <email address hidden>

Bug affects unity 3d. Tested on 12.04 64 bit AMD.

It seems to affect Flash based websites with both Chromium & FF. Application "Cheese" (webcam) works fine.

UbuntuManiac (ilyasbox) wrote :

Confirming this bug under both (32 and 64-bit) versions of Ubuntu 12.04 LTS.

Firefox 15, updated via Software Center.

Adobe Flash 11.2, updated via Software Center.

theflip (theeruiflip) wrote :

i do have same prob wth permission for audio and video box

Rob Bosch (rob-bosch) wrote :

Same problem here. My problem is that my mic doesn't work through a flash application I use. I can't 'enable' it (or change settings).
In I have set cam+mic to allow but no joy for the mic to work.

any suggestions?

theflip (theeruiflip) wrote :

TNX Rob ive just used In and LIVESTREAM is working on Ubuntu 12.04 with audio and video permissions

Benjamin J Norton (leomcsnarf) wrote :

After reading another users comment I found out that I can use my camera when logging in with Unity 2d... really need this to work in Unity 3d though.

xtremeasure (mbennerd) wrote :

Slight fix because this problem carries to 12.10,
this is a problem with the composite manager used by gnome 3 and unity 3d
im using 12.10 gnome remix and the way i workaround this without logging is to use metacity to manage my windows
and gtk to decorate them it then allows me to work the menu, the problem lies within compiz and the composite manager when i get time ill look into it more...

side note: if you use cairo just disabling the composite manager on the dock doesnt work you have to fire up your fusion icon and switch the window decorator as well.

Robert Charlton (rectec) wrote :

I have this problem too. I've had it for a while. Since about 11.10 (I started using Unity with 11.10) all the way to my current desktop. Right now I'm running 12.10 amd64, and I've had this problem across several machines and various Ubuntu versions including 12.04. Very annoying and can even be a bit disasterous for some people, since one must refresh the page to get the settings dialog to go away.

I'd love to see a fix for this. This likely impacts most, if not all, users of Adobe Flash Player on Ubuntu, which is a lot of people, unfortunately. Is there a new bug report for this with Quantal? Should I comment there, also?

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 865672, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers