[Karmic] Removing Flash Plugin causes annoying package managing problems

Bug #412944 reported by Carroarmato0 on 2009-08-13
532
This bug affects 211 people
Affects Status Importance Assigned to Milestone
adobe-flashplugin (Ubuntu)
Undecided
msebolino

Bug Description

When using the computer-janitor on Karmic Alpha 3, it shows a list of rightfully candidate for removal, old libraries that aren't needed by others, unused old kernel versions, etc...

However, it also listed the Adobe Flash Plugin, which was installed as a third party from the .deb package from Adobe themselves.

When allowing the Janitor to remove the plugin, it causes an error saying that the plugin needs to be reinstalled , but that it cannot find an archive for it.

This has an impact on the whole package managing system, that refuses to work until this problem has been taken care of.

Reinstalling the flash package, even through the command line ( sudo apt-get remove adobe-flashplugin ) doesn't do the job.

** christophe@lithium-flower:~/Desktop$ sudo dpkg -C
** The following packages are in a mess due to serious problems during
** installation. They must be reinstalled for them (and any packages
** that depend on them) to function properly:
** adobe-flashplugin Adobe Flash Player plugin version 10

Trying to remove it with force, still doesn't solve the problem

** christophe@lithium-flower:~/Desktop$ sudo dpkg --force-remove-reinstreq -r adobe-flashplugin
** dpkg: warning: overriding problem because --force enabled:
** Package is in a very bad inconsistent state - you should
** reinstall it before attempting a removal.
** (Reading database ... 106164 files and directories currently installed.)
** Removing adobe-flashplugin ...
** update-alternatives: error: no alternatives for iceape-flashplugin.
** update-alternatives: error: no alternatives for iceape-flashplugin.
** dpkg: error processing adobe-flashplugin (--remove):
** subprocess installed pre-removal script returned error exit status 2
** postinst called with argument `abort-remove'
** dpkg: error while cleaning up:
** subprocess installed post-installation script returned error exit status 1
** Errors were encountered while processing:
** adobe-flashplugin

Carroarmato0 (carroarmato0) wrote :

I have found a workaround to solve this issue manually, though this should be fixed properly with a patch.

You need to delete this file as root:
rm /var/lib/dpkg/info/adobe-flashplugin.prerm

And then you can reinstall it again.

to be removed (liw) wrote :

This looks like a adobe-flashplugin problem. I've never seen the package and don't know what it is doing, but from the errors it looks like the prerm script is broken and uses the update-alternatives command wrongly.

affects: computer-janitor (Ubuntu) → adobe-flashplugin (Ubuntu)
Matthew Woerly (nattgew) wrote :

I upgraded to Karmic and I had the same problem with flashplugin-nonfree. It gave me the same
update-alternatives: error: no alternatives for iceape-flashplugin.
subprocess installed pre-removal script returned error exit status 2

Gavo (gavalier-marcel) wrote :

Thanx, Carroarmato0 wrote on 2009-08-13: This fix my problem with adobe-flashplugin.

spbrereton (simon-brereton) wrote :

I confirm - running as root:
rm /var/lib/dpkg/info/adobe-flashplugin.prerm

and then as user

sudo apt-get auto-remove

worked for me. I guess reinstalling (sudo apt-get install adobe-flashplugin 10.0.32.18-1) would work too..

Rob Beard (rob-esdelle) wrote :

I also had the same problem, although I found this alternative to removing the .prerm file...

http://blog.ixti.ru/archives/6

I edited the /var/lib/dpkg/info/adobe-flashplugin.prerm file and comments out the line:

VARIANTS="iceape iceweasel mozilla firefox xulrunner midbrowser xulrunner-addons"

One more alternate work-around: comment out the line that says "set -e". That line tells the script to exit on error whenever any regular command fails. Commenting out just this line means that the update-alternatives calls that work still get run, and those that don't work don't also cause removal to fail.

Changed in adobe-flashplugin (Ubuntu):
status: New → Confirmed
Ejderha (timjames001) wrote :

Thanx spbrereton the suggestion fixed my problem as well

nichole (niccirose612) wrote :

well I didn't get my problem fixed I have to redo my whole system!! and lose everything I had on the last system but i'm glad the problem is no longer there!!!

nicolas loyer (nicolas-loyer) wrote :

Solved !!! thank u
I confirm - running as root:
rm /var/lib/dpkg/info/adobe-flashplugin.prerm

thanks

I confirm, running sudo rm /var/lib/dpkg/info/adobe-flashplugin.prerm the problem are solved.

rchristy1 (rchristy9) wrote :

I had this same problem and none of the above helped. I wound up running

"update-manager -d" (without the quotes) in the command box. Update Manager should open up and tell you: New distribution release '9.xx' is available. Click Upgrade and follow the on-screen instructions

This made the initial flash problem go away and then I ran the following in the the terminal and all is good now.

~$ sudo apt-get install flashplugin-installer

alaixi (alaixih) wrote :

the solution is : sudo dpkg --remove --force-remove-reinstreq adobe-flashplugin

found on french ubuntu forum answer given by jean phi 43.

After you can install flash player non free i guess.

msebolino (mike-sebolz) on 2009-11-24
Changed in adobe-flashplugin (Ubuntu):
assignee: nobody → msebolino (mike-sebolz)
Changed in adobe-flashplugin (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Confirmed

removing the prerm file worked on my netbook!
in the root terminal: rm /var/lib/dpkg/info/adobe-flashplugin.prerm
then, update flashplugin and restart.
thanks!

This was fixed in the latest adobe-flashplugin package.

Changed in adobe-flashplugin (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.