Have Flash recommend libwebkit2gtk-4.0-37-gtk2

Bug #1689313 reported by Jeremy Bicha on 2017-05-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
adobe-flashplugin (Ubuntu)
Undecided
Unassigned
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Please have flashplugin-installer and adobe-flashplugin recommend libwebkit2gtk-4.0-37-gtk2.

That package is needed for GTK3 Webkit2 browsers like Epiphany to use Flash.

Of course, the alternative is to have Epiphany recommend libwebkit2gtk-4.0-37-gtk2 itself (that is what was done in Ubuntu 17.04; before that, webkit itself recommended the gtk2 version). But that's not entirely right either since the only thing Epiphany needs the gtk2 support for is for Flash and Epiphany's package does not recommend Flash.

Moving this dependency would make it easier to have a computer without gtk2 and it would make it more obvious what exactly requires gtk2 (LP: #1585903)

libwebkit2gtk-4.0-37-gtk2 is currently in universe but its source is in main. It was in main before webkit stopped recommending it in 17.04.

Jeremy Bicha (jbicha) on 2017-05-08
summary: - Recommend libwebkit2gtk-4.0-37-gtk2
+ Have Flash recommend libwebkit2gtk-4.0-37-gtk2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers