message timestamps are too verbose

Bug #619932 reported by Nicolò Chieffo
130
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Adium Theme Ubuntu
Fix Released
Undecided
Unassigned
Ayatana Design
New
Undecided
Unassigned
adium-theme-ubuntu (Ubuntu)
Fix Released
Low
Unassigned
Declined for Maverick by Sebastien Bacher

Bug Description

Description: In Maverick the adium-theme had accepted a few patches and a change went in which caused every chat message to show date, time and even seconds

rationale: if this bug is not fixed its a major annoyance for a user perspective as no body wanna know the date on every message they type. the other problem is that when someone reduces the width of the chat window a very weired type of text formatting is seen. (image in comment#9) this bug should be fixed for a better chat experience in Ubuntu. some people on ubuntuforums.org are complaining too http://ubuntuforums.org/showthread.php?t=1555651

Note: it does not change anything for 'previous conversations' in empathy

Related branches

Revision history for this message
Nicolò Chieffo (yelo3) wrote :
summary: - messag timestamps are too verbose
+ message timestamps are too verbose
tags: added: patch
kyleabaker (kyleabaker)
Changed in adium-theme-ubuntu (Ubuntu):
status: New → Confirmed
Revision history for this message
kyleabaker (kyleabaker) wrote :

Screenshot of the theme where the time stamp is too long and more description:
http://ubuntuforums.org/showthread.php?t=1555651

Revision history for this message
Omer Akram (om26er) wrote :

testing the patch if it works we can get someone to sponser ;-)

Changed in adium-theme-ubuntu (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Omer Akram (om26er) wrote :
Revision history for this message
Omer Akram (om26er) wrote :

+1 for the patch. live chat only shows the current time and if you see previous conversations you see the date and time

Revision history for this message
David J. Lennon (david-justsomeboy) wrote :

deb build works brilliantly! all now as expected, time showing only.

Revision history for this message
Omer Akram (om26er) wrote :

this should be fixed for maverick for a better chat experience

Changed in adium-theme-ubuntu (Ubuntu):
status: Confirmed → Triaged
Changed in adium-theme-ubuntu:
status: New → Confirmed
assignee: nobody → Ken VanDine (ken-vandine)
Revision history for this message
Omer Akram (om26er) wrote :

will there have to be a UIFe for this patch to get in?

Revision history for this message
Omer Akram (om26er) wrote :
description: updated
Changed in adium-theme-ubuntu (Ubuntu):
status: Triaged → New
summary: - message timestamps are too verbose
+ [UIFe] message timestamps are too verbose
Revision history for this message
Matthew Pirocchi (matthew-pirocchi) wrote : Re: [UIFe] message timestamps are too verbose

Has there been any progress on this? It's still a problem in Maverick final.

Revision history for this message
Mahyuddin Susanto (udienz) wrote :

i'm try to fix this bug

Revision history for this message
Nicolò Chieffo (yelo3) wrote :
Revision history for this message
Mahyuddin Susanto (udienz) wrote :

Hello Nicolo, thanks for your patch. your patch has awesome! works well and i've uploaded your patch at my merge proposal

Revision history for this message
Omer Akram (om26er) wrote :

we want feedback from ayatana-design on the timestamp behavior

Changed in adium-theme-ubuntu (Ubuntu):
importance: Medium → Low
Revision history for this message
Sebastien Bacher (seb128) wrote :

let's open an ayatana design since Ken said he wants to get design input on the change, not accepting the maverick sru task either since would be an ui freeze break, we can reconsider once there is an update in natty if required though

Revision history for this message
Scott Kitterman (kitterman) wrote :

Unsubscribing ubuntu-release since there is no release team action needed now.

Changed in adium-theme-ubuntu:
assignee: Ken VanDine (ken-vandine) → nobody
summary: - [UIFe] message timestamps are too verbose
+ message timestamps are too verbose
Changed in adium-theme-ubuntu:
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package adium-theme-ubuntu - 0.3.1-0ubuntu1

---------------
adium-theme-ubuntu (0.3.1-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Shorten the timestamp display (Nicolò Chiffo) (LP: #619932)
 -- Ken VanDine <email address hidden> Wed, 15 Dec 2010 16:53:41 -0500

Changed in adium-theme-ubuntu (Ubuntu):
status: New → Fix Released
Revision history for this message
Dylan McCall (dylanmccall) wrote :

This is still showing seconds and messages in the history have the same very complex format as before. Is that correct?
(Should we at least consider a more natural day / month name format like “28 Dec” instead of 10-12-28?).

With the seconds it still feels pretty noisy and unnecessary, particularly when the full date is shown with older messages.

Revision history for this message
Gavin Chan (bitrevo) wrote :

I still have this problem in natty with ubuntu theme.

My LANG env: LANG=en_HK.UTF-8
My adium-theme-ubuntu package version: 0.3.1-0ubuntu1

Revision history for this message
Gavin Chan (bitrevo) wrote :

Sorry, please ignore my previous message, it's my configure problem.
I can confirm that it's fixed on package version 0.3.1-0ubuntu1.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers