New messages do not show in Empathy

Bug #1235472 reported by Jeb E. on 2013-10-04
300
This bug affects 87 people
Affects Status Importance Assigned to Milestone
adium-theme-ubuntu (Ubuntu)
Medium
Unassigned
Xenial
Medium
Ken VanDine

Bug Description

I send a message to a friend (using my Google account), close that particular chat window, and when I receive a notification on my system stating he or she replied, I go back to Empathy and click back on the user's name.
It opens up the same chat thread, but with his or her comments nowhere to be found.

I can't seem to see what the issue may be :/

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: empathy 3.8.4-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
Uname: Linux 3.11.0-11-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Fri Oct 4 17:09:12 2013
InstallationDate: Installed on 2013-10-04 (0 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Beta amd64 (20130926)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

[Impact]

 * Breaks chat view for the chat history

[Test Case]

 * Start a chat with a friend and close the window
 * After being notified you received a reply, open the chat window to see the reply
 * Verify you see your previous message and the reply

[Regression Potential]

 * Chat might not be rendered is the worse case, which is the current case in 16.04. So no regression potential.

Related branches

Jeb E. (jebeld17) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Leonid Evdokimov (darkk) wrote :

Alike issue here, here is the test-case:

I receive a message from a person not in my contact list via XMPP for the first time (no history exists).
telepathy-indicator shows new message.
I click a line in the indicator.
New chat tab is opened in the empathy-chat with the contact.

BUG: No messages are shown in the tab at all — new messages should be shown
BUG: window title shows "(-1 unread)" — that's nonsense :)
BUG: unread-messages icon does not disappear even in focus is in the tab — that may be another simptom of the bug.

If I look at "Previous conversations" at the moment I see new messages.
If I close the tab and reopen with Ctrl-Shift-Tab it I see new messages.

I have empathy 3.8.4-1ubuntu1

Leonid Evdokimov (darkk) wrote :

The bug is also reproduced if the person is not in contact list, but some chat history exists.
BUG: In this case I see no __new__ messages in the chat tab (only old messages from the tail of the history are displayed).
Other symptoms are same.

Changed in empathy (Ubuntu):
importance: Undecided → High

I am experiencing this bug with Empathy 3.8.4, Ubuntu 13.10.

The message window shows "-1 Unread" or some other negative number, in the title bar.

Also, in the contacts menu (blue message indicator when messages available), clicking on the conversation does not bring the Empathy window to focus.

It probably is, but the previous bug is not done anyway.

The bug is added on Gnome bugzilla - https://bugzilla.gnome.org/show_bug.cgi?id=724791

Todd (dudemansomebody) wrote :

Is this also a duplicate of bug #1019609 ?

I am having this same problem, cant recieve initial message from another user unless i open their box, close it, and reopen it.

Ubuntu 13.10, Empathy 3.8.4

This bug is still available in empathy 3.8.6 (ubuntu 14.04)

This was marked as a duplicate of Bug #1261060, but is still present in 3.8.6-0ubuntu9.1 in which that bug was supposedly fixed.

Benjamin Xiao (ben-r-xiao) wrote :

Can confirm that this still happens in 14.04. This app is completely broken and it has been broken since 13.04. How is this even acceptable for release?

William (banasura) wrote :

I also confirm this happens in 14.04...

Łukasz Fidosz (virhilo) wrote :

I'm also confirming this happening in 14.04, which is kind of sad...

ls (litos) wrote :

I confirm this for Ubuntu 14.04.1

gorun (gorun) wrote :

same here :
# lsb_release -d
Description: Ubuntu 14.04.1 LTS

empathy 3.8.6-0ubuntu9.1 (up2date)

way to reproduce is exactly same as Leonid Evdokimov described. I do have history for all my contact as this account in a professional one this 9 years. Bug is specific to ubuntu as it works without any problem on debian 6&7 amd64 with identical home folder.

cristian (mataoanu-cristian) wrote :

When I receive a message from a yahoo user that I don't have a chat window open with, I see the notification, but when it opens the window it is not showing. I have to close and open again.

This is a realy annoing bug. I had ubuntu 12.04 and everithing was well. I delayed the upgrade e few months and this is still not asigned for a fix. I thought LTS was all about stability.

cristian (mataoanu-cristian) wrote :

I forgot to mention, i upgraded from 12.04 to 14.04

14.04.1 and here we are.

alfar (crunching-karma) wrote :

14.10 the same issue

ls (litos) wrote :

Any updates?

Richard Pendlebury (rich5851) wrote :

Still the same issue. 14.04.3 what the point of LTS if no fix?

Julie L (julie-larson42) wrote :

Still experiencing this issue. Ubuntu 15.04 and Empathy 3.12.9!
Possible workaround by changing the theme (to boxes, clean).
Any status???

Andrej Shadura (andrew.sh) wrote :

Found the cause of the bug.

Andrej Shadura (andrew.sh) wrote :

The bug is in package adium-theme-ubuntu, switch to a theme different than Ubuntu (say, Classic) as a workaround. I'll provide a fix in a couple of minutes.

Andrej Shadura (andrew.sh) wrote :

Here's the patch fixing the issue. There's a couple of other issues with he theme, I'm not addressing them here.

Changed in adium-theme-ubuntu:
status: New → Confirmed

The attachment "Patch for adium-theme-ubuntu 0.3.4" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Nicolas Delvaux (malizor) wrote :

Thanks Andrew, your patch seems to work for me.
Maybe you should provide a branch with your patch and/or a debdiff?
I would be great if this long standing bug was finally fixed out of the box on Ubuntu 16.04.

Andrej Shadura (andrew.sh) wrote :

Another patch for adium-theme-ubuntu, fixing a warning and an occasional failure to display old messages.

Changed in adium-theme-ubuntu (Ubuntu):
status: New → Confirmed
Andrej Shadura (andrew.sh) wrote :

Following the advice cjwatson gave me, here's the debdiff of my branch (slightly updated).

Andrej Shadura (andrew.sh) wrote :

Any news on this one please?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package adium-theme-ubuntu - 0.3.4-0ubuntu2

---------------
adium-theme-ubuntu (0.3.4-0ubuntu2) yakkety; urgency=medium

  * Non-maintainer upload.
  * Switch to 3.0 (quilt) source package format.
  * Update the theme to work with recent Empathy (LP: #1235472).
  * Use dh-python, update Standards-Version.
  * Patch setup.py to install things into the right places.

 -- Andrew Shadura <email address hidden> Mon, 11 Apr 2016 10:53:43 +0200

Changed in adium-theme-ubuntu (Ubuntu):
status: Confirmed → Fix Released
no longer affects: empathy (Ubuntu)
tags: removed: chrome empathy gnome3-ppa google hangouts im ubuntu
affects: adium-theme-ubuntu → ubuntu-translations
Changed in adium-theme-ubuntu (Ubuntu):
importance: Undecided → Medium
no longer affects: ubuntu-translations
tags: added: trusty xenial
description: updated
Changed in adium-theme-ubuntu (Ubuntu Xenial):
status: New → Triaged
Changed in adium-theme-ubuntu (Ubuntu Xenial):
importance: Undecided → Medium
summary: - New messages do not show
+ New messages do not show in Empathy
Changed in adium-theme-ubuntu (Ubuntu Xenial):
assignee: nobody → Ken VanDine (ken-vandine)
status: Triaged → In Progress

Hello Jeb, or anyone else affected,

Accepted adium-theme-ubuntu into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/adium-theme-ubuntu/0.3.4-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in adium-theme-ubuntu (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Nicolas Delvaux (malizor) wrote :

I confirm this bug is fixed on Xenial with adium-theme-ubuntu 0.3.4-0ubuntu1.1.
Many thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package adium-theme-ubuntu - 0.3.4-0ubuntu1.1

---------------
adium-theme-ubuntu (0.3.4-0ubuntu1.1) xenial-proposed; urgency=medium

  [ Andrew Shadura ]
  * Update the theme to work with recent Empathy (LP: #1235472).

 -- Ken VanDine <email address hidden> Fri, 06 May 2016 11:39:27 -0400

Changed in adium-theme-ubuntu (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for adium-theme-ubuntu has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.