The latest update in Adept suggests removing Emacs.

Bug #162600 reported by Mats Palmgren on 2007-11-14
4
Affects Status Importance Assigned to Milestone
adept (Ubuntu)
Undecided
Unassigned

Bug Description

The latest update in Adept suggests removing Emacs.
I did not request this change, I'm using emacs and I definitely
don't want to remove it. Why is Adept suggesting it should be
removed?

Mats Palmgren (mats-palmgren) wrote :
Juan Carlos Torres (jucato) wrote :

Are you still experiencing this problem? Could you provide more information on this?

Marking this bug as Incomplete since it needs updated information. Please feel free to reopen with new information. Thanks for your efforts to make Kubuntu rock. :)

Changed in adept:
status: New → Incomplete
Mats Palmgren (mats-palmgren) wrote :

> Are you still experiencing this problem?

Yes, every time I open "Adept Updater" and click "Fetch List of Updates" it
suggests I should remove the emacs packages as shown in the screenshot.
It's really annoying since I have to manually "Cancel changes" on these
packages every time I apply the updates.

> Could you provide more information on this?

Tell me what you need.

Changed in adept:
status: Incomplete → New
Yuriy Kozlov (yuriy-kozlov) wrote :

I would say this is a bug in the emacs packaging and has nothing to do with Adept, but installing emacs worked fine for me on Gutsy.
What version of Ubuntu are you using and what repositories do you have enabled? What version of emacs is adept trying to upgrade/remove?

Changed in adept:
status: New → Incomplete
Mats Palmgren (mats-palmgren) wrote :

Attaching /etc/apt/sources.list in case it helps...

Mats Palmgren (mats-palmgren) wrote :

> I would say this is a bug in the emacs packaging and has nothing to do with Adept

Uhm, ok, so should you perhaps reassign this bug to those responsible?

> but installing emacs worked fine for me on Gutsy

Good for you, it still doesn't explain why Adept is suggesting I should remove the latest
version of Emacs. There *IS* a bug here.

> What version of Ubuntu are you using

Kubuntu 7.10 (Gutsy), x86_64. All updates installed.

> What version of emacs is adept trying to upgrade/remove?

Package: emacs
State: installed
Automatically installed: yes
Version: 22.1-0ubuntu5
Priority: optional
Section: editors
Maintainer: Ubuntu Core Developers <email address hidden>
Uncompressed Size: 36.9k
Depends: emacs22-gtk | emacs22 | emacs22-nox
Provides: editor, emacsen, info-browser, mail-reader, news-reader
Description: The GNU Emacs editor (metapackage)
 GNU Emacs is the extensible self-documenting text editor. This is a metapackage which will always depend on the latest Emacs release.

Mats Palmgren (mats-palmgren) wrote :

I got tired of waiting for a fix here so I just let Adept go ahead and remove it
and then reinstalled it with a quick "sudo apt-get install emacs22" and that
seems to have fixed it. Adept isn't suggesting it should be removed anymore.

Yuriy Kozlov (yuriy-kozlov) wrote :

emacs22-gtk is in universe and it seems you don't have gutsy-security and gutsy-updates enabled for universe in your sources.list, so that might have been the problem. Since it's working for you now we can't do any further debugging, so I am closing this bug. Feel free to reopen it if you run into the problem again.

Changed in adept:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers