version-upgrade doesn't upgrade to gutsy on adept-manager

Bug #146499 reported by Loye Young on 2007-09-28
2
Affects Status Importance Assigned to Milestone
adept (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: adept-manager

I'm on Kubuntu Feisty and want to join the beta testing, but I get no joy on version-upgrade.

Followed the instructions on help.ubuntu.com for Kubuntu. Used adept to manage repositories, Update.

I got distracted, went away, came back. Adept-updater was lit up, so I absent-mindedly fired it off. It updated a few packages, mostly apache2 and related packages as I recall.

Then I remembered what I was doing
<code>
kdesu "adept-manager --version-upgrade"
</code>

Then I Adept opens, I get the Version Upgrade button. Click. Go though the wizard. Says it's finished, but I'm still on feisty, and no packages to upgrade.

sources.list still shows all the repositories being feisty.

I should mention that I use apt-mirror to maintain a mirror on the network, which is where my repositories point to. E.g.,
"deb http://mirror.iycc.biz/us.archive.ubuntu.com/ubuntu feisty main restricted universe multiverse"
etc. . . .

Perhaps this has something to do with the problem?

Anyway, whatever I can do to help the cause, I'm here.

Loye Young

Update:

This morning, I decided to walk through the upgrade again, to see if I could
figure out anything more about why it wouldn't upgrade.

I first ran plain old adept manager. No packages to upgrade. Closed the app.

Then I ran "adept_manager --version-upgrade". Wonder of wonders, it works now.
Dunno what made the difference between yesterday and today. Perhaps upgrading
requires opening adept after running the initial version-upgrade, but I can't
imagine why that would be. Perhaps the upgrade utility was updated by Ubuntu
overnight. But I'm only speculating. All I see now is that my system is
happily upgrading even as I type.

Loye

Marco Maini (maini10) wrote :

Thanks. I close this report because you said that the problem is solved. Feel free to report any other bug.

Changed in adept:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers