Adept couldn't open debtags database

Bug #121456 reported by Jannick Kuhr
42
Affects Status Importance Assigned to Milestone
adept (Ubuntu)
Critical
Unassigned
Gutsy
Critical
Unassigned

Bug Description

Binary package hint: apt

The new version of apt in Gutsy (0.7.2ubuntu2) or one of its dependencies forces the uninstallation of Adept. This is probably not intended.

Revision history for this message
Marco Maini (maini10) wrote : Re: New apt version forces uninstallation of adept

Confirm this problem. It seems that Adept has broken dependencies with package libapt-pkg-libc6.4-6-3.53, that is required to install debtags. Adept is not installable without debtags.
Thanks for this report.

Changed in apt:
status: New → Confirmed
Revision history for this message
Marco Maini (maini10) wrote :

Problem wiht dependencies seems fixed with new version of adept, debtags and other libraries from Debian.
Try "sudo apt-get install adept" to reinstall it.
Please report if you experience further problem.

Revision history for this message
joey (joeyubt-deactivatedaccount) wrote :

I have did the above but still get "The APT Database could not be opened! This may be caused by incorrect APT configuration or some similar problem. Try running apt-setup and apt-get update in terminal and see if it helps to resolve the problem". Running update and setup does not help.

Revision history for this message
Marco Maini (maini10) wrote :

Confirm also this issue.

Revision history for this message
Richard Birnie (rbirnie-deactivatedaccount) wrote : Re: Adept couldn't open APT database

Setting importance to high. I can confirm the 'could not open cache' error and reinstalling adept does not resolve the problem. Adept is completely broken in it's current condition

Changed in adept:
importance: Undecided → High
Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

what happens when you do "apt-get clean"?

I cant reproduce this.

Maini, which part are you confirming? There are two parts of this bug, and the first is definetly fixed.

Changed in adept:
status: Confirmed → Incomplete
Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

Argh. Confirming here. milestoning.

Changed in adept:
status: Incomplete → Triaged
importance: High → Critical
Changed in adept:
status: Triaged → Confirmed
Revision history for this message
SergeyS (ssedreev) wrote :

Confirming the defect. I've just upgraded to Gutsy... when I'm trying to run adept_manager I'm getting such an error message.

Jonathan Riddell (jr)
Changed in adept:
assignee: nobody → mvo
Revision history for this message
Michael Vogt (mvo) wrote :

It looks like the new debtags changed something that adept is not expecting, this is what I see in gdb:

kapture::PkgSystem::PkgSystem()
terminate called after throwing an instance of 'Tagcoll::SystemException'
  what(): No such file or directory opening index file /root/.debtags//pkgidx.idx

Changed in adept:
assignee: mvo → nobody
Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

This is fixed now, with reverting back to an older debtags.

Changed in adept:
status: Confirmed → Fix Released
Revision history for this message
Markus Strobl (mstrobl2) wrote :

This bug is back as of 07/20. I did an update 07/19 and did not have a problem. After doing todays update I'm getting the "Could not open debtage database". apt-get update works but will not fix problem. Command line apt-get install works.

Distribution: Gutsy

Installed versions:

Get:1 http://us.archive.ubuntu.com gutsy/main adept-common 2.1.2ubuntu28 [144kB]
Get:2 http://us.archive.ubuntu.com gutsy/main adept-manager 2.1.2ubuntu28 [737kB]
Get:3 http://us.archive.ubuntu.com gutsy/main adept-installer 2.1.2ubuntu28 [787kB]
Get:4 http://us.archive.ubuntu.com gutsy/main adept-updater 2.1.2ubuntu28 [696kB]
Get:5 http://us.archive.ubuntu.com gutsy/main adept-notifier 2.1.2ubuntu28 [272kB]
Get:6 http://us.archive.ubuntu.com gutsy/main adept-batch 2.1.2ubuntu28 [324kB]

Get:1 http://us.archive.ubuntu.com gutsy/main debtags 1.7.3ubuntu1 [603kB]

Revision history for this message
Markus Strobl (mstrobl2) wrote :

As a workaround I found that synaptic works.

Revision history for this message
Marco Maini (maini10) wrote :

The issue reported by Markus Strobl is confirmed with the version released today of debtags.

Changed in adept:
status: Fix Released → Confirmed
Revision history for this message
3vi1 (launchpad-net-eternaldusk) wrote :

Just another confirmation: I installed GG tribe3 to an ix86 machine today and ran into this same bug. Using synaptic until debtags and adept are in sync.

Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :
Changed in adept:
assignee: nobody → hobbsee
status: Confirmed → In Progress
Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

libapt-front fixed, this will fix itself in the next day or so.

Changed in adept:
assignee: hobbsee → nobody
status: In Progress → Fix Committed
Revision history for this message
Markus Strobl (mstrobl2) wrote :

Confirm fix. Everything's working again.

In case someone is stuck with the broken adept, to fix it open a console and type:

sudo apt-get update

After it finishes:

sudo apt-get upgrade

Revision history for this message
S@H (hernandez-sergio-a) wrote : Re: [Bug 121456] Re: Adept couldn't open debtags database

On Sunday 22 July 2007 08:14:58 Markus Strobl wrote:
> Confirm fix. Everything's working again.
>
> In case someone is stuck with the broken adept, to fix it open a console
> and type:
>
> sudo apt-get update
>
> After it finishes:
>
> sudo apt-get upgrade

Markus,
I already unistall Kubuntu 7.10 Tribe 3.
Right now I'm testing Edubuntu 7.10 Tribe 3.

Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

Hooray!

Thanks for bringing this up in #kubuntu-devel too, guys!

Changed in adept:
status: Fix Committed → Fix Released
Revision history for this message
mmxbass (mmxbass) wrote :

Problem is back yet again for me and far from fixed.
Here's the rundown of the error.

Update followed by upgrade has been tried and it's simply not happening at this point.

The following packages have unmet dependencies:
  adept: Depends: adept-manager but it is not going to be installed
         Depends: adept-installer but it is not going to be installed
         Depends: adept-updater but it is not going to be installed
         Depends: adept-notifier but it is not going to be installed
         Depends: adept-batch but it is not going to be installed
E: Broken packages

The following packages have unmet dependencies:
  adept-manager: Depends: libapt-pkg-libc6.6-6-4.4 but it is not installable
E: Broken packages

Package libapt-pkg-libc6.6-6-4.4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libapt-pkg-libc6.6-6-4.4 has no installation candidate

Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

no, that's a completely different bug.

https://bugs.launchpad.net/ubuntu/+source/adept/+bug/130470

It happens each time that apt has an api change - just dist-upgrade.

Revision history for this message
nigelbarker (nigel-hardwick) wrote :

Hi

Getting the error :-

apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies.
  apt-utils: Depends: libapt-pkg-libc6.6-6-4.4 but it is not installable
  aptitude: Depends: libapt-pkg-libc6.6-6-4.4 but it is not installable
E: Unmet dependencies. Try using -f

This could well be down to finger trouble (I am in no sense an expert user!) but I'd welcome a clue how work on the problem.

#cat /etc/apt/sources.list
deb http://ftp.uk.debian.org/debian/ etch main
deb-src http://ftp.uk.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib

Cheers

Nige

Revision history for this message
nigelbarker (nigel-hardwick) wrote :

Oh, in case it helps :-

apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies...Done
The following packages will be REMOVED
  apt-utils aptitude tasksel tasksel-data
0 upgraded, 0 newly installed, 4 to remove and 8 not upgraded.
12 not fully installed or removed.
Need to get 0B of archives.
After unpacking 13.1MB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... dpkg: error processing apt-utils (--remove):
 failed in buffer_read(fd): files list for package `procps': Invalid argument
Errors were encountered while processing:
 apt-utils
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Nige

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions