adduser not allowing underscore "_" in a username

Bug #341698 reported by Jerone Young on 2009-03-12
4
Affects Status Importance Assigned to Milestone
adduser (Ubuntu)
Undecided
Steve Langasek

Bug Description

adduser currently is not allowing underscores "_" in usernames. This is something supported by all other distributions, but appears somewhere regressed in debian.

Jerone Young (jerone) on 2009-03-12
Changed in adduser:
assignee: nobody → vorlon
description: updated
Todd Bradshaw (snooptodd) wrote :

Thanks for reporting a this bug.
To be considered complete you need to include with the bug report:

The version of Ubuntu
The version of the package
The actions taken to produce the problem
Whether or not it is possible for the reporter to reproduce the bug
The expected result of these actions
The actual result of these actions

Changed in adduser:
status: New → Incomplete
Steve Langasek (vorlon) wrote :

This bug was filed at the request of a developer. It already includes all the information we need.

Changed in adduser:
status: Incomplete → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package adduser - 3.110ubuntu3

---------------
adduser (3.110ubuntu3) jaunty; urgency=low

  * Fix the default username regexp to allow underscores. LP: #341698.

 -- Steve Langasek <email address hidden> Thu, 19 Mar 2009 16:50:59 +0000

Changed in adduser:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers